Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 2893

Summary: ┬┐How I install a binary package from other distribution?
Product: [OLD] Docs-user Reporter: Pedro Baez <pedrobz>
Component: Gentoo Linux FAQAssignee: Sherman Boyd (meekrob) (RETIRED) <meekrob>
Status: RESOLVED FIXED    
Severity: enhancement CC: marc.provencher, vapier
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Pedro Baez 2002-05-21 11:20:36 UTC
I want to install binary packages from other distributions (debian, red hat, 
etc.) but i don't see anyway to do that!
Comment 1 SpanKY gentoo-dev 2002-07-03 20:08:43 UTC
depends ;)
debian ... atm there is no way to do it automatically ... just do it by hand
redhat (well, all rpm based distros) ... `emerge rpm` and do it like normal
Comment 2 SpanKY gentoo-dev 2002-08-04 18:40:36 UTC
does the bug reporter feel his problem has been solved ?
does anyone think these kind of things need to be addressed ?
(after all, i dont know of anyone who tries to install .deb's on anything but 
debian ...)
Comment 3 Pedro Baez 2002-08-05 03:58:08 UTC
Yes. with the rpm you can install from red hat, and debian normaly install only
in debian, but what if i have a package in debian format that i want to install,
what if is other format not know?. I think the solution is include in gentoo the
alien package which take care about all of these.
Comment 4 SpanKY gentoo-dev 2002-08-05 20:45:48 UTC
*** Bug 4562 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2002-08-05 20:47:39 UTC
heh, does anyone wanna take a stab at creating something like this ?
i know i dont want to, plus i think seemant said it best
'why do we want to be like everyone else?' (or it was something like that ... i 
dont log irc :P)
Comment 6 SpanKY gentoo-dev 2002-09-05 14:55:15 UTC
rpm will handle rpm-packages

i dont think we'll ever make a util to handle installin of .deb packages 
since .deb packages are made with assumptions (binary locations, library 
locations, filesystem setup, etc...), and in order to make gentoo compatible 
with .deb setups, it would require us to mirror how debian does things (which 
if gentoo does that, i'm going back to slackware ;])