Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 289250

Summary: www.g.o hits could help translators and users
Product: Doc Translations Reporter: Christophe LEFEBVRE <chtof62>
Component: OtherAssignee: Gentoo Infrastructure <infra-bugs>
Status: RESOLVED OBSOLETE    
Severity: enhancement CC: alex_y_xu, docs-team
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Christophe LEFEBVRE 2009-10-15 20:59:32 UTC
It's not easy for translators to choice an useful article to translate. Then I suggest a web page with the percentage of readings of each article among all the articles. It can be a way to translate the more urgent translations.

Reproducible: Always
Comment 1 nm (RETIRED) gentoo-dev 2009-10-16 04:00:41 UTC
http://www.gentoo.org/proj/en/gdp/tests/topdocs.xml - hasn't been updated in a while

http://gentoo.neysx.org/mystuff/trads/fr/trads-fr.xml - this is the trads page for the French language, to show how up-to-date the translations are. See http://gentoo.neysx.org/mystuff/trads/doc/trads-doc.xml, which explains the reason for trads.xml.

Also, you must read the translators howto:

http://www.gentoo.org/proj/en/gdp/doc/translators-howto.xml

This page tells you which documents are critical.
Comment 2 Camille Huot (RETIRED) gentoo-dev 2009-10-16 08:53:11 UTC
Josh, Xavier doesn't maintain the French docs, the trads-fr.xml link you've provided is obsolete.

BTW, I agree with you that topdocs isn't up to date.

Christophe, docs to translate in French are sorted according to the topdocs in my various trads pages (http://dev.gentoo.org/~cam/gentoo-doc-fr/) : the first is the most "urgent".
Comment 3 Xavier Neys (RETIRED) gentoo-dev 2009-10-16 16:41:59 UTC
empty comment
Comment 4 Xavier Neys (RETIRED) gentoo-dev 2009-10-16 16:47:00 UTC
Data became unavailable so topdocs became unupdated.

Hits would have to be made available again.
Apache access logs are OK. If I could get them from a single box, combined or in separate logs, that would be even better because I would not have to know which servers act as www.g.o at any given moment.
Comment 5 Naoaki Shindo (RETIRED) gentoo-dev 2009-10-27 13:44:41 UTC
topdocs is good for translator.
It gives hints and priority for choosing the doc should be translated.
Comment 6 Xavier Neys (RETIRED) gentoo-dev 2009-11-03 17:35:50 UTC
Any ETA, even long-term on this?
Just wondering if it's worth spending time on getting ready to process them. Thanks.
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-11-03 18:44:37 UTC
Post-Christmas probably. Trying for Bugzilla3 before that.
Comment 8 nm (RETIRED) gentoo-dev 2010-05-14 22:53:12 UTC
Any progress?

Note that Xavier's pages are dead and gone from the internet entirely. All that can be done is get stuff working for the topdocs page in the GDP projspace. If infra doesn't want to get this rolling again on their side, feel free to close the bug.

Note, however, that while it was available, topdocs was a good resource for translators and the rest of the GDP alike, as well as all other would-be contributors.
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-05-14 23:46:27 UTC
we're making some progress on working towards it, but it might wait a bit longer for other hardware.
Comment 10 Alex Xu (Hello71) 2013-08-28 15:39:31 UTC
Update: Most documentation is now at http://wiki.gentoo.org/.

Translators should see the help at http://wiki.gentoo.org/wiki/Help:Translating#For_Anyone:_Becoming_a_translator.
Comment 11 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2014-04-26 11:59:05 UTC
Is this still needed? Or needed for wiki.g.o? If so, reopen.