Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 288680

Summary: gnome-system-monitor-2.26.2 needs glitz and svg use flags in cairo
Product: Gentoo Linux Reporter: Ingo Krabbe <ikrabbe.ask>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED INVALID    
Severity: normal CC: chaseguard, dpblnt
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Ingo Krabbe 2009-10-12 06:58:17 UTC
gnome-system-monitor refused to build against cairomm, as cairomm had unresolved symbols against cario:

/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_svg_get_versions'
/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_svg_surface_create_for_stream'
/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_glitz_surface_create'
/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_svg_version_to_string'
/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_svg_surface_create'
/usr/lib64/libcairomm-1.0.so: undefined reference to `cairo_svg_surface_restrict_to_version'

Reproducible: Always

Steps to Reproduce:
USE="-svg -glitz" emerge -NuD cairo gnome-system-monitor





solution is to add svg and glitz use flags to cairo.  Either a warning message or a dependency fix should be given in gnome-system-monitor-2.26.2.
Comment 1 Rémi Cardona gentoo-dev 2009-10-12 07:05:12 UTC
Please rebuild cairomm and gtkmm. gnome-system-monitor should build fine after that.

Thanks
Comment 2 Ingo Krabbe 2009-10-13 12:24:21 UTC
Thats wrong:  As I already commented the solution is not to rebuild cairomm and gtkmm but to change use flags for cairo.

This change is not obvious for people who don't know about missing symbols during link phase.  So I recommend to add the use dependencies to the package.
Comment 3 Rémi Cardona gentoo-dev 2009-10-13 15:17:59 UTC
No it's not wrong. If you change cairo's USE flags, you'll need to rebuild cairomm and gtkmm. And there's nothing we can do in that case, unfortunately.
Comment 4 Pacho Ramos gentoo-dev 2010-09-30 16:26:03 UTC
*** Bug 339263 has been marked as a duplicate of this bug. ***
Comment 5 Ludovic Bellier 2010-10-02 12:08:30 UTC
(In reply to comment #1)
> Please rebuild cairomm and gtkmm. gnome-system-monitor should build fine after
> that.

This works fine for me.

Thanks
 

Comment 6 Ingo Krabbe 2010-10-02 13:39:08 UTC
(In reply to comment #5)
> (In reply to comment #1)
> > Please rebuild cairomm and gtkmm. gnome-system-monitor should build fine after
> > that.
> 
> This works fine for me.
> 

Yes, I assume this is solved now,as cairomm has a better depend statement on cairo (asking for the svg flag), so that a -D(eep) update will automgically rebuild cairomm, which is the desired behaviour.
Comment 7 Pacho Ramos gentoo-dev 2010-10-16 15:44:44 UTC
*** Bug 341233 has been marked as a duplicate of this bug. ***