Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 288218

Summary: dev-games/clanlib version bump
Product: Gentoo Linux Reporter: proDOOMman <proDOOMman>
Component: [OLD] GamesAssignee: Gentoo Games <games>
Status: RESOLVED FIXED    
Severity: enhancement CC: cmhoward, denilsonsa, kensington, niko.bockerman, pacho
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.clanlib.org/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: clanlib ebuild
ClanLib ebuild
clanlib-2.3.4-bump.patch
clanlib-2.3.4-autotools.patch

Description proDOOMman 2009-10-08 16:19:34 UTC
dev-games/clanlib-2.0.4 released

Reproducible: Always

Steps to Reproduce:
Comment 1 proDOOMman 2009-10-08 16:20:38 UTC
Created attachment 206456 [details]
clanlib ebuild
Comment 2 Mr. Bones. (RETIRED) gentoo-dev 2009-10-08 20:21:32 UTC
This can't be slotted 2 since it collides with files from the current version of clanlib.
Comment 3 proDOOMman 2009-10-09 05:15:03 UTC
Created attachment 206496 [details]
ClanLib ebuild

Oh, sorry. I doesn't test collisions with 0.8 version
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2009-10-09 06:08:14 UTC
looks like bug #154513 still isn't fixed.
Comment 5 Pacho Ramos gentoo-dev 2009-11-08 16:52:02 UTC
You could maybe take a look on fedora's job for trying to install clanlib-1* and clanlib-2 in parallel:
http://cvs.fedoraproject.org/viewvc/rpms/ClanLib/devel/ClanLib.spec?revision=1.23&view=markup
http://cvs.fedoraproject.org/viewvc/rpms/ClanLib1/devel/ClanLib1.spec?revision=1.1&view=markup
Comment 6 Christopher Howard 2009-12-03 08:29:51 UTC
How much more needs to be done to make this ebuild work?  (I don't know anything about ebuilds, I'm just a developer using clanlib 2.0.) Is it something I could do? I looked at the ebuild and the obvious thing was that it defines SLOT="0.8" which doesn't make any sense as this is clanlib 2.0.
Comment 7 Niko Böckerman 2009-12-03 09:15:33 UTC
ClanLib version 2.1.0 installs without any file collision with files from ClanLib-0.8.1. Upstream changed filenames a bit in that release so it can be installed to SLOT="2".

Ebuild for version 2.0.4 works fine to install 2.1.0.
Comment 8 Michael Palimaka (kensington) gentoo-dev 2011-12-14 10:04:28 UTC
Created attachment 295787 [details, diff]
clanlib-2.3.4-bump.patch

Changed slot to two major version components, as this is when upstream introduces breaking changes. SDL is no longer part of the core library. Changed USE="mikmod vorbis" -> USE="sound" as clanSound requires both to work.
Comment 9 Michael Palimaka (kensington) gentoo-dev 2011-12-14 10:05:44 UTC
Created attachment 295789 [details, diff]
clanlib-2.3.4-autotools.patch

Patch to avoid breakage if sound is disabled, and to install docs to the correct location for Gentoo.
Comment 10 Tupone Alfredo gentoo-dev 2012-02-06 13:57:36 UTC
Bumped to 2.3.4 Thanks for report and patches