Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 287230

Summary: gnome-base/gnome-control-center: synaptics hal settings are ignored
Product: Gentoo Linux Reporter: Tommaso Pasini <tommaso.pasini>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED WONTFIX    
Severity: normal CC: alexeyp, gentoo-bugs, pacho
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugzilla.gnome.org/show_bug.cgi?id=598820
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Adds tap-to-click button settings, with gconf schema update

Description Tommaso Pasini 2009-10-01 13:16:22 UTC
Starting with gnome-2.27 the settings of my synaptics touchpad have changed even if I didn't do anything. E.g. I had both edge scrolling and two-finger scrolling enabled, two-fingers-tap emulating the middle click, and so on; now I can have edge scrolling or two-finger scrolling, but not both; two-fingers-tap emulates the right click...

Part of the new settings can be seen/set in the "touchpad" tab inside Sistem -> Preferences -> Mouse Preferences, http://www.thinkwiki.org/wiki/File:Screenshot-Mouse_Preferences.png
If I run `hal-find-by-capability --capability input.touchpad` I get '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input'. Running `hal-device /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input` returns

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input'
  input.x11_options.FingerHigh = '30'  (string)
  input.x11_options.VertScrollDelta = '100'  (string)
  input.x11_options.MinSpeed = '0.09'  (string)
  input.x11_options.MaxSpeed = '0.48'  (string)
  input.x11_options.AccelFactor = '0.15'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  input.x11_options.VertTwoFingerScroll = 'true'  (string)
  input.x11_options.VertEdgeScroll = 'true'  (string)
  info.capabilities = { 'input', 'input.touchpad' } (string list)
  info.category = 'input'  (string)
  input.device = '/dev/input/event8'  (string)
  input.product = 'SynPS/2 Synaptics TouchPad'  (string)
  input.x11_options.HorizTwoFingerScroll = 'true'  (string)
  info.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port'  (string)
  info.product = 'SynPS/2 Synaptics TouchPad'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input'  (string)
  input.x11_driver = 'synaptics'  (string)
  linux.device_file = '/dev/input/event8'  (string)
  input.x11_options.SHMConfig = 'true'  (string)
  input.x11_options.TapButton1 = '1'  (string)
  input.x11_options.TapButton2 = '2'  (string)
  input.x11_options.TapButton3 = '3'  (string)
  input.x11_options.Emulate3Buttons = 'yes'  (string)
  input.x11_options.LockedDrags = '0'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio4/input/input8/event8'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port'  (string)
  input.x11_options.MaxTapMove = '220'  (string)
  input.x11_options.PalmDetect = 'yes'  (string)
  input.x11_options.LeftEdge = '1900'  (string)
  input.x11_options.RightEdge = '5000'  (string)
  input.x11_options.TopEdge = '1700'  (string)
  input.x11_options.BottomEdge = '4200'  (string)
  input.x11_options.FingerLow = '25'  (string)
  input.x11_options.MaxTapTime = '180'  (string)
  input.x11_options.CoastingSpeed = '20'  (string)

These are the options I set inside /etc/hal/fdi/policy/11-x11-synaptics.fdi
But if I run `synclient -l` I get

Parameter settings:
    LeftEdge                = 1900
    RightEdge               = 5000
    TopEdge                 = 1700
    BottomEdge              = 4200
    FingerLow               = 25
    FingerHigh              = 30
    FingerPress             = 255
    MaxTapTime              = 180
    MaxTapMove              = 220
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 280
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 100
    HorizScrollDelta        = 100
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 0.09
    MaxSpeed                = 0.48
    AccelFactor             = 0.15
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 29
    EdgeMotionMaxZ          = 159
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 401
    EdgeMotionUseAlways     = 0
    UpDownScrolling         = 1
    LeftRightScrolling      = 1
    UpDownScrollRepeat      = 1
    LeftRightScrollRepeat   = 1
    ScrollButtonRepeat      = 100
    TouchpadOff             = 0
    GuestMouseOff           = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 0
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 2
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 1
    PalmMinWidth            = 10
    PalmMinZ                = 199
    CoastingSpeed           = 20
    PressureMotionMinZ      = 29
    PressureMotionMaxZ      = 159
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 1

Among the options, I'd like to point out that while hal defines
input.x11_options.TapButton1 = '1'  (string)
input.x11_options.TapButton2 = '2'  (string)
input.x11_options.TapButton3 = '3'  (string)

synclient shows
TapButton1              = 1
TapButton2              = 3
TapButton3              = 2

This is clearly wrong, I've never specified the behaviour as shown by synclient, and I don't know how to revert to the old one without disabling SHMConfig. With gnome-2.26 I didn't have this problem.

Reproducible: Always

Steps to Reproduce:
Comment 1 Tommaso Pasini 2009-10-13 16:35:15 UTC
I've been suggested to compile gnome-control-center with the hal USE flag disabled, but the problem persists.
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-10-19 11:50:56 UTC
Experience the same problem since 2.28 upgrade. This is pretty annoying as I can't do right clicks anymore if it overwrites hal settings. There is a good chance upstream doesn't care about hal settings since they are trying to replace it with udev, but they could at least not overwrite already set values by default in the session.

This deserve an upstream bug report if it doesn't exist yet.
Comment 3 Tommaso Pasini 2009-10-19 12:15:00 UTC
Someone already opened it, you can find it here https://bugzilla.gnome.org/show_bug.cgi?id=598820
I already posted a link to this page.

Other ones similar are these:
https://bugzilla.gnome.org/show_bug.cgi?id=578444
https://bugzilla.gnome.org/show_bug.cgi?id=591696
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-11-05 00:10:52 UTC
*** Bug 291819 has been marked as a duplicate of this bug. ***
Comment 5 Tommaso Pasini 2010-01-07 09:59:40 UTC
Created attachment 215496 [details, diff]
 Adds tap-to-click button settings, with gconf schema update

Yuri Khan posted this patch on gnome bugzilla. I modified gnome-settings-daemon ebuild and it works. It's not the complete solution to the problem since it doesn't get back hal settings, but at least now it's possible to use two-finger-tapping for the middle click and three-finger-tapping for the right one.
Comment 6 Alexey Parshin 2010-04-10 03:01:04 UTC
I've discovered something related. On one of my laptops, tap-to-click stopped working in Gnome (but worked in login screen). Tapping in System->Preferences->Touchpad was switched on. The tapping started working after I swithed it on in System->Preferences->Mouse->Touchpad. This is, at the very least, confusing. The touchpad settings must be only in one place.
Comment 7 Tommaso Pasini 2010-04-10 08:25:54 UTC
I think you have gsynaptics installed, and that provides the System->Preferences->Touchpad menu entry; it is deprecated and should be uninstalled.
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-04-12 20:30:07 UTC
This issue is now documented in the tentative migration guide [1]. Closing wontfix since there is nothing we will do to maintain hal compatibility here.

[1] http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.28-upgrade.xml