Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 283050

Summary: xfce4: desktop icons disappeared
Product: Gentoo Linux Reporter: Tobias Jakobi <liquid.acid>
Component: Current packagesAssignee: XFCE Team <xfce>
Status: VERIFIED WORKSFORME    
Severity: normal CC: Sasha.Medvedev
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Tobias Jakobi 2009-08-28 17:01:54 UTC
Hi there,

upon updating world yesterday I'm now missing all my XFCE4 desktop icons. During update I noticed that a lot of xfce packages were remerged.

After emerge finished I restarted X and voila... no more desktop icons. I already checked the settings manager but the desktop icons are activated and ~/Desktop still contains the correct files.

Even the standard icons that can be selected in the settings menu are missing (these are not created from the .desktop files in ~/Desktop).

I already did a google search but didn't but anything that really matched by problem (there were some problems which resulted in missing icons in the desktop context menu, but these are fine for me). I also tried switching the icon set from Rodent to Tango, but that doesn't change anything.

Greets,
Tobias
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2009-08-28 17:16:40 UTC
emerge tango-icon-theme, tangerine-icon-theme, xfce4-icon-theme or gnome-icon-theme... prolly some others will work too, like gartoon
Comment 2 Tobias Jakobi 2009-08-28 17:23:16 UTC
You say "or", so one should suffice, right?

Well, like stated in the entry post I have the Tango icon theme (x11-themes/tango-icon-theme) installed and even though: no icons on the desktop.

Oh yeah, xfce4-icon-theme and the gnome one are also installed. I can select them in the settings manager, log out and restart X - but still no luck.
Comment 3 John Ratliff 2009-08-28 18:40:13 UTC
Same thing happened to me. I fixed it by deleting all my xfce settings from my home directory. Everything in .local, .share, .config. Anything I could find associated with either Xfce or xorg.
Comment 4 Tobias Jakobi 2009-08-29 00:02:39 UTC
I just tried that, however don't have any ~/.share directory. I still cleaned most of the stuff in .local and .config, but still they desktop icons won't appear (and not even the default ones which should be there).
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-29 14:00:33 UTC
Samuli, Can you continue to help here? (I'll be unavailable for bug fixing for $num more days). Thanks.
Comment 6 Tobias Jakobi 2009-08-29 15:57:26 UTC
Just wanted to add that completly removing .local and .config also doesn't change the situation.

etc-update also doesn't mention any config files that need updating.
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2009-09-04 07:28:51 UTC
emerge --info is missing...

Use desktop profile (use eselect profile to select one) to get USE thunar enabled by default...

There hasn't been other changes related to icons, unless you depcleaned all your icon themes away (emerge xfce4-icon-theme tango-icon-theme for example).
Comment 8 Tobias Jakobi 2009-09-05 21:31:46 UTC
Thanks, you were right about the thunar USE-flag. I did not have it enabled.

In fact I disabled it right after I became aware of it. I'm not using thunar for file management purpose (but emelfm2), but it looks like a lot of xfce's functionality doesn't work that well when thunar support is disabled.

With the USE-flag enabled again the desktop icons reappeared. Thanks for your help Samuli, I never thought of thunat being the culprit :)