Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 282161

Summary: Stabilize =dev-util/devhelp-0.21-r1
Product: Gentoo Linux Reporter: Robert Buchholz (RETIRED) <rbu>
Component: New packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal Keywords: STABLEREQ
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 280393    

Description Robert Buchholz (RETIRED) gentoo-dev 2009-08-21 06:11:33 UTC
Gnome, please ACK this first. We're going stable with xulrunner 1.9.1.

Arches, please test and mark stable:
=dev-util/devhelp-0.23.1
Target keywords : "amd64 hppa ppc sparc x86"
Comment 1 Mart Raudsepp gentoo-dev 2009-08-21 08:36:48 UTC
NAK from my part for now.

This version uses webkit-gtk, which in Gentoo is an even bigger security nightmare right now as you know very well yourself ;) - bugs #271861, #271865, #281819

To get a newer webkit-gtk stable with less security issues, we need to get in libsoup split to libsoup and libsoup-gnome, which in turn requires libsoup-2.26 stable, which we do together with the full GNOME-2.26 (but could think about doing before the rest of GNOME-2.26). And a big review on the splitting patches, preferably convincing upstream of them, and so on.
The latest webkit-gtk (that perhaps isn't affected by #281819) also needs libsoup-2.27, which is a development version and even farther away from going stable.
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-08-21 15:27:47 UTC
Alright, we don't need 0.23.1 -- the problem with 0.21-r1 + 1.9.1 has been fixed, now we need it stable.
Comment 3 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-13 09:58:51 UTC
@arches: please stabilize :)

@x86: we might be able to squeeze ff-3.5 in for 10.0, so please do the needful.
Comment 4 nixnut (RETIRED) gentoo-dev 2009-09-20 19:35:52 UTC
ppc stable 
Comment 5 Markus Meier gentoo-dev 2009-09-22 13:10:27 UTC
x86 stable
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-10-27 17:21:28 UTC
sparc doesn't have xulrunner-1.9.1 keyworded, so they don't need to keyword this...