Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 281437

Summary: media-gfx/gthumb-2.10.11 with USE="raw" depends on dcraw
Product: Gentoo Linux Reporter: crusaderky
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED NEEDINFO    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description crusaderky 2009-08-14 08:13:54 UTC
Lately (I can't say since when), I can't preview any more any of my fujitsu RAW pictures (.RAF) in gthumb. Neither thumbnailing nor full-screen view work.

The ufraw plugin for gimp still works fine.
I've already tried rebuilding both ufraw and gthumb.

An extract from genlop --list:
Mon Nov  3 21:59:41 2008 >>> media-gfx/gthumb-2.10.10
Tue Nov  4 22:01:25 2008 >>> media-gfx/ufraw-0.14.1
(definitely worked fine at this point)
Tue Jan 20 14:41:54 2009 >>> media-gfx/ufraw-0.15
Mon Feb 23 12:03:34 2009 >>> media-gfx/ufraw-0.15-r1
Fri Feb 27 11:47:41 2009 >>> media-gfx/gthumb-2.10.11

$ emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.0
Timestamp of tree: Thu, 13 Aug 2009 01:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="it_IT.UTF8"
LC_ALL="it_IT.UTF8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cjk cli cracklib crypt cups curl dbus dga dri dts dv dvb dvd dvdr eds emboss encode esd evo exif fam ffmpeg firefox flac fontconfig fortran ftp fuse gdbm gif gimp gmp gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kerberos ldap libnotify lzo mad mikmod mmx mp3 mp4 mpeg mtp mudflap multilib musepack mysql ncurses nls nptl nptlonly ogg openal opengl openmp pam pcre pdf perl php png ppds pppd python qt3support quicktime raw readline reflection samba sdl session smp speex spell spl sqlite sse sse2 ssl ssse3 startup-notification svg sysfs tcl tcpd threads tiff tk truetype unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 crusaderky 2009-08-14 08:26:38 UTC
Tried rebuilding media-libs/libopenraw-0.0.5, as well as downgrading to gthumb-2.10.10; no change.
Comment 2 crusaderky 2009-08-14 08:40:26 UTC
The problem is that sometime in the past, emerge --depclean pulled out dcraw. After emerging dcraw-8.86, everything worked again. gthumb with USE="raw" should depend on it.
Comment 3 crusaderky 2009-08-14 08:53:30 UTC
P.S. after reinstalling dcraw, in order to make thumbnails work again I had to wipe my ~/.thumbnails directory.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-08-14 12:07:29 UTC
are you sure it wouldn't work with something like gnome-raw-thumbnailer or raw-thumbnailer ? gthumb autoconf only mentions libopenraw so I guess the rest if some infrastructure magic.
Comment 5 crusaderky 2009-08-14 12:14:11 UTC
I never had gnome-raw-thumbnailer.
I used to have raw-thumbnailer and I removed it with the same depclean that removed dcraw. However, I did not have to reinstall it to make gthumb work (or compile, at all). Also, libopenraw compiles fine with neither installed.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-08-14 15:45:43 UTC
so what about gnome-raw-thumbnailer, could you please test it ?
Comment 7 crusaderky 2009-08-21 11:42:02 UTC
(In reply to comment #6)
> so what about gnome-raw-thumbnailer, could you please test it ?
> 

I don't understand what you're saying. If it isn't, and most importantly it's never been, installed on my PC, how could it be involved in something that suddendly stopped working? :P
What do you mean with "test it"? 
Comment 8 crusaderky 2009-08-21 11:46:30 UTC
Here's a probably insightful genlop query:

# genlop -lu | grep -e '\(thumb\|raw\)'
     Mon Nov  3 21:52:23 2008 >>> media-libs/libopenraw-0.0.5
     Mon Nov  3 21:59:41 2008 >>> media-gfx/gthumb-2.10.10
     Tue Nov  4 22:01:25 2008 >>> media-gfx/ufraw-0.14.1
     Tue Nov 11 12:14:57 2008 >>> media-gfx/raw-thumbnailer-0.2
     Tue Nov 11 12:15:12 2008 >>> media-gfx/dcraw-8.73
     Tue Nov 11 12:36:49 2008 >>> media-video/ffmpegthumbnailer-1.2.5
     Tue Nov 11 12:36:55 2008 >>> xfce-extra/thunar-thumbnailers-0.3.2
     Thu Nov 20 13:19:04 2008 <<< xfce-extra/thunar-thumbnailers-0.3.2
     Thu Nov 20 13:19:04 2008 >>> xfce-extra/thunar-thumbnailers-0.4.1
     Tue Dec 23 13:50:45 2008 >>> media-video/ffmpegthumbnailer-1.3.0
     Tue Jan 20 14:41:54 2009 >>> media-gfx/ufraw-0.15
     Mon Feb 23 12:03:34 2009 >>> media-gfx/ufraw-0.15-r1
     Fri Feb 27 11:47:41 2009 >>> media-gfx/gthumb-2.10.11
     Sun Jul 12 20:46:38 2009 <<< media-video/ffmpegthumbnailer-1.3.0
     Sun Jul 12 20:46:38 2009 >>> media-video/ffmpegthumbnailer-1.5.3
     Mon Jul 13 02:17:15 2009 <<< media-gfx/ufraw-0.15-r1
     Mon Jul 13 02:17:16 2009 >>> media-gfx/ufraw-0.15-r1
     Mon Jul 27 14:49:00 2009 <<< media-gfx/gthumb-2.10.11
     Mon Jul 27 14:49:01 2009 >>> media-gfx/gthumb-2.10.11
     Thu Aug 13 12:30:44 2009 <<< media-gfx/raw-thumbnailer-0.2
     Thu Aug 13 12:30:45 2009 >>> media-gfx/raw-thumbnailer-0.2
     Thu Aug 13 12:31:04 2009 <<< media-gfx/raw-thumbnailer-0.2
     Thu Aug 13 12:31:55 2009 <<< xfce-extra/thunar-thumbnailers-0.4.1
     Thu Aug 13 12:32:01 2009 <<< media-video/ffmpegthumbnailer-1.5.3
     Thu Aug 13 12:32:02 2009 <<< media-gfx/dcraw-8.73
     Thu Aug 13 12:39:57 2009 <<< media-gfx/ufraw-0.15-r1
     Thu Aug 13 12:39:57 2009 >>> media-gfx/ufraw-0.15-r1
     Thu Aug 13 12:42:48 2009 <<< media-gfx/gthumb-2.10.11
     Thu Aug 13 12:42:50 2009 >>> media-gfx/gthumb-2.10.11
     Fri Aug 14 10:18:26 2009 <<< media-libs/libopenraw-0.0.5
     Fri Aug 14 10:18:27 2009 >>> media-libs/libopenraw-0.0.5
     Fri Aug 14 10:23:07 2009 <<< media-gfx/gthumb-2.10.11
     Fri Aug 14 10:23:08 2009 >>> media-gfx/gthumb-2.10.11
     Fri Aug 14 10:25:33 2009 <<< media-gfx/gthumb-2.10.11
     Fri Aug 14 10:25:34 2009 >>> media-gfx/gthumb-2.10.10
     Fri Aug 14 10:27:20 2009 >>> media-gfx/rawstudio-1.1.1-r1
     Fri Aug 14 10:35:30 2009 >>> media-gfx/dcraw-8.86
     Fri Aug 14 11:10:08 2009 <<< media-gfx/gthumb-2.10.10
     Fri Aug 14 11:10:10 2009 >>> media-gfx/gthumb-2.10.11
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-08-23 01:42:23 UTC
The point here is to figure if something else than dcraw could make the feature work as well so we can have correct dependencies.
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-09-06 11:57:59 UTC
Please get back to us.