Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 280031

Summary: x11-drivers/nvidia-drivers-185.18.{29,31}: xserver hangs when it tries to set screen resolution
Product: Gentoo Linux Reporter: Stefan Trenker <strenker>
Component: [OLD] UnspecifiedAssignee: Doug Goldstein <cardoe>
Status: RESOLVED DUPLICATE    
Severity: normal CC: gentoo, spock
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: output of nvidia-bug-report.sh for the last working driver
output of nvidia-bug-report.sh for the last __NOT__ working driver
xserver log for the last working driver
xserver log for the last __NOT__ working driver

Description Stefan Trenker 2009-08-02 12:43:01 UTC
Hai all,

I have a Lenovo ThinkPad notebook shipped with a nVidia Corporation Quadro NVS 140M graphics adatper.

After an upgrade of the Nvidia proprietary driver x11-drivers/nvidia-drivers-185.18.14 to x11-drivers/nvidia-drivers-185.18.29 and later on to x11-drivers/nvidia-drivers-185.18.31 my xserver hangs during startup.

When i compare the last working (185.18.14 driver) Xorg.0.log to the non-working (185.18.29 and 185.18.31) it seems as if the newer drivers hand during setting the display resolution (the non-working xserver log-files all stop at the same place and the next line of the working xserver log-file says it sets the display resolution).

I did not change anyting in my xorg-conf etc. I just updated the ebuild.

Reproducible: Always




emerge --info                                                     
Portage 2.2_rc33 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 i686)                                                                                                   
=================================================================                                   
System uname: Linux-2.6.30-gentoo-r4-i686-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-glibc2.0  
Timestamp of tree: Sun, 02 Aug 2009 10:00:01 +0000                                                  
ccache version 2.4 [enabled]                                                                        
app-shells/bash:     3.2_p39                                                                        
dev-java/java-config: 2.1.8-r1                                                                      
dev-lang/python:     2.5.4-r3                                                                       
dev-util/ccache:     2.4-r7                                                                         
dev-util/cmake:      2.6.4                                                                          
sys-apps/baselayout: 1.12.11.1                                                                      
sys-apps/sandbox:    2.0                                                                            
sys-devel/autoconf:  2.13, 2.63-r1                                                                  
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                           
sys-devel/binutils:  2.18-r3                                                                        
sys-devel/gcc-config: 1.4.1                                                                         
sys-devel/libtool:   1.5.26                                                                         
virtual/os-headers:  2.6.27-r2                                                                      
ACCEPT_KEYWORDS="x86"                                                                               
CBUILD="i686-pc-linux-gnu"                                                                          
CFLAGS="-O2 -pipe"                                                                                  
CHOST="i686-pc-linux-gnu"                                                                           
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"                                                                      
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache cvs distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sfperms unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="C"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="de de-DE de_DE"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://loisl.maus.homelinux.net/gentoo-portage"
USE="X a52 aac accessibility acl acpi aiglx alsa amr apache2 arts asf audiofile automount avahi bash-completion berkdb bidi bluetooth bonjour bzip2 cairo cddb cdio cdr cgi cli consolekit cracklib crypt ctype cups curl dbus dirac dri dv dvb dvd dvdr dvdread ebook emerald encode esd exif faac fame fbcondecor ffmpeg fftw firefox flac foomatic foomaticdb fortran ftp gd gdbm gif gimp gimpprint glib glitz gmp gnome gnutls gphoto2 gpm gsm gstreamer gtk hal hdri htmlhandbook httpd iconv id3tag idn imagemagick imap imlib ipod ipv6 isdnlog java jpeg jpeg2k json kde laptop ldap libgcrypt libv4l2 live logrotate lzma lzo mad matroska mhash mjpeg mmap mmx mng modplug mozilla mp3 mp4 mpeg mplayer mudflap mysql ncurses netpbm network nls nptl nptlonly nsplugin oav ogg openexr opengl openmp oss pam pcap pcmcia pcre pda pdf perl php plasma png posix ppds pppd python qt3support qt4 quicktime rar rdesktop readline reflection rtsp ruby samba sasl scanner schroedinger sdl sesame2 session shout slp sndfile snmp sockets speex spell spl sse sse2 ssl ssse3 stream subtitles svg sysfs syslog tcltk tcpd tetex theora threads thumbnail tiff tk truetype unicode usb utempter v4l v4l2 vcd vcdx vdpau vhook vidix vim-syntax vlm vnc vorbis webdav wifi win32codecs wma wxwindows x264 x86 xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de de-DE de_DE" SANE_BACKENDS="snapscan" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Stefan Trenker 2009-08-02 12:44:17 UTC
Created attachment 199903 [details]
output of nvidia-bug-report.sh for the last working driver
Comment 2 Stefan Trenker 2009-08-02 12:44:53 UTC
Created attachment 199904 [details]
output of nvidia-bug-report.sh for the last __NOT__ working driver
Comment 3 Stefan Trenker 2009-08-02 12:45:37 UTC
Created attachment 199906 [details]
xserver log for the last working driver
Comment 4 Stefan Trenker 2009-08-02 12:46:12 UTC
Created attachment 199907 [details]
xserver log for the last __NOT__ working driver
Comment 5 Florian Streibelt 2009-08-02 23:08:49 UTC
I think bug #279588 is the same.
Comment 6 Doug Goldstein gentoo-dev 2009-08-03 03:25:20 UTC
The solution is to use the nvidia-drivers-180.60 version for the time being. You'll likely have to wait until a 190.x series is out to have this fixed.
Comment 7 Doug Goldstein gentoo-dev 2009-08-03 03:44:57 UTC

*** This bug has been marked as a duplicate of bug 279588 ***