Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 279978

Summary: kde-base/konsole-4.x always remembers the last size it was set to
Product: Gentoo Linux Reporter: Lars Wendler (Polynomial-C) <polynomial-c>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: enhancement    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=152385
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 313999    
Attachments: konsole-4.2.4-remember-size.diff

Description Lars Wendler (Polynomial-C) gentoo-dev 2009-08-02 00:24:54 UTC
Hi,

despite this might be created with good intentions in mind, the current behaviour of kde-4's konsole to always remember its size is quite annoying for people like me who want to have the konsole starting at a fixed size (like 80x25 in my case).
There's already an upstream bug open regarding this problem (see URL). I took the patch from that bug and reworked it slightly so it can be applied through our ebuilds.
This patch adds an extra option to the settings called "Save window size and position on exit".
It seems like the position doesn't get saved even when the setting is activated but the konsole will remember its size it had when the setting was deacticvated.
Please consider this patch for inclusion.

Reproducible: Always

Steps to Reproduce:
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-02 00:26:45 UTC
Created attachment 199870 [details, diff]
konsole-4.2.4-remember-size.diff
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-08-05 14:35:52 UTC
I'd rather have this implemented by upstream or at least "supported" by upstream. Up until now I haven't seen a "strong" support for the patch(es) in the bug by KDE developers.
If this gets committed soon to HEAD, we might add the patch before asking for 4.2.4 to be marked stable. Otherwise, I think we should wait for upstream to commit it.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-05 16:36:35 UTC
I opened this bug for two reasons. The bigger one is that the current behavior of konosle is an extremely big annoyance to me and the second one is that scarabeus asked me to open this bug.
On the other hand as I already use this patch in my private overlay, so I have no problem with you waiting for official approval of this patch.
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2010-04-08 23:10:51 UTC
What's the status wrt 4.4.2 here?
Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-08 23:58:39 UTC
Fixed in tree, thanks. The patch isn't applied upstream yet, but the reason is undefined so i decided to apply it to us, since it works
Comment 6 Toralf Förster gentoo-dev 2010-04-09 08:19:16 UTC
(In reply to comment #3)
> The bigger one is that the current behavior of konosle is an extremely big annoyance to me
Right.

Thx for your effort to solve this annoyance

-a pleased user-
:-)