Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 279525

Summary: net-analyzer/echoping-6.0.2 fails to build with >=net-libs/gnutls-2.7.1
Product: Gentoo Linux Reporter: Joost Ruis <joost.ruis>
Component: Current packagesAssignee: Netmon Herd <netmon>
Status: RESOLVED FIXED    
Severity: normal CC: Adrian.Bassett
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 253709    
Attachments: Log.

Description Joost Ruis 2009-07-28 23:01:20 UTC
See attached log.

Reproducible: Always




sabayon server # emerge --info                                                                                                                                                                                
Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.25-sabayon x86_64)                                                                                                      
=================================================================                                                                                                                                             
System uname: Linux-2.6.25-sabayon-x86_64-Intel-R-_Xeon-R-_CPU_X3220_@_2.40GHz-with-gentoo-2.0.1                                                                                                              
Timestamp of tree: Tue, 28 Jul 2009 21:45:02 +0000                                                                                                                                                            
app-shells/bash:     4.0_p28                                                                                                                                                                                  
dev-java/java-config: 1.3.7-r1, 2.1.8-r1                                                                                                                                                                      
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1                                                                                                                                                                
dev-python/pycrypto: 2.0.1-r8                                                                                                                                                                                 
dev-util/cmake:      2.6.4-r1                                                                                                                                                                                 
sys-apps/baselayout: 2.0.1                                                                                                                                                                                    
sys-apps/openrc:     0.4.3-r5                                                                                                                                                                                 
sys-apps/sandbox:    2.0                                                                                                                                                                                      
sys-devel/autoconf:  2.13, 2.63-r1                                                                                                                                                                            
FEATURES="collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirror.switch.ch/ftp/mirror/gentoo/"                                                                                                     
LANG="en_US"                                                                                                                                                                                                  
LC_ALL="en_US"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="en en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg
 tr uk uz vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh"
MAKEOPTS="-s -j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/enlightenment /usr/local/portage/layman/sabayon /usr/local/portage/layman/kde-testing"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7Zip X a52 aac aalib accessibility acl acpi aiglx aim alsa amd64 artswrappersuid audiofile avahi bash-completion berkdb bidi bluetooth bzip2 cairo cdda cddb cdr chm cjk cli config_wizard cpudetection c
racklib crypt css cups dbox2 dbus dga dri dts dv dvb dvd dvdr dvdread dvi dxr3 emboss encode extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint gmp
gnutls gphoto2 gpm gs gsm gstreamer gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda isdnlog jabber jack jfs jingle joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kipi lame lcd
ldap libnotify live lj lm_sensors logitech-mouse lzo mad mail matroska midi mikmod mjpeg mmx mng mozdevelop mp3 mp3rtp mpeg msn mudflap multilib musepack musicbrainz ncurses network new-login nls nptl nptlo
nly nsplugin ntfs ogg openal openexr opengl openmp pam pcmcia pcre pda pdf perl png policykit povray ppds pppd pulseaudio python qt3support qt4 quicktime quotas rar rdesktop readline reflection reiserfs rss
 scanner sdl session slp sms speex spell spl sse sse2 ssl startup-notification stream svg sysfs tcpd theora tiff tracker truetype udev unicode usb v4l v4l2 visualization voice vorbis weather wifi wmf x264 x
cb xfs xine xinerama xml xorg xpm xprint xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart
mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw
 multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_ow
ner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvi
f speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 pana
sonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox b
arbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50
x sq905 stv0674 stv0680 sx330z template" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="e
n en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg tr uk uz
vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh" LIRC_DEVICES="audio audio_alsa serial" USERLAND="GNU" VIDEO_CARDS="fbdev vesa radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Joost Ruis 2009-07-28 23:01:38 UTC
Created attachment 199491 [details]
Log.
Comment 2 James Earl Spahlinger 2009-07-28 23:32:12 UTC
What you have looks like a linking problem with gnutls, but I can't narrow it down more then that. Would your system be lacking net-libs/gnutls for any reason? Your useflags make me think you have that package though. Assigning to relevant maintainer.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-29 01:04:33 UTC
>-net-libs/gnutls-2.7
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-29 03:00:56 UTC
Upstream has this fixed in the repo but there hasn't been a release since that announcement, a month or so ago.

I will commit a patched -r1 shortly.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-29 03:11:57 UTC
Fixed in net-analyzer/echoping-6.0.2-r1. Man, eautoreconf could need some more automation...
Comment 6 Joost Ruis 2009-07-29 10:30:41 UTC
Need to REOPEN this is its still failing for me:

...
Plugins to build: random whois dns postgresql ldap
>>> Source configured.                            
>>> Compiling source in /var/tmp/portage/net-analyzer/echoping-6.0.2-r1/work/echoping-6.0.2 ...
make -s -j3                                                                                    
Making all in plugins                                                                          
Making all in dns                                                                              
./libtool: line 872: X--tag=CC: command not found                                              
./libtool: line 905: libtool: ignoring unknown tag : command not found                         
./libtool: line 872: X--mode=compile: command not found                                        
./libtool: line 1038: *** Warning: inferring the mode of operation is deprecated.: command not found
./libtool: line 1039: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
./libtool: line 1182: Xx86_64-pc-linux-gnu-gcc: command not found                                             
./libtool: line 1182: X-DHAVE_CONFIG_H: command not found                                                     
./libtool: line 1182: X-I.: command not found                                                                 
./libtool: line 1182: X-O2: command not found                                                                 
./libtool: line 1182: X-march=x86-64: command not found                                                       
./libtool: line 1182: X-pipe: command not found                                                               
./libtool: line 1182: X-MT: command not found                                                                 
./libtool: line 1182: Xdns.lo: command not found                                                              
./libtool: line 1182: X-MD: command not found                                                                 
./libtool: line 1182: X-MP: command not found                                                                 
./libtool: line 1182: X-MF: command not found                                                                 
./libtool: line 1182: X.deps/dns.Tpo: No such file or directory                                               
./libtool: line 1182: X-c: command not found                                                                  
./libtool: line 1233: Xdns.lo: command not found
./libtool: line 1238: libtool: compile: cannot determine name of library object from `': command not found
make[4]: *** [dns.lo] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Let me know if you need additional info.
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-29 11:53:40 UTC
(In reply to comment #6)

It's a different bug, related to libtool, not gnutls.
This bug is fixed.