Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 277837

Summary: media-gfx/rawstudio: fails to build with glibc-2.10
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugzilla.rawstudio.org/show_bug.cgi?id=259
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 270353    
Attachments: Build log

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-14 16:49:05 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-14 16:49:19 UTC
Created attachment 197946 [details]
Build log
Comment 2 Markus Meier gentoo-dev 2009-08-08 08:33:02 UTC
fixed in cvs, thanks for the report.

  08 Aug 2009; Markus Meier <maekke@gentoo.org> rawstudio-1.2.ebuild,
  +files/rawstudio-1.2-glibc-2.10.patch:
  fix building with glibc-2.10 wrt bug #277837