Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 277785

Summary: media-sound/amarok fails to connect to the embedded mysql database
Product: Gentoo Linux Reporter: Thomas Pegeot <thomas.pegeot>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: de_doener, jmbsvicetto, ken69267, kevin.bowling, magnus.lidbom, mbostwick89, mkyral, orangewarrior, richard.foltyn, sparrow1, vamp898
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Amarok --debug showing the sql queries that fail
emerge --info
output of emerge -uDpvt amarok

Description Thomas Pegeot 2009-07-14 09:31:19 UTC
Hi,

I know that Mysql was patched in order to be provide a shared embedded
libmysqld for Amarok, but it still doesn't work for me with the latest versions of Mysql (dev-db/mysql-5.0.76-r1 and mysql-5.0.83).

In my case, Amarok seems to be not able to connect to the Mysql database :( 
See the attached log. ;)

Thank you in advance.

Regards


Reproducible: Always

Steps to Reproduce:
1. Deleting Amarok configuration : 
rm .kde4/share/apps/amarok -Rf
rm .kde4/share/config/amarok*
2. Lauching Amarok with the debug option : amarok --debug
3. Instead of having a normal empty collection, i've got : 
"Local Collection
Counting"
And, i also have some mysql errors in my terminal like : 
"[ERROR!] GREPME MySQL query failed! No database selected  on  "SELECT id, deviceid, dir, changedate FROM directories WHERE deviceid IN (-1);"
Comment 1 Thomas Pegeot 2009-07-14 09:32:34 UTC
Created attachment 197897 [details]
Amarok --debug showing the sql queries that fail
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-07-16 01:32:02 UTC
Please add your use flags for mysql and amarok as well as your emerge --info.
Comment 3 Thomas Pegeot 2009-07-16 15:42:02 UTC
gentoo thomas # emerge -av dev-db/mysql amarok

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-db/mysql-5.0.83  USE="community embedded perl ssl -berkdb -big-tables -cluster -debug -extraengine -latin1 -max-idx-128 -minimal -profiling (-selinux) -static" 0 kB [0]
[ebuild   R   ] media-sound/amarok-9999  USE="cdaudio daap ipod opengl semantic-desktop (-aqua) -debug -lastfm -mp3tunes -mtp" 0 kB [1]
Comment 4 Thomas Pegeot 2009-07-16 15:43:09 UTC
Created attachment 198198 [details]
emerge --info
Comment 5 Thomas Pegeot 2009-07-16 15:47:34 UTC
I know that I've some non-safe flags : if you want me to compile Mysql and Amarok with safe flags only, i can do it. ;)

Moreover, i'm pretty sure that the problem is not related to the last three "loop" flags, because even without these flags the same problem occured. :(

Thank you for taking care of this problem ;)



Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-07-16 16:43:23 UTC
Please build mysql and amarok with safe CFLAGS and try amarok-2.1.1.
Comment 7 Thomas Pegeot 2009-07-16 18:32:42 UTC
I've just compiled Amarok-2.1.1 and Mysql with safer flags (-march=k8 -O2 -pipe) and i still get the same issue :(
Comment 8 Lukasz Ligowski 2009-08-27 11:53:41 UTC
Same problem here:
dev-db/mysql-5.0.76-r1  USE="embedded ssl -berkdb -big-tables -cluster -debug -extraengine -latin1 -max-idx-128 -minimal -perl (-selinux) -static"
media-sound/amarok-2.1.1  USE="cdda daap mtp opengl semantic-desktop (-aqua) -debug -ipod -mp3tunes" LINGUAS="pl -bg -ca -cs -da -de -el -en_GB -es -et -eu -fr -gl -he -is -it -ja -km -ku -lt -lv -nb -nds -nl -nn -pa -pt -pt_BR -ro -ru -sl -sv -th -tr -uk -wa -zh_CN -zh_TW"

Portage 2.2_rc40 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r2 x86_64)
=================================================================                                        
System uname: Linux-2.6.28-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7100_@_1.80GHz-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 27 Aug 2009 10:30:19 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.5.2-r7, 2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.51.0.14
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr apache2 audiofile avahi avi bash-completion bzip2 cddb cdparanoia cdr cli cracklib crypt cscope cups dbus djvu doc dri dts dvd dvdr dvdread encode examples exif fam ffmpeg flac fortran freetype gdbm gif hal htmlhandbook iconv imagemagick ipv6 isdnlog jabber jpeg kde kdeenablefinal kdehiddenvisibility logrotate mad memlimit mime mmap mmx mp3 mpeg mudflap multilib musicbrainz ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf png posix pppd python qt3 qt4 rdesktop readline reflection session skey sndfile source spell spl sse sse2 ssl svg sysfs tetex theora threads tiff truetype unicode usb userlocales v4l v4l2 vcd vim-syntax vorbis wifi x264 xcomposite xinerama xorg xpm xv xvid zeroconf zlib" ALSA_CARDS="cmi8330" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Johannes Hirte 2009-10-22 09:03:47 UTC
Same problem here. It worked fine until yesterday, when I removed amarok with all pulled in dependencies and reemerged it. Since then the mysql-embedded db doesn't work anymore.


emerge --info:

Portage 2.2_rc46 (default/linux/amd64/2008.0, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31.4-fglrx x86_64)
=================================================================                               
System uname: Linux-2.6.31.4-fglrx-x86_64-AMD_Opteron-tm-_Processor_252-with-gentoo-2.0.1       
Timestamp of tree: Thu, 22 Oct 2009 07:30:01 +0000                                              
app-shells/bash:     4.0_p33                                                                    
dev-java/java-config: 2.1.9-r1                                                                  
dev-lang/python:     2.6.3, 3.1.1-r1                                                            
dev-util/cmake:      2.6.4-r3                                                                   
sys-apps/baselayout: 2.0.1                                                                      
sys-apps/openrc:     0.5.2-r1                                                                   
sys-apps/sandbox:    2.1                                                                        
sys-devel/autoconf:  2.13, 2.63-r1                                                              
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11                                                     
sys-devel/binutils:  2.20                                                                       
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/initng/daemon /etc/initng/net /etc/initng/system /etc/pam.d /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests collision-protect distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,-z,combreloc"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/usr/src/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/x11 /usr/local/portage/layman/kde-testing /usr/local/portage/layman/qting-edge /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac accessibility acl acpi akonadi alsa amd64 amr amrnb amrwb aspell audiofile authfile avi bash-completion berkdb boost bzip2 bzlib cairo calendar caps cdda cdparanoia cdr chipcard chm cisco cleartype cli consolekit cracklib crypt css cups cvs dbus dirac djvu dlloader dri dts dv dvd dvdr dvdread encode enscript exif exiv2 fastcgi ffmpeg fftw flac fortran gcc-libffi gcj gd gdbm gif gimp git glitz gmp gnuplot gpm graphite graphviz hal hbci htmlhandbook http iconv idl idle ieee1394 imagemagick inotify ipv6 isdnlog java java5 java6 jikes jpeg kde kdehiddenvisibility kdepim kipi lame lapack latex lcms ldap lensfun libnotify libsamplerate live lm_sensors logrotate lucene lzma lzo mad matroska mjpeg mmap mmx mmxext mng modules mp2 mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses network networkmanager nfs nls nolvm1 nptl nptlonly nsplugin obex ogg oggvorbis openal openexr opengl openmp pam patch pcre pdf perl pic plasma png pnm podofo policykit posix postscript pppd profiledbootstrap python python3 pyx qt qt3 qt3support qt4 quicktime readline redeyes redland reflection rss rtc samba samplerate sasl scanner schroedinger sdl semantic-desktop sendfile session silvercity slang smime smp sndfile snmp soundtouch sox speex spell spl sqlite sse sse2 ssl subversion svg sysfs taglib tcpd tetex theora threads thumbnail tiff tk trayicon truetype unicode usb userlocales v4l v4l2 vorbis vorbis-psy webkit x264 xattr xcb xcomposite xext xhtml xine xml xml2 xmp xorg xscreensaver xulrunner xv xvid yv12 zeroconf zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 10 Marian Kyral 2009-10-22 11:16:47 UTC
The embedded mysql worked to me, but several day before amarok start to crashing on startup and now, after some tests and rebuilds I'm not able to start amarok at all :-( Some issue with phonon.

https://bugs.kde.org/show_bug.cgi?id=211405

Downgrade to amarok-2.2.0, rebuild mysql, phonon, phonon-kde, xinelib does not help. In Systemsetting I can hear the test sound.

$ emerge --info
Portage 2.2_rc46 (default/linux/amd64/2008.0/desktop, gcc-4.3.4, glibc-2.10.1-r0, 2.6.31-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8400_@_2.26GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 21 Oct 2009 17:45:01 +0000
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.5.4-r3, 2.6.3, 3.1.1-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz/ http://gentoo.supp.name/"
LANG="cs_CZ.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="cs"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--quiet"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo exif faad fam ffmpeg firefox flac fortran gdbm gif git gpm gstreamer hal iconv imagemagick ipv6 jpeg jpeg2k kde kde4 lame ldap libnotify logrotate lzma lzo mad matroska mikmod mmx mmxext mng modules mozilla mp3 mp4 mpeg mplayer msql mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl phonon plasma png ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection samba sdl session smp spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads thumbnail thunar thunderbird tiff truetype unicode unzip usb vim-syntax vorbis webkit wmf wmp x264 xine xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="oki3200" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

Comment 11 白川間瀬流 2009-10-25 19:58:58 UTC
Same error here

Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31.5-Vamp898 i686)
=================================================================                                   
System uname: Linux-2.6.31.5-Vamp898-i686-Pentium-R-_Dual-Core_CPU_T4200_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 25 Oct 2009 18:15:01 +0000                                                  
app-shells/bash:     4.0_p33                                                                        
dev-java/java-config: 2.1.9-r1                                                                      
dev-lang/python:     2.6.3, 3.1.1-r1                                                                
dev-util/cmake:      2.6.4-r3                                                                       
sys-apps/baselayout: 2.0.1                                                                          
sys-apps/openrc:     0.5.2-r1                                                                       
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://ftp5.gwdg.de/pub/linux/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/pro-audio /overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode evo fam firefox flac fortran gdbm gif gpm hal iconv ipv6 isdnlog jack jpeg kde ldap libnotify mad mikmod mmx modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 12 Michael B 2009-10-28 03:10:21 UTC
Same issue.
Portage 2.1.7.1 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31-gentoo-r2-bostwick-server i686)                                                                                        
=================================================================                                                                                                                                          
System uname: Linux-2.6.31-gentoo-r2-bostwick-server-i686-Intel-R-_Core-TM-2_Duo_CPU_E8500_@_3.16GHz-with-gentoo-2.0.1                                                                                     
Timestamp of tree: Thu, 22 Oct 2009 19:45:02 +0000                                                                                                                                                         
app-shells/bash:     4.0_p33                                                                                                                                                                               
dev-java/java-config: 2.1.9-r1                                                                                                                                                                             
dev-lang/python:     2.6.3, 3.1.1-r1                                                                                                                                                                       
dev-util/cmake:      2.6.4-r3                                                                                                                                                                              
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ "
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi activefilter admin administrator alsa amarok2 apache2 apm archive arts aspell backtrace bash-completion berkdb bluetooth branding bugzilla bzip2 cairo calendar cdr chm cisco cli clipboard cmake colordiff colors consolekit corefonts cracklib crypt css csv cups curl curlwrappers cvs cxx db2 dbus disk-partition dns dri dts dvd dvdnav dvdr dvdread ebook editor eds embedded emboss encode esd evo excel exchange exif faac faad faillog fam fat fbsplash festival ffmpeg filter finger firebird firefox firefox3 flac flash fortran ftp gcrypt gdbm gecko geoip gif gmail gnome google google-gadgets gpm groupwise grub gs gstreamer gtk gtkspell hal hpn http http-forms http-server httpd hub icons iconv ieee1394 injection inkjar inline iostats iproute2 ipsec ipv6 irc irda isdnlog iso14755 jabber java javascript john joystick jpeg jpeg2k jpg kate kde kde4 lcms ldap libcaca libedit libnotify libssh2 lirc lm_sensors log4j logwatch mad mail md5sum meanwhile mikmod mime mjpeg mng modules mono mp3 mp4 mpeg msn msql mssql mudflap multiuser munin-apache munin-dhcp munin-irc munin-surfboard mysql mysqli nat ncurse ncurses net network network-cron networking nfs nfsv3 nfsv4 nids nls nmap nptl nptlonly nss ntfs ntp objc objc++ objc-gc odbc ogg openal opengl openid openmp openssl opensslcrypt openvpn oracle otr pam passwd passwordsave pastebin pcap pcre pda pdf perl perl-geoipupdate php pidgin plasma player plugins pm-utils png podcast pop pop3d posix postproc postscript ppds pppd pptp prediction ps python python-bindings pythong qmake qt3 qt3support qt4 quicktime radio rar raw rdesktop react readline recode reflection regex rrdtool rss samba scanner screen sdl search serial server session sftp shadow skype sms smtp sndfile snes snmp sockets socks socks5 solver speech spell spl spoof-source sql sqlite sqlite3 ssh ssl startup-notification stats subversion suexec svg sysfs tcl tcpd tcpdump tcpmd5 tcpwrapper tftp themes theora thumbnail thunar thunderbird tiff tk tls tordns tos trace transcode truetype tts ui unicode unzip upnp url usb utils v4l v4l2 vcd video video-file videos visual vlc vnc vorbis wav wavpack weather web webkit webmail wifi wildcards win32codecs winetools wireshark wma wma-fixed wmf wmp wps x264 x86 xine xinerama xml xorg xterm xulrunner xv xvid yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 13 Marian Kyral 2009-10-29 06:48:25 UTC
(In reply to comment #10)
> The embedded mysql worked to me, but several day before amarok start to
> crashing on startup and now, after some tests and rebuilds I'm not able to
> start amarok at all :-( Some issue with phonon.
> 
> https://bugs.kde.org/show_bug.cgi?id=211405

So it was not a issue with phonon, but "debug" USE flag on mysql. Now Amarok starts, but not I have to switch to a external mysql as the collection is blank :-(

Apropo, on amarok wiki (http://amarok.kde.org/wiki/Development/MySQL_Embedded) in common problems is mentioned: MySQL 5.0 vs 5.1. But without details.

Maybe installation of MySQL 5.1 could help. I'll try later.
Comment 14 白川間瀬流 2009-11-02 00:23:50 UTC
Gentoo is the only Distribution with this problem and the amarok developers say that it is a gentoo only problem too

so there is something wrong with the ebuild or something like this
Comment 15 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-11-02 01:33:46 UTC
(In reply to comment #14)
> Gentoo is the only Distribution with this problem and the amarok developers say
> that it is a gentoo only problem too
> 
> so there is something wrong with the ebuild or something like this

amarok has been working with mysql[embedded] for me since the shared lib patch for mysql was finished.
As Gentoo was the first distro to fix libmysqld, it's not too surprising we faced some issues before the others. About upstream wanting mysql-5.1 for amarok-2.2, I am confident that mysql >=5.0.70-r1 in Gentoo should be enough.
Comment 16 Oskar Wrobel 2009-11-04 21:02:14 UTC
I've encountered similar problems with mysql-5.0.84. But after I upgraded to 5.1.31 everything went back to normal (with new database, I didn't try to use old one).
I think that mysql-5.1 should be in portage tree, even hardmasked-it's developers claim it has production quality-why should gentoo devs argue with that?
Comment 17 Magnus Lidbom 2009-11-11 17:37:35 UTC
>I've encountered similar problems with mysql-5.0.84. But after I upgraded to
>5.1.31 everything went back to normal

How exactly did you do that? I'm unable to find a working ebuild for a 5.1 version of mysql.
Comment 18 白川間瀬流 2009-11-16 09:08:33 UTC
There is no working ebuild for MySQL 5.1 Ö_Ö
Comment 19 白川間瀬流 2009-11-16 09:14:42 UTC
Same problem with 5.0.84-r1

tons of MySQL errors from amarok -.-
Comment 20 Marshall Banana 2009-11-16 21:59:45 UTC
same here...
the often mentioned trick of compiling mysql with -fPIC -dPIC didn't work either...

the significant part of amarok -d --nofork seems to be the following, showing that building the databases "amarok" and "mysql" failed (and then some error 176 occurred "MySQL error code 176: File too short; Expected more data in file", likely this happens because creating the database failed)

<snip>
amarok:           [PluginManager] Trying to load:  "amarok_collection-mysqlecollection"                                      
amarok:           [PluginManager]                                                                                            
"          " PluginManager Service Info:                                                                                     
"          " ---------------------------                                                                                     
"          " name                          : "MySQLe-Sammlung"                                                               
"          " library                       : "amarok_collection-mysqlecollection"                                            
"          " desktopEntryPath              : "amarok_collection-mysqlecollection.desktop"                                    
"          " X-KDE-Amarok-plugintype       : "collection"                                                                    
"          " X-KDE-Amarok-name             : "mysqle-collection"                                                             
"          " X-KDE-Amarok-authors          : ("Maximilian Kossick")                                                          
"          " X-KDE-Amarok-rank             : "100"                                                                           
"          " X-KDE-Amarok-version          : "1"                                                                             
"          " X-KDE-Amarok-framework-version: "49"                                                                            

amarok:           [CollectionManager] Initialising sqlcollection 
amarok:           BEGIN: ScanManager::ScanManager(SqlCollection*) 
amarok:           END__: ScanManager::ScanManager(SqlCollection*) - Took 0.00039s 
amarok:           BEGIN: MySqlEmbeddedCollection::MySqlEmbeddedCollection(const QString&, const QString&) 
InnoDB: The InnoDB memory heap is disabled                                                                
InnoDB: use atomic builtins.                                                                              
InnoDB: unit of spin count at ut_delay() is aligned to 31                                                 
InnoDB: The first specified data file /home/meister/.kde4/share/apps/amarok/mysqle/ibdata1 did not exist: 
InnoDB: a new database to be created!                                                                     
091115 23:41:37  InnoDB: Setting file /home/meister/.kde4/share/apps/amarok/mysqle/ibdata1 size to 10 MB  
InnoDB: Database physically writes the file full: wait...                                                 
091115 23:41:37  InnoDB: Log file /home/meister/.kde4/share/apps/amarok/mysqle/ib_logfile0 did not exist: new to be created
InnoDB: Setting log file /home/meister/.kde4/share/apps/amarok/mysqle/ib_logfile0 size to 5 MB                             
InnoDB: Database physically writes the file full: wait...                                                                  
091115 23:41:38  InnoDB: Log file /home/meister/.kde4/share/apps/amarok/mysqle/ib_logfile1 did not exist: new to be created
InnoDB: Setting log file /home/meister/.kde4/share/apps/amarok/mysqle/ib_logfile1 size to 5 MB                             
InnoDB: Database physically writes the file full: wait...                                                                  
InnoDB: Doublewrite buffer not found: creating new                                                                         
InnoDB: Doublewrite buffer created                                                                                         
InnoDB: Creating foreign key constraint system tables                                                                      
InnoDB: Foreign key constraint system tables created                                                                       
amarok:              [ERROR!] GREPME MySQL query failed! Can't get stat of '/home/meister/.kde4/share/apps/amarok/mysqle/amarok' (Errcode: 176)  on  "Could not create amarok database"                                                                   
amarok:              [ERROR!] GREPME MySQL query failed! Can't get stat of '/home/meister/.kde4/share/apps/amarok/mysqle/mysql' (Errcode: 176)  on  "Could not create mysql database"                                                                     
amarok:              [ERROR!] GREPME MySQL query failed! Unknown database 'amarok'  on  "Could not select database"          
amarok:              Connected to MySQL server 5.0.84-embedded                                                               
amarok:              Initialized thread, count== 1                                                                           
amarok:              [ERROR!] GREPME MySQL query failed! No database selected  on  "SELECT version FROM admin WHERE component = 'DB_VERSION';"                                                                                                            
amarok:             BEGIN: void DatabaseUpdater::update()                                                                    
amarok:                [ERROR!] GREPME MySQL query failed! No database selected  on  "SELECT version FROM admin WHERE component = 'DB_VERSION';"
<snip>


so i just ran the following command:
~/.kde4/share/apps/amarok $ /usr/sbin/mysqld --defaults-file=`pwd`/my.cnf --default-storage-engine=MyISAM --datadir=`pwd`/mysqle --socket=`pwd`/sock --skip-grant-tables
and connected to the mysql-daemon, creating two empty databases "amarok" and "mysql"

now amarok -d --nofork crashes having this part in the output:
<snip>
amarok:             [CollectionManager] Initialising sqlcollection 
amarok:             BEGIN: ScanManager::ScanManager(SqlCollection*) 
amarok:             END__: ScanManager::ScanManager(SqlCollection*) - Took 0.00032s 
amarok:             BEGIN: MySqlEmbeddedCollection::MySqlEmbeddedCollection(const QString&, const QString&) 
InnoDB: The InnoDB memory heap is disabled                                                                  
InnoDB: use atomic builtins.                                                                                
amarok:                Connected to MySQL server 5.0.84-embedded                                            
amarok:                Initialized thread, count== 1                                                        
amarok:                [ERROR!] GREPME MySQL query failed! Can't find file: '/home/meister/.kde4/share/apps/amarok/mysqle//amarok/admin.frm' (errno: 177)  on  "SELECT version FROM admin WHERE component = 'DB_VERSION';"                                
amarok:               BEGIN: void DatabaseUpdater::update()                                                                  
amarok:                  [ERROR!] GREPME MySQL query failed! Can't find file: '/home/meister/.kde4/share/apps/amarok/mysqle//amarok/admin.frm' (errno: 177)  on  "SELECT version FROM admin WHERE component = 'DB_VERSION';"                              
amarok:                  Database version:  0                                                                                
amarok:                 BEGIN: void DatabaseUpdater::createTables() const                                                    
KCrash: Application 'amarok' crashing...                                                                                     
sock_file=/home/meister/.kde4/socket-MorkVomOrk/kdeinit4__0                                                                  

[1]+  Stopped                 amarok -d --nofork






starting amarok a second time of course didn't improve the situation:
<snip>
amarok:             [CollectionManager] Initialising sqlcollection 
amarok:             BEGIN: ScanManager::ScanManager(SqlCollection*) 
amarok:             END__: ScanManager::ScanManager(SqlCollection*) - Took 0.00034s 
amarok:             BEGIN: MySqlEmbeddedCollection::MySqlEmbeddedCollection(const QString&, const QString&) 
InnoDB: The InnoDB memory heap is disabled                                                                  
InnoDB: use atomic builtins.                                                                                
InnoDB: unit of spin count at ut_delay() is aligned to 43                                                   
amarok:                Connected to MySQL server 5.0.84-embedded                                            
amarok:                Initialized thread, count== 1                                                        
amarok:               BEGIN: void DatabaseUpdater::update()                                                 
amarok:                  Database version:  0                                                               
amarok:                 BEGIN: void DatabaseUpdater::createTables() const                                   
amarok:                    [ERROR!] GREPME MySQL query failed! Table 'admin' already exists  on  "CREATE TABLE admin (component VARCHAR(255), version INTEGER) ENGINE = MyISAM;"                                                                          
amarok:                    [ERROR!] GREPME MySQL query failed! Table 'devices' already exists  on  "CREATE TABLE devices (id INTEGER PRIMARY KEY AUTO_INCREMENT,type VARCHAR(255),label VARCHAR(255),lastmountpoint VARCHAR(255),uuid VARCHAR(255),servername VARCHAR(80),sharename VARCHAR(240)) ENGINE = MyISAM;"                                                                    
KCrash: Application 'amarok' crashing...                                                                                     
sock_file=/home/meister/.kde4/socket-MorkVomOrk/kdeinit4__0                                                                  

[2]+  Stopped                 amarok -d --nofork




this info any helpful?
Comment 21 Kevin Bowling 2009-11-18 23:30:54 UTC
The problem is that 2.2.1 needs MySQL 5.1.  Confirmed working/fixed with it.
Comment 22 Michael B 2009-11-19 17:24:34 UTC
 Kevin, if you got it working, do you have an ebuild you could add here ?
Comment 23 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-12-01 01:59:25 UTC
Please test amarok-2.2.1-r2 as it should fix this bug.
Comment 24 Marshall Banana 2009-12-01 19:02:58 UTC
(In reply to comment #23)
> Please test amarok-2.2.1-r2 as it should fix this bug.
> 
not so nice...

> emerge -uDNvp @system @world --with-bdeps=y

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-db/mysql-5.1*".
(dependency required by "virtual/mysql-5.1" [ebuild])        
(dependency required by "dev-perl/DBD-mysql-4.01.3" [installed])
(dependency required by "dev-db/mysql-5.0.84-r1" [installed])   
(dependency required by "media-sound/amarok-2.2.1-r2" [ebuild]) 
(dependency required by "@world" [argument])                    



and 
> emerge -ep =virtual/mysql-5.1

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-db/mysql-5.1*".
(dependency required by "virtual/mysql-5.1" [ebuild])
(dependency required by "=virtual/mysql-5.1" [argument])


and
> emerge -ep amarok

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-db/mysql-5.1*".
(dependency required by "virtual/mysql-5.1" [ebuild])
(dependency required by "x11-libs/qt-sql-4.6.0" [ebuild])
(dependency required by "kde-base/libkcddb-4.3.3" [ebuild])
(dependency required by "kde-base/kdemultimedia-kioslaves-4.3.3" [ebuild])
(dependency required by "media-sound/amarok-2.2.1-r2" [ebuild])
(dependency required by "amarok" [argument])
Comment 25 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-12-01 19:09:22 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > Please test amarok-2.2.1-r2 as it should fix this bug.
> > 
> not so nice...
> 
> > emerge -uDNvp @system @world --with-bdeps=y
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> 
> emerge: there are no ebuilds to satisfy "=dev-db/mysql-5.1*".
> (dependency required by "virtual/mysql-5.1" [ebuild])        
> (dependency required by "dev-perl/DBD-mysql-4.01.3" [installed])
> (dependency required by "dev-db/mysql-5.0.84-r1" [installed])   
> (dependency required by "media-sound/amarok-2.2.1-r2" [ebuild]) 
> (dependency required by "@world" [argument])                    
> 
> and 
> > emerge -ep =virtual/mysql-5.1
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> 
> emerge: there are no ebuilds to satisfy "=dev-db/mysql-5.1*".
> (dependency required by "virtual/mysql-5.1" [ebuild])
> (dependency required by "=virtual/mysql-5.1" [argument])

This issue is not related to this bug, but in any case, please post the output of emerge --info. What overlay(s) are you using that has mysql-5.1 ebuilds? The 5.1.41 ebuild I've added is still masked while I do some testing.
Comment 26 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-12-01 19:19:15 UTC
Please also add the output of emerge -uDpvt amarok
Comment 27 Marshall Banana 2009-12-01 19:32:58 UTC
hmmmmm, i only had virtual/mysql and dev-db/mysql in /etc/portage/package.unmask

after also adding dev-db/mysql-community and doing a
> emerge -C dev-db/mysql virtual/mysql
i at least would be able to update (part of) my world-tree (i am not using any overlays), but it is still bringing an error:

!!! One or more updates have been skipped due to a dependency conflict:

virtual/mysql:0

  ('ebuild', '/', 'virtual/mysql-5.1', 'merge') conflicts with
    =virtual/mysql-5.0 required by ('ebuild', '/', 'dev-db/mysql-5.0.84-r1', 'merge')


my emerge --info says:
Portage 2.2_rc54 (default/linux/x86/10.0, gcc-4.4.2, glibc-2.11-r0, 2.6.31-gentoo-r6 i686)
=================================================================                         
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 01 Dec 2009 18:00:23 +0000                                              
app-shells/bash:     4.0_p35                                                                    
dev-java/java-config: 2.1.9-r1                                                                  
dev-lang/python:     2.6.4, 3.1.1-r1                                                            
dev-util/cmake:      2.8.0                                                                      
sys-apps/baselayout: 2.0.1                                                                      
sys-apps/openrc:     0.5.2-r2                                                                   
sys-apps/sandbox:    2.2                                                                        
sys-devel/autoconf:  2.13, 2.64                                                                 
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                           
sys-devel/binutils:  2.20                                                                       
sys-devel/gcc-config: 1.4.1                                                                     
sys-devel/libtool:   2.2.6b                                                                     
virtual/os-headers:  2.6.30-r1                                                                  
ACCEPT_KEYWORDS="x86 ~x86"                                                                      
ACCEPT_LICENSE="* -@EULA"                                                                       
CBUILD="i686-pc-linux-gnu"                                                                      
CFLAGS="-O2 -march=prescott -mssse3 -pipe -fomit-frame-pointer"                                 
CHOST="i686-pc-linux-gnu"                                                                       
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"                                           
CXXFLAGS="-O2 -march=prescott -mssse3 -pipe -fomit-frame-pointer"                                                            
DISTDIR="/usr/portage/distfiles"                                                                                             
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch ~x86"                                                                                        
GENTOO_MIRRORS="http://mirror.its.uidaho.edu/pub/gentoo/ http://gentoo.mneisen.org/ ftp://mirror.its.uidaho.edu/gentoo/ ftp://mirror.cambrium.nl/pub/os/linux/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://de-mirror.org/distro/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"                                                                        
LDFLAGS="-Wl,-O1"                                                                                                            
LINGUAS="de en"                                                                                                              
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/local-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa audacious bash-completion battery bzip2 cdaudio cdda cddb chm cisco cli cpufreq cracklib crypt cups cvs dbus directfb dri dvb dvd dvdr dvdread evo fbcon fbsplash ffmpeg firefox firefox3 fortran ftp gdbm gif glut gpm grub gtk hal iconv ipv6 java javascript jpeg kde kde4 mmx mmxext mng modules mp3 mpeg mplayer msn mudflap ncurses networkmanager nls nptl nptlonly nsplugin opengl openmp oscar pam pcre perl pidgin png pppd python qt3support qt4 readline reflection rpm samba session sftp smp spl sse2 ssl ssse2 subversion svg sysfs tcpd truetype unicode v4l v4l2 vim vorbis wifi win32codecs wma x86 xcb xcomposite xorg xscreensaver zlib" ALSA_CARDS="hda-intel loopback" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel fbdev glint vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 28 Marshall Banana 2009-12-01 19:36:23 UTC
Created attachment 211712 [details]
output of emerge -uDpvt amarok
Comment 29 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-12-01 19:44:38 UTC
(In reply to comment #27)
> hmmmmm, i only had virtual/mysql and dev-db/mysql in
> /etc/portage/package.unmask

Please remove all mention of mysql-5.1 from package.unmask. Your dep resolution problem was caused by you unmasking them when there's no ebuild in the tree.


PS - The *experimental* 5.1.41 ebuild is only available in the overlay and should not be used until the testing is complete.
Comment 30 Magnus Lidbom 2009-12-01 19:46:54 UTC
(In reply to comment #23)
> Please test amarok-2.2.1-r2 as it should fix this bug.
> 

Works for me :) Thanks!

Comment 31 Marshall Banana 2009-12-01 19:52:04 UTC
> Please remove all mention of mysql-5.1 from package.unmask. Your dep resolution
> problem was caused by you unmasking them when there's no ebuild in the tree.

hehe, muuuuchas gracias :-) removed it all, everythings building right now...

will report back when everything is finished (which may take a while...)
Comment 32 Marshall Banana 2009-12-02 11:50:19 UTC
(In reply to comment #23)
> Please test amarok-2.2.1-r2 as it should fix this bug.
> 

houston, we have a running amarok with working library :-)
thanks alot for your effort!