Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 27763

Summary: strange loops when trying to install sendmail
Product: Portage Development Reporter: Mark Chappell <gentoo-bugs>
Component: CoreAssignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: net-mail
Priority: High    
Version: 2.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mark Chappell 2003-09-02 02:47:01 UTC
What I did

emerge --unmerge mta      
  # To get rid of ssmtp
emerge sendmail           
  # After this point ssmtp and procmail were installed (but not sendmail
emerge --unmerge ssmtp
  # To get rid of ssmtp so I could install sendmail
emerge sendmail
  # This finally worked

According to peitolm
"sendmail provides virtual/mta, but if you have mbox in USE, then it pulls in
procmail. which requires virtual/mta but at the dependancy checking, I think it
doesn't realise sendmail will provide it"

I haven't put mbox into the USE, so I'm assuming this is a default.

This is the third machine I've had this happen on.
Comment 1 Marius Mauch (RETIRED) gentoo-dev 2003-11-26 16:22:39 UTC

*** This bug has been marked as a duplicate of 1343 ***