Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 276253

Summary: media-video/vlc-0.9.9a-r1 fails to build looking for non-existing /usr/lib64/
Product: Gentoo Linux Reporter: Thomas Capricelli <orzel>
Component: Current packagesAssignee: Alexis Ballier <aballier>
Severity: normal CC: jcallen, media-video
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Thomas Capricelli 2009-07-02 15:23:29 UTC
The command "files libogg | grep" returns nothing... i have libogg.a, but not
I've tried to uninstall/re-install libogg... but still not .la. Now i'm stuck.

Here is the log for failed compilation of vlc :

flac.c:1098: warning: comparison between signed and unsigned integer expressions                                                                                                            
flac.c: In function ‘OpenEncoder’:                                                                                                                                                          
flac.c:1305: warning: passing argument 2 of ‘FLAC__stream_encoder_init_stream’ from incompatible pointer type                                                                               
/usr/include/FLAC/stream_encoder.h:1471: note: expected ‘FLAC__StreamEncoderWriteCallback’ but argument is of type ‘enum FLAC__StreamEncoderWriteStatus (*)(const struct FLAC__StreamEncoder *, const FLAC__byte *, unsigned int,  unsigned int,  unsigned int,  void *)’                                                                                                               
mv -f .deps/libflac_plugin_la-flac.Tpo .deps/libflac_plugin_la-flac.Plo                                                                                                                     
/bin/sh ../../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -std=gnu99 `top_builddir="../.." ../../vlc-config --cflags plugin` -march=native -O3 -pipe -msse3 -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -rpath '/usr/lib64/vlc/codec' -avoid-version -module -no-undefined -export-symbol-regex ^vlc_entry -shrext .so `top_builddir="../.." ../../vlc-config --ldflags plugin` -Wl,-O1 -o  libflac_plugin_la-flac.lo  `top_builddir="../.." ../../vlc-config -libs plugin` ../../src/                                                                                   
/bin/grep: /usr/lib64/ No such file or directory                                                                                                                                  
/bin/sed: can't read /usr/lib64/ No such file or directory                                                                                                                        
libtool: link: `/usr/lib64/' is not a valid libtool archive                                                                                                                        
make[5]: *** [] Error 1                                                                                                                                                    
make[5]: Leaving directory `/tmp/portage/media-video/vlc-0.9.9a-r1/work/vlc-0.9.9a/modules/codec'                                                                                           
make[4]: *** [all-recursive] Error 1                                                                                                                                                        
make[4]: Leaving directory `/tmp/portage/

Reproducible: Always

Portage 2.2_rc33 (default/linux/amd64/2008.0/developer, gcc-4.4.0, glibc-2.10.1-r0, 2.6.30 x86_64)
System uname: Linux-2.6.30-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.0.1
Timestamp of tree: Wed, 01 Jul 2009 01:00:20 +0000                                                
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                         
ccache version 2.4 [disabled]                                                                     
app-shells/bash:     4.0_p24                                                                      
dev-java/java-config: 2.1.8-r1                                                                    
dev-lang/python:     2.6.2-r1                                                                     
dev-python/pycrypto: 2.0.1-r8                                                                     
dev-util/ccache:     2.4-r8                                                                       
dev-util/cmake:      2.6.4                                                                        
sys-apps/baselayout: 2.0.1                                                                        
sys-apps/openrc:     0.4.3-r3                                                                     
sys-apps/sandbox:    2.0                                                                          
sys-devel/autoconf:  2.13, 2.63-r1                                                                
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                              
sys-devel/binutils:  2.19.1-r1                                                                    
sys-devel/gcc-config: 1.4.1                                                                       
sys-devel/libtool:   2.2.6a                                                                       
virtual/os-headers:  2.6.29                                                                       
ACCEPT_KEYWORDS="amd64 ~amd64"
Comment 1 Jonathan Callen (RETIRED) gentoo-dev 2009-07-02 15:46:56 UTC
Try running `lafilefixer --justfixit` from dev-util/lafilefixer.
Comment 2 Alexis Ballier gentoo-dev 2009-07-02 17:00:54 UTC

*** This bug has been marked as a duplicate of bug 275597 ***
Comment 3 Thomas Capricelli 2009-07-24 00:55:48 UTC
i ran lafilefixer --justfixit and i guess it fixed my problem. Now i have another error:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/libfreetype_plugin_la-freetype.o: relocation R_X86_64_PC32 against undefined symbol `GetStyleFromFontStack' can not be used when making a shared object; recompile with -fPIC                                                                                                                      
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value 
collect2: ld returned 1 exit status  
make[5]: *** [] Error 1
make[5]: *** Waiting for unfinished jobs....      "
Comment 4 Thomas Capricelli 2009-08-18 20:14:19 UTC
i still have this error. It now has a bug of it's own : #281963