Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 275889

Summary: app-portage/layman-1.2.3 does not install dev-util/subversion
Product: Gentoo Linux Reporter: Benny Pedersen <me>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED INVALID    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: dso log of the pronblem

Description Benny Pedersen 2009-06-30 01:47:12 UTC
dependice missing on this so warning gives me problem

Reproducible: Always

Steps to Reproduce:
1. emerge =app-portage/layman-1.2.3


Actual Results:  
show here that subversion miss with dso use flags, but its not installed at all

Expected Results:  
layman ebuild should install subversion if its not installed

in layman 1.1.1 subversion is installed all okay, maybe after 1.1.1 is installed 1.2.3 works ?, i have not verified this here
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-30 05:18:51 UTC
How about setting the "subversion" USE flag?
Comment 2 Benny Pedersen 2009-06-30 08:24:39 UTC
use flags works in 1.1.1 also, just not in 1.2.3 where dso is new
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-30 09:50:10 UTC
Works for me:

# USE="subversion" emerge -pqv layman
[ebuild  N    ] dev-util/subversion-1.6.2  USE="apache2 -bash-completion berkdb -ctypes-python -debug -doc dso -emacs -extras -gnome-keyring -java nls -perl -python -ruby -sasl -test -vim-syntax webdav-neon -webdav-serf"
[ebuild   R   ] app-portage/layman-1.2.3  USE="-git subversion* -test"

Please check your /etc/portage/package.use and your /etc/make.conf file. Maybe you have the subversion USE flag unset by mistake...
Comment 4 Wormo (RETIRED) gentoo-dev 2009-07-02 07:08:43 UTC
Please post your 'emerge --info' output, and also 'emerge -pv layman' like Lars did...
Comment 5 Benny Pedersen 2009-07-06 01:11:43 UTC
found that if subversion is emerged with dso then it fails to install layman 1.2.3, if subversion is emerged with -dso then all works

problem is that layman 1.2.3 handle this case badly

Comment 6 Benny Pedersen 2009-07-06 01:14:13 UTC
#3 also with dso use on subversion ?

Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-06 19:21:42 UTC
Please attach build log containing any failures.
Comment 8 Benny Pedersen 2009-07-06 19:45:36 UTC
there is no failure if subversion is build with -dso

just verify it please :)
Comment 9 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-06 20:54:15 UTC
I use Subversion with USE="dso" and I'm not able to reproduce any problem which could be reproduced by using layman.
Comment 10 Benny Pedersen 2009-07-06 22:09:06 UTC
Created attachment 196968 [details]
dso log of the pronblem

emerge -puDNvt world 2>&1 | less press s to save got this log
Comment 11 Benny Pedersen 2009-07-06 22:11:25 UTC
i need to reopen it ?
Comment 12 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-07 01:56:50 UTC
You misunderstood message printed by emerge.