Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 274782

Summary: net-misc/wicd-1.6.0-r1 doesn't want to get IP
Product: Gentoo Linux Reporter: Casufi <vladimirkotulskiy>
Component: Current packagesAssignee: Thomas Kahle (RETIRED) <tomka>
Severity: normal CC: c1pher, esigra, fbonelle.div, swdrumm
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard: Unknown problem with dhclient, upstream is aware of issues. Not Gentoo specific
Package list:
Runtime testing required: ---
Attachments: emerge --info
equery files net-misc/dhcp

Description Casufi 2009-06-20 10:58:15 UTC
I am using net-misc/wicd-1.6.0-r1 and net-misc/dhcp-3.1.1. When I trying to connect to WiFi network wicd doesn't want to get IP address from DHCP server, dhclient get IP without problem when I run it manualy

Reproducible: Always
Comment 1 Casufi 2009-06-20 10:59:59 UTC
Here id WICD log

2009/06/20 13:47:28 :: domain is None
2009/06/20 13:47:28 :: search domain is None
2009/06/20 13:47:28 :: setting automatically reconnect when connection drops False
2009/06/20 13:47:28 :: Setting dhcp client to 1
2009/06/20 13:47:28 :: Wireless configuration file found...
2009/06/20 13:47:28 :: Wired configuration file found...
2009/06/20 13:47:28 :: chmoding configuration files 0600...
2009/06/20 13:47:28 :: chowning configuration files root:root...
2009/06/20 13:47:28 :: Using wireless interface...ath0
2009/06/20 13:47:28 :: Using wired interface...eth0
2009/06/20 13:47:39 :: Connecting to wireless network UlskiyHome
2009/06/20 13:47:39 :: Putting interface down
2009/06/20 13:47:39 :: Releasing DHCP leases...
2009/06/20 13:47:39 :: Setting false IP...
2009/06/20 13:47:39 :: Stopping wpa_supplicant
2009/06/20 13:47:39 :: Flushing the routing table...
2009/06/20 13:47:39 :: Putting interface up...
2009/06/20 13:47:39 :: Generating psk...
2009/06/20 13:47:39 :: Attempting to authenticate...
2009/06/20 13:47:42 :: Running DHCP
2009/06/20 13:47:42 :: Internet Systems Consortium DHCP Client V3.1.1-Gentoo
2009/06/20 13:47:42 :: Copyright 2004-2008 Internet Systems Consortium.
2009/06/20 13:47:42 :: All rights reserved.
2009/06/20 13:47:42 :: For info, please visit
2009/06/20 13:47:42 ::
2009/06/20 13:47:42 :: wifi0: unknown hardware address type 801
Comment 2 Casufi 2009-06-20 11:00:47 UTC

DHCP client log
Jun 20 13:47:39 [dhclient] Listening on LPF/ath0/00:16:e3:99:00:0d
Jun 20 13:47:39 [dhclient] Sending on   LPF/ath0/00:16:e3:99:00:0d
Jun 20 13:47:39 [dhclient] Sending on   Socket/fallback
Jun 20 13:47:39 [dhclient] DHCPRELEASE on ath0 to port 67
Jun 20 13:47:39 [dhclient] send_packet: Network is unreachable
Jun 20 13:47:39 [dhclient] send_packet: please consult README file regarding broadcast address.
Jun 20 13:47:42 [dhclient] Internet Systems Consortium DHCP Client V3.1.1-Gentoo
Jun 20 13:47:42 [dhclient] Copyright 2004-2008 Internet Systems Consortium.
Jun 20 13:47:42 [dhclient] All rights reserved.
Jun 20 13:47:42 [dhclient] For info, please visit
Jun 20 13:47:42 [dhclient] wifi0: unknown hardware address type 801
Comment 3 Casufi 2009-06-20 11:02:18 UTC
Here is dhclient log when I run it manualy

casufi / # dhclient
Internet Systems Consortium DHCP Client V3.1.1-Gentoo
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/eth0/00:16:36:ab:d0:86
Sending on   LPF/eth0/00:16:36:ab:d0:86
Listening on LPF/wifi0/
Sending on   LPF/wifi0/
Listening on LPF/ath0/00:16:e3:99:00:0d
Sending on   LPF/ath0/00:16:e3:99:00:0d
Sending on   Socket/fallback
DHCPDISCOVER on wifi0 to port 67 interval 7
DHCPREQUEST on ath0 to port 67
bound to -- renewal in 292387 seconds.
Comment 4 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2009-06-24 17:14:19 UTC
Please post your "emerge --info" as well as the output of

  emerge -qpv wicd dhcp dhclient
Comment 5 Casufi 2009-06-24 18:28:25 UTC
Created attachment 195679 [details]
emerge --info

casufi casufi # emerge -qpv wicd dhcp dhclient
emerge: there are no ebuilds to satisfy "dhclient".

casufi casufi # emerge -qpv wicd dhcp         
[ebuild   R   ] net-misc/dhcp-3.1.1  USE="-doc -minimal (-selinux) -static" 
[ebuild   R   ] net-misc/wicd-1.6.0-r1  USE="libnotify ncurses pm-utils -ioctl"
Comment 6 Casufi 2009-06-24 18:28:54 UTC
Created attachment 195680 [details]
equery files net-misc/dhcp
Comment 7 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2009-06-25 07:49:42 UTC
Heh... got me. I'm using dhcpcd and thought, dhclient would have its own package, too :)
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2009-06-26 20:24:46 UTC
There is an unknown bug with wicd/dhclient that some people have problems with. We cannot identify it yet. I suspect your problem will go away with dhcpcd if you are not opposed to switching. Mind trying and reporting back?
Comment 9 Taiyang Chen 2009-07-05 19:16:32 UTC
I can confirm the same problem with dhclient-3.1.1 and wicd-1.6.1.
Switching to dhcpcd fixed the problem... thanks!
Comment 10 John (EBo) David 2009-07-30 23:56:26 UTC
I just started playing with wicd and have the same problem, but for me changing the wicd-client preferences from "Automatic" to "dhcpcd" did not help.

=========== emerge --info ==============

Portage (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.30-tuxonice-r4 i686)
System uname: Linux-2.6.30-tuxonice-r4-i686-Intel-R-_Pentium-R-_Dual_CPU_T2330_@_1.60GHz-with-glibc2.0
Timestamp of tree: Wed, 29 Jul 2009 07:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.4.6, 2.5.4-r3
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="ccache distlocks fixpackages metadata-transfer nostrip parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/science /usr/local/portage/layman/pd-overlay /usr/local/portage/layman/sunrise /home/ebo/gtd/projects/computer/local_portage/ref/local-portage"
SYNC=" rsync://"
USE="3dnow X a52 aac acl acpi alsa arts audiofile bash-completion berkdb blas blender-game bluetooth branding bzip2 cairo cdr cli clisp cmucl cracklib crypt css cups curl cvs dbus divx dri dvd dvdr dvdread eds emacs emboss encode esd evo fam ffmpeg fftw firefox fits flac fortran ft2232 ftdi ftp gcl gd gdbm geos gif gimp git gmedia gnome gpg gpm graphviz gstreamer gtk hal haskell hddtemp hdf5 iconv ieee1394 ipod ipv6 ipw3945 isdnlog jack java java6 javascript jpeg jpeg2k kde lapack laptop latex ldap libnotify lm_sensors lzf lzo mad midi mikmod mp3 mpeg mudflap ncurses netcdf nls nptl nptlonly nsplugin ogdi ogg openal opengl openmp osc pam parport pcre pdf perl php png portaudio postgres ppds pppd python qt3 qt3support qt4 quicktime readline realmedia reflection sasl sbcl scanner sdl session snmp spell spl sql ssl startup-notification subversion svg sysfs tcl tcpd theora threads tiff tk truetype unicode usb vorbis wavpack win32codecs wmf wmp x86 xcb xine xinerama xml xorg xpm xprint xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hpp1006" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="i810 v4l vesa"
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2009-08-23 14:07:01 UTC
*** Bug 282409 has been marked as a duplicate of this bug. ***
Comment 12 Chris Bruner 2009-12-30 07:52:02 UTC
A further clue for you. I was having this problem, and when I did an
/etc/init.d/net.eth1 status
the result was crashed.

I upgraded the wicd to 1.7.0_alpha3 and it started working. 

Although the status remains at crashed.
Also the icon isn't showing in the task bar.
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2010-12-20 23:50:54 UTC
assigning to new maintainer.
Comment 14 Thomas Kahle (RETIRED) gentoo-dev 2011-04-19 14:54:58 UTC
Long time since this bug was opened, I remember having it myself and don't have it anymore.  Does it still apply for you in the latest version?  Please reopen if yes.