Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 273446

Summary: Dependancy problem with emerge and qt
Product: Gentoo Linux Reporter: Pierre <pierre42d>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED TEST-REQUEST    
Severity: normal CC: SebastianLuther
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Pierre 2009-06-09 23:10:55 UTC
# emerge -uavDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=x11-libs/qt-3.3.8-r3".
(dependency required by "media-sound/yammi-1.2.3" [installed])
(dependency required by "world" [argument])
Comment 1 Rafał Mużyło 2009-06-09 23:45:39 UTC
When did you sync last ?
Did you mask qt-3.3.8b-r1 ?
What ebuilds for qt3 are in your tree ?

In short I suspect it's INVALID.
Comment 2 Pierre 2009-06-10 06:05:20 UTC
I just synced before.

I didn't mask any version of Qt

# ls -a /usr/portage/x11-libs/qt/*.ebuild
/usr/portage/x11-libs/qt/qt-3.3.8b-r1.ebuild
/usr/portage/x11-libs/qt/qt-4.4.2.ebuild
/usr/portage/x11-libs/qt/qt-4.5.1.ebuild


I first think of a sync problem but I got this for a week...
Comment 3 Sebastian Luther (few) 2009-06-10 10:17:32 UTC
yammi is no longer in the tree, remove it. If this doen't fix your issue, try emerge --deselect qt (you shouldn't have this in your world file). If you need more help, post your emerge --info, grep qt /var/lib/portage/world and the new output of emerge -uavDN world.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-13 19:38:19 UTC
Please try what Sebastian suggested and in case that doesn't help, feel free to reopen this bug.
Comment 5 Pierre 2009-09-08 16:10:41 UTC
yammi has been removed