Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 271464

Summary: [PATCH] games-puzzle/enigma-1.01 fails to compile with glibc-2.10.1
Product: Gentoo Linux Reporter: Martin Väth <martin>
Component: [OLD] GamesAssignee: Gentoo Games <games>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 270353    
Attachments: Fix compilation with glibc-2.10.1

Description Martin Väth 2009-05-27 20:36:11 UTC
Since glibc-2.10.1 has a typesafe strchr(), a "const" has to be added
to make engima-1.01 compile with it.
Comment 1 Martin Väth 2009-05-27 20:37:10 UTC
Created attachment 192640 [details, diff]
Fix compilation with glibc-2.10.1
Comment 2 Tupone Alfredo gentoo-dev 2009-05-28 07:55:21 UTC
Fixed in portage. Thanks for report and patch