Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 270638

Summary: [4.4 - ICE] media-video/mplayer-1.0_rc2_p20090322 fails to build with sys-devel/gcc-4.4
Product: Gentoo Linux Reporter: Evan Teran <evan.teran>
Component: [OLD] UnspecifiedAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, jlp.bugs, media-video, vostorga
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://gcc.gnu.org/PR39543
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 249226    
Attachments: stable version build lot
latest build lof
gcc44-PR39543.patch

Description Evan Teran 2009-05-20 22:46:15 UTC
I've tried to build both the stable version of mplayer-1.0_rc2_p28450 and the latest mplayer-1.0_rc2_p20090322. Both fail to build with gcc-4.4. The errors are similar but not the same.

Basically, both fail with impossible asm constraint errors.

Reproducible: Always




Portage 2.2_rc28 (default/linux/x86/2008.0/desktop, gcc-4.4.0, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 i686)
=================================================================                                            
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-gentoo-1.12.11.1   
Timestamp of tree: Wed, 20 May 2009 22:30:01 +0000                                                           
app-shells/bash:     3.2_p39                                                                                 
dev-java/java-config: 2.1.7                                                                                  
dev-lang/python:     2.6.2                                                                                   
dev-util/cmake:      2.6.2-r1                                                                                
sys-apps/baselayout: 1.12.11.1                                                                               
sys-apps/sandbox:    1.6-r2                                                                                  
sys-devel/autoconf:  2.13, 2.63                                                                              
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                        
sys-devel/binutils:  2.18-r3                                                                                 
sys-devel/gcc-config: 1.4.1                                                                                  
sys-devel/libtool:   1.5.26                                                                                  
virtual/os-headers:  2.6.27-r2                                                                               
ACCEPT_KEYWORDS="x86"                                                                                        
CBUILD="i686-pc-linux-gnu"                                                                                   
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"                                                        
CHOST="i686-pc-linux-gnu"                                                                                    
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"                                                                                                             
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                   
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"                                                                                            
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="   "
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa apache2 arts avahi bash-completion berkdb bluetooth boost branding bzip2 cairo captury cdr chroot cleartype cli cracklib crypt cups curl cvs dbus debugger dell dhcp divx doc dri dvd dvdr dvdread eds emboss encode esd evo examples expat fam fat ffmpeg firefox flac gdbm gif glibc-omitfp glitz gmp gnome gnutls google-gadgets gpm graphite graphviz gstreamer gtk hal htmlhandbook iconv imagemagick innodb inotify ipod ipv6 ipw3945 isdnlog jadetex java java6 jpeg jpeg2k kde kdeprefix kpathsea kqemu lame ldap lesstif libnotify libwww lm_sensors mad mdnsresponder-compat midi mikmod mjpeg mmap mmx mng mono mp3 mp4 mpeg mpeg2 mplayer mudflap mysql ncurses network-cron nls nptl nptlonly nsplugin ntfs nvidia ogg openal openexr opengl openmp openssl oss pam pango pcap pch pcre pdf perl phonon php physfs plasma pmu png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection rss rtc samba sdk sdl session smp sockets spell spl sqlite sqlite3 sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcl tcpd templates theora threads thumbnail tiff tivo tk truetype unicode usb userlocales utempter v4l vcd vim-syntax vnc vorbis webkit wifi win32codecs wireshark wmf wmp wxwindows x86 xanim xcomposite xft xine xinerama xml xorg xpm xrandr xrender xscreensaver xulrunner xv xvid zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Evan Teran 2009-05-20 22:48:53 UTC
Created attachment 191957 [details]
stable version build lot
Comment 2 Evan Teran 2009-05-20 22:49:08 UTC
Created attachment 191959 [details]
latest build lof
Comment 3 Mike Auty gentoo-dev 2009-05-20 23:18:58 UTC
Please don't include bzip logs, whilst it will save a tiny bit of space, it makes it much more difficult for people to read directly, and it can create mime issues (the attachments were listed as text/plain)...
Comment 4 Mike Auty gentoo-dev 2009-05-20 23:20:52 UTC
Also, there's been report of a successful compilation (although failure to run) under gcc-4.4.0 in bug 269975...
Comment 5 Evan Teran 2009-05-20 23:23:40 UTC
Yea, I would guess this an x86 (and possibly core2) specific issue since it involves inline asm. The other bug is for x86-64 which would obviously have different inline assembly needs.
Comment 6 VĂ­ctor Ostorga (RETIRED) gentoo-dev 2009-05-23 20:58:00 UTC
This bug is related with http://gcc.gnu.org/ml/gcc-bugs/2009-05/msg00633.html which is reported in http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39543 and fixed in gcc 4.4.1
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2009-05-30 23:44:50 UTC
Created attachment 193024 [details, diff]
gcc44-PR39543.patch
Comment 8 Mark Loeser (RETIRED) gentoo-dev 2009-07-24 18:12:22 UTC
Should be fixed with gcc-4.4.1