|Summary:||x11-libs/libXt-1.0.5 problems with WANT_AUTOMAKE|
|Product:||Gentoo Linux||Reporter:||Diego Elio Pettenò (RETIRED) <flameeyes>|
|Component:||Eclasses||Assignee:||Gentoo X packagers <x11>|
|Severity:||normal||CC:||360404, juliandimitrov, orionbelt2|
|Package list:||Runtime testing required:||---|
|Bug Depends on:|
Description Diego Elio Pettenò (RETIRED) 2009-05-15 23:57:45 UTC
Not sure what is it that makes it break this way, but right now it does not build when automake-1.9 is not installed in the system, failing aclocal because of this: ***** aclocal ***** ***** PWD: /var/tmp/portage/x11-libs/libXt-1.0.5/work/libXt-1.0.5 ***** aclocal am-wrapper: warning: invalid WANT_AUTOMAKE 'latest'; ignoring. am-wrapper: /usr/bin/aclocal-1.9 is missing or not executable. Please try emerging the correct version of automake.
Comment 1 Sebastian Luther (few) 2009-05-16 07:18:22 UTC
*** Bug 270019 has been marked as a duplicate of this bug. ***
Comment 2 Sebastian Luther (few) 2009-05-18 06:14:21 UTC
*** Bug 270197 has been marked as a duplicate of this bug. ***
Comment 3 Rémi Cardona 2009-05-18 07:30:40 UTC
I've added WANT_AUTOMAKE="1.9" to the ebuild without a revbump. That ought to fix it... Thanks
Comment 4 Diego Elio Pettenò (RETIRED) 2009-05-18 10:27:04 UTC
You *did* confirm it doesn't work with 1.10 didn't you?
Comment 5 Rémi Cardona 2009-05-18 10:42:57 UTC
Well... that's what this bug was about, wasn't it?
Comment 6 Diego Elio Pettenò (RETIRED) 2009-05-18 10:49:42 UTC
Uh, no, the bug was with some bad interaction (afaics) between x-modular and autotools eclasses...
Comment 7 orionbelt2 2012-02-12 06:30:19 UTC
Problem seems to have reappeared. I was updating world today, which pulled in net-nds/openldap-2.4.24 , which failed to run aclocal in the prepare phase: * Running aclocal ... [ !! ] * Failed Running aclocal ! * * Include in your bugreport the contents of: * * /var/tmp/portage/net-nds/openldap-2.4.24/temp/aclocal.out * ERROR: net-nds/openldap-2.4.24 failed (prepare phase): * Failed Running aclocal ! % cat /var/tmp/portage/net-nds/openldap-2.4.24/temp/aclocal.out ***** aclocal ***** ***** PWD: /var/tmp/portage/net-nds/openldap-2.4.24/work/openldap-2.4.24 ***** aclocal am-wrapper: warning: invalid WANT_AUTOMAKE 'none'; ignoring. am-wrapper: /usr/bin/aclocal-1.9 is missing or not executable. Please try emerging the correct version of automake. % equery list automake * Searching for automake ... [IP-] [ ] sys-devel/automake-1.11.1:1.11 Why require automake-1.9 when automake-1.11 is the current version? Is 1.9 really needed?
Comment 8 orionbelt2 2012-02-18 03:17:21 UTC
A few days after i submitted my comment, automake-1.9 was reinstalled in a separate SLOT from 1.11, and the problem disappeared. I suppose it was discussed and fixed in some other bug thread ;)