Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 269260

Summary: sys-devel/binutils-2.19.1-r1[gold] fails to compile with gcc-4.4 due to missing include
Product: Gentoo Linux Reporter: Zeev Tarantov <zeev.tarantov>
Component: New packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED FIXED    
Severity: normal CC: ansla80, cruzki123, esigra, jlp.bugs
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 269315, 249226    
Attachments: Foo

Description Zeev Tarantov 2009-05-10 13:55:35 UTC
doesn't build in ~amd64 gentoo on a core2.

Reproducible: Always

Steps to Reproduce:
1. try to emerge
2.
3.

Actual Results:  
libtool: link: creating libopcodes.la
if x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold -I. -I/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold -I/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/../include -I/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/../elfcpp -DLOCALEDIR="\"/usr/share/binutils-data/x86_64-pc-linux-gnu/2.19.1/locale\"" -DBINDIR="\"/usr/x86_64-pc-linux-gnu/binutils-bin/2.19.1\"" -DTOOLBINDIR="\"/usr/x86_64-pc-linux-gnu/bin\""    -W -Wall   -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -frandom-seed=compressed_output.o -g -O2 -pipe -march=core2 -MT compressed_output.o -MD -MP -MF ".deps/compressed_output.Tpo" -c -o compressed_output.o /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/compressed_output.cc; \
        then mv -f ".deps/compressed_output.Tpo" ".deps/compressed_output.Po"; else rm -f ".deps/compressed_output.Tpo"; exit 1; fi
libtool: link: ( cd ".libs" && rm -f "libopcodes.la" && ln -s "../libopcodes.la" "libopcodes.la" )
libtooldir=`/bin/sh ./libtool --config | sed -n -e 's/^objdir=//p'`; \
        if [ -f $libtooldir/libopcodes.a ]; then \
          cp $libtooldir/libopcodes.a libopcodes.tmp; \
          x86_64-pc-linux-gnu-ranlib libopcodes.tmp; \
          /bin/sh /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/opcodes/../move-if-change libopcodes.tmp libopcodes.a; \
        else true; fi
In file included from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/common.cc:28:
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/mapfile.h:65: error: 'uint64_t' has not been declared
In file included from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:37,
                 from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/layout.h:32,
                 from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/common.cc:29:
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script-sections.h:179: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script-sections.h:180: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script-sections.h:180: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script-sections.h:181: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script-sections.h:210: error: 'uint64_t' does not name a type
In file included from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/layout.h:32,
                 from /var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/common.cc:29:
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:74: error: 'uint64_t' does not name a type
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:87: error: 'uint64_t' does not name a type
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:95: error: 'uint64_t' does not name a type
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:112: error: 'uint64_t' does not name a type
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:218: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:226: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:236: error: 'uint64_t' has not been declared
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/gold/script.h:242: error: 'uint64_t' has not been declared
touch stamp-lib
make[4]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/opcodes'
make[3]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/opcodes'
make[2]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/opcodes'



emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.30-rc4 x86_64)
=================================================================
System uname: Linux-2.6.30-rc4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.0.0
Timestamp of tree: Sun, 10 May 2009 11:15:01 +0000
app-shells/bash:     4.0_p17-r1
dev-lang/python:     2.6.2
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-g -O2 -pipe -march=core2 -momit-leaf-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-g -O2 -pipe -march=core2 -momit-leaf-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.hamakor.org.il/pub/mirrors/gentoo/ "
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--enable-new-dtags"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gcc-porting /usr/local/portage/layman/mozilla /usr/local/portage"
SYNC="rsync://mirror.hamakor.org.il/gentoo-portage"
USE="X acl acpi alsa amd64 bash-completion bidi bluetooth branding bzip2 cairo cdr cli cracklib crypt dbus dri dvd dvdr dvdread eds emboss encode evo fam firefox gif gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde libnotify mad midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly offensive ogg opengl openmp pam pch pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sqlite3 sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis xcb xcomposite xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Zeev Tarantov 2009-05-10 20:40:11 UTC
I guess it has to do with gcc4.4
I have unmasked and successfully installed =sys-devel/binutils-2.19.51.0.4 instead.
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2009-05-10 20:45:28 UTC
looks like a missing #include <stdint.h>
Comment 4 Samuli Suominen gentoo-dev 2009-08-11 08:49:19 UTC
(In reply to comment #3)
> http://sourceware.org/ml/binutils/2009-01/msg00355.html
> 

Thanks.

The link provides a directive (patch) for fixing this. Are we going to apply it, or are we going to wait for a new binutils release? I don't think the gold is so important it should block the GCC unmasking but it would be nice to see this fixed in tree beforehand. I'd do that but a) I'm not sure if I'm allowed. b) I'm not sure how to wrap a binutils patchset so it'll please everyone, since I haven't done so before.
Comment 5 Samuli Suominen gentoo-dev 2009-08-12 14:24:32 UTC
Created attachment 201031 [details, diff]
Foo

From the above link. There was one rejected chunk, object.cc, there's no such line in 2.19.1 to add the = NULL; to. Doesn't seem fatal.
Comment 6 SpanKY gentoo-dev 2009-09-09 06:37:50 UTC
added patch to 2.19.1 patchset, thanks