Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 269245

Summary: [PATCH] media-libs/amanith-0.3-r2 fails to emerge with GCC 4.4
Product: Gentoo Linux Reporter: 404 Error <404errorqc>
Component: [OLD] GCC PortingAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, vostorga
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 249226    
Attachments: build.log
Patch allowing media-libs/amanith-0.3-r2 to build against gcc 4.4

Description 404 Error 2009-05-10 13:15:44 UTC
When emerged, the package compilation fails:

In file included from ../src/2d/gtesselator2d.cpp:29:
../include/amanith/2d/gtesselator2d.h:167: error: 'std::FILE' has not been declared
../include/amanith/2d/gtesselator2d.h:168: error: 'std::FILE' has not been declared
../src/2d/gtesselator2d.cpp:60: error: expected constructor, destructor, or type conversion before '*' token
../src/2d/gtesselator2d.cpp:88: error: variable or field 'DebugOpenFile' declared void
../src/2d/gtesselator2d.cpp:88: error: 'FILE' is not a member of 'std'
../src/2d/gtesselator2d.cpp:88: error: 'File' was not declared in this scope
../src/2d/gtesselator2d.cpp:88: error: expected primary-expression before 'const'
../src/2d/gtesselator2d.cpp:2624: error: expected '}' at end of input
../src/2d/gtesselator2d.cpp:57: warning: 'Amanith::gPrecisionSquared' defined but not used
make[1]: *** [gtesselator2d.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from ../include/amanith/gelement.h:33,
                 from ../include/amanith/1d/gcurve1d.h:32,
                 from ../include/amanith/1d/gmulticurve1d.h:37,
                 from ../include/amanith/1d/ghermitecurve1d.h:37,
                 from ../include/amanith/gproperty.h:32,
                 from ../include/amanith/gmultiproperty.h:32,
                 from ../src/2d/ganimtrsnode2d.cpp:29:
../include/amanith/geometry/ginterval.h:135: warning: type qualifiers ignored on function return type
In file included from ../include/amanith/1d/gcurve1d.h:32,
                 from ../include/amanith/1d/gmulticurve1d.h:37,
                 from ../include/amanith/1d/ghermitecurve1d.h:37,
                 from ../include/amanith/gproperty.h:32,
                 from ../include/amanith/gmultiproperty.h:32,
                 from ../src/2d/ganimtrsnode2d.cpp:29:
../include/amanith/gelement.h:458: warning: type qualifiers ignored on function return type
../include/amanith/gelement.h:832: warning: type qualifiers ignored on function return type
../src/2d/gfont2d.cpp: In member function 'int Amanith::GFontCharContour2D::IntersectionsCount(const Amanith::GRay2&) const':
../src/2d/gfont2d.cpp:532: warning: 'u0' may be used uninitialized in this function
../src/2d/gfont2d.cpp:532: warning: 'u1' may be used uninitialized in this function
make[1]: Leaving directory `/var/tmp/portage/media-libs/amanith-0.3-r2/work/amanith/build'
make: *** [sub-build-make_default-ordered] Error 2
 * 
 * ERROR: media-libs/amanith-0.3-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2811:  Called die
 * The specific snippet of code:
 *       emake || die
 *  The die message:
 *   (no error message)



Reproducible: Always

Steps to Reproduce:




Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.30-rc5 x86_64)
=================================================================
System uname: Linux-2.6.30-rc5-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 09 May 2009 21:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -msse4"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -msse4"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://localhost/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en fr"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/nx /usr/local/portage/layman/enlightenment /usr/local/portage/layman/mozilla /usr/local/portage/layman/dotnet /usr/local/portage/layman/emacs /usr/local/portage/layman/gentoo-quebec"
SYNC="rsync://localhost/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cddb cdio cdr chardet cli cracklib crypt cups dbus dirac dri dts dvd dvdr dvdread dvi eds emboss encode esd evo fam ffmpeg flac fortran ftp gdbm gif glib gnome gpm gstreamer gtk gtk2 hal hvm iconv isdnlog jack java jpeg jpeg2k kde kdeprefix kerberos kpathsea ldap libnotify mad midi mikmod mmx mp2 mp3 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly nswrapper objc objc++ objc-gc ogg openal opengl openmp oss pam pcre pdf perl png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcl tcpd theora threads tiff tk truetype unicode usb vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr" USERLAND="GNU" VIDEO_CARDS="vesa radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 404 Error 2009-05-10 13:16:49 UTC
The issue does not occur with GCC 4.3.3, although lots of warnings are displayed
Comment 2 404 Error 2009-05-10 13:17:41 UTC
Created attachment 190837 [details]
build.log
Comment 3 VĂ­ctor Ostorga (RETIRED) gentoo-dev 2009-05-20 17:29:04 UTC
Created attachment 191913 [details, diff]
Patch allowing media-libs/amanith-0.3-r2 to build against gcc 4.4
Comment 4 404 Error 2009-07-19 19:08:04 UTC
Compiles and install fine with the patch. Lots of warning are displayed but it seems to work.
Comment 5 Samuli Suominen gentoo-dev 2009-07-19 19:18:49 UTC
+  19 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> amanith-0.3-r2.ebuild,
+  +files/amanith-0.3-gcc44.patch:
+  Fix building with GCC 4.4 wrt #269245, thanks to Victor Ostorga.
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-20 00:12:34 UTC
*** Bug 269247 has been marked as a duplicate of this bug. ***