Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 266966

Summary: app-editors/mousepad-0.2.14: failed compiling 'cause of missing intltool dependency (dev-perl/XML-Parser)
Product: Gentoo Linux Reporter: ernsteiswuerfel <erhard_f>
Component: Current packagesAssignee: XFCE Team <xfce>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description ernsteiswuerfel 2009-04-21 10:11:42 UTC
Fails to compile on a fresh & clean gentoo system because a dependency of intltool isn't satisfied.

Reproducible: Always

Steps to Reproduce:
1. emerge -D xfce4
2.
3.

Actual Results:  
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool



supah ef # emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-x86_64-AMD_Phenom-tm-_9500_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Mon, 20 Apr 2009 06:30:17 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -Os -mtune=amdfam10 -march=amdfam10 -fomit-frame-pointer -fivopts -ftree-loop-im -ftree-loop-linear -minline-stringops-dynamically"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-pipe -Os -mtune=amdfam10 -march=amdfam10 -fomit-frame-pointer -fivopts -ftree-loop-im -ftree-loop-linear -minline-stringops-dynamically"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ "
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,-z,now -Wl,--sort-common -Wl,--as-needed -Wl,-S"
LINGUAS="de en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 amr audacious bash-completion berkdb bluetooth bzip2 cairo caps cli cracklib crypt cups custom-cflags custom-cxxflags dbus djvu dri dts dvd dvdr dvdread dvi enca exif fam flac foomaticdb fortran gdbm gnutls gtk hal iconv ipv6 isdnlog ithreads java6 jbig joystick jpeg jpeg2k kerberos libnotify libsamplerate live lm_sensors lzma mad matroska midi mmap mmx mmxext mng mozsvg mp3 mp4 mudflap multilib musepack nas ncurses nls no-old-linux nptl nptlonly nsplugin ntfs ogg ogm openmp pam pcre perl png ppds pppd pulseaudio python readline reflection rle rtc schroedinger session speex spl sse sse2 sse3 ssl svg sysfs tcpd theora threads tiff tivo truetype unicode usb vorbis wavpack wmf x264 xmp xorg xulrunner xv xvid xvmc zlib zoran" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="fbdev radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Christoph Mende (RETIRED) gentoo-dev 2009-04-23 19:58:21 UTC
mousepad depends on intltool and intltool depends on XML-Parser... I suspect something else is broken on your side
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-01 03:57:08 UTC
Yup, makes no sense to me. The only additional bit of info I can offer is to expand on the last comment:

mousepad requires intltool to build only. intltool requires XML-Parser to *run* so if intltool is installed, XML-Parser will always be on the system.

Feel free to re-open if you have any additional info. As for now, this will go nowhere so I'm going to resolve it.
Comment 3 Samuli Suominen gentoo-dev 2014-04-09 07:03:41 UTC

*** This bug has been marked as a duplicate of bug 41124 ***