Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 266859

Summary: Multiple package readline
Product: Gentoo Linux Reporter: Petr Skarka <p.skarka>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED INVALID    
Severity: normal CC: darkside, felix
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Petr Skarka 2009-04-20 14:43:57 UTC
When I merge world

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  ('ebuild', '/', 'sys-libs/readline-6.0', 'merge') pulled in by
    sys-libs/readline required by system
    sys-libs/readline:0 required by world
    sys-libs/readline required by world
    (and 16 more)

  ('installed', '/', 'sys-libs/readline-5.2_p13', 'nomerge') pulled in by
    =sys-libs/readline-5* required by ('installed', '/', 'dev-lang/ghc-6.8.2', 'nomerge')
    (and 19 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-20 14:50:02 UTC
Your emerge --info would help clarify many points. Please post that.

stable ghc explicitly requires =readline-5*, readline-6 is in the ~arch tree. The output below implies that you are mixing stable and ~arch, this is generally bad and cannot easily be supported. ~arch ghc requires >=readline-5 if the binary USE flag is set.
Comment 2 Petr Skarka 2009-04-20 15:04:08 UTC
After upgrade readline to 6.0

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  ('ebuild', '/', 'sys-libs/readline-5.2_p13', 'merge') pulled in by
    =sys-libs/readline-5* required by ('installed', '/', 'dev-lang/ghc-6.8.2', 'nomerge')
    (and 19 more)

  ('installed', '/', 'sys-libs/readline-6.0', 'nomerge') pulled in by
    sys-libs/readline required by system
    sys-libs/readline required by world
    sys-libs/readline:0 required by world
    (and 16 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

----------------

Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r7-i686-Intel-R-_Celeron-R-_CPU_2.70GHz-with-gentoo-2.0.0
Timestamp of tree: Thu, 16 Apr 2009 14:45:01 +0000
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r15, 2.5.4-r2, 2.6.1-r1
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-mtune=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks fixpackages mstadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="cs_CZ"
LDFLAGS="-Wl,-O1"
LINGUAS="en cs"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dfx 3dnow 3dnowext X accessibility acl acpi alsa apache2 apm avahi berkdb bzip2 cairo cdparanoia cdr cli cracklib crypt cs cups dbus divx doc dri dvd dvdread emacs enca encode esd exif ffmpeg flac fortran gdbm glitz gpm gtk hal iconv icq ipv6 irda isdnlog jpeg jpg mdnsresponder-compat midi mikmod mmx mp3 mudflap mule mysql ncurses nforce2 nls nptl nptlonly ntpl ogg opengl openmp pam pcre perl pmu png pppd python qt-static quicktime readline reflection session spl sqlite sse sse2 ssl subcp svg sysfs tcpd tif tiff truetype unicode usb vorbis x86 xorg xulrunner xv xvid" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Petr Skarka 2009-04-20 18:24:26 UTC
my revdep-rebuild

* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 6% ] *   broken /usr/bin/bc (requires libreadline.so.5)
[ 7% ] *   broken /usr/bin/certtool (requires libreadline.so.5)
[ 10% ] *   broken /usr/bin/ftp (requires libreadline.so.5)
[ 11% ] *   broken /usr/bin/gdb (requires libreadline.so.5)
*   broken /usr/bin/gdbtui (requires libreadline.so.5)
[ 13% ] *   broken /usr/bin/hunspell (requires libreadline.so.5)
[ 15% ] *   broken /usr/bin/lftp (requires libreadline.so.5)
[ 18% ] *   broken /usr/bin/net (requires libreadline.so.5)
*   broken /usr/bin/ntpdc (requires libreadline.so.5)
*   broken /usr/bin/ntpq (requires libreadline.so.5)
[ 24% ] *   broken /usr/bin/rpcclient (requires libreadline.so.5)
[ 25% ] *   broken /usr/bin/slsh (requires libreadline.so.5)
*   broken /usr/bin/smbclient (requires libreadline.so.5)
[ 26% ] *   broken /usr/bin/sqlite (requires libreadline.so.5)
[ 29% ] *   broken /usr/bin/xine-remote (requires libreadline.so.5)
[ 38% ] *   broken /usr/libexec/autopackage/luau-downloader.bin (requires libcurl.so.3
libuau.so.3)
[ 45% ] *   broken /usr/lib/ghc-6.8.2/ghc-6.8.2 (requires libreadline.so.5)
[ 63% ] *   broken /usr/lib/libguilereadline-v-17.so.17.0.3 (requires libreadline.so.5)
[ 72% ] *   broken /usr/lib/opera/plugins/libnullplugin.so (requires libnspr4.so.6
libplc4.so.6
libplds4.so.6
libxpcom_core.so
libxpcom.so)
*   broken /usr/lib/opera/plugins/libunixprintplugin.so (requires libnspr4.so.6
libplc4.so.6
libplds4.so.6
libxpcom_core.so
libxpcom.so)
[ 77% ] *   broken /usr/lib/python2.4/lib-dynload/readline.so (requires libreadline.so.5)
[ 78% ] *   broken /usr/lib/python2.5/lib-dynload/readline.so (requires libreadline.so.5)
[ 84% ] *   broken /usr/lib/ruby/1.8/i686-linux/readline.so (requires libreadline.so.5)
[ 96% ] *   broken /usr/local/lib/gaim/gevolution.so (requires libedataserver-1.2.so.7)
[ 97% ] *   broken /usr/local/lib/gaim/ssl-gnutls.so (requires libgnutls.so.13)
*   broken /usr/local/lib/gaim/ssl-nss.so (requires libnspr4.so.6
libnss3.so.11
libplc4.so.6
libplds4.so.6
libsmime3.so.11
libssl3.so.11)
[ 100% ]                 
* Generated new 3_broken.rr
* Assigning files to packages
*   /usr/bin/bc -> sys-devel/bc
*   /usr/bin/certtool -> net-libs/gnutls
*   /usr/bin/ftp -> net-ftp/ftp
*   /usr/bin/gdb -> sys-devel/gdb
*   /usr/bin/gdbtui -> sys-devel/gdb
*   /usr/bin/hunspell -> app-text/hunspell
*   /usr/bin/lftp -> net-ftp/lftp
*   /usr/bin/net -> net-fs/samba
*   /usr/bin/ntpdc -> net-misc/ntp
*   /usr/bin/ntpq -> net-misc/ntp
*   /usr/bin/rpcclient -> net-fs/samba
*   /usr/bin/slsh -> sys-libs/slang
*   /usr/bin/smbclient -> net-fs/samba
*   /usr/bin/sqlite -> dev-db/sqlite
*   /usr/bin/xine-remote -> media-video/xine-ui
*  !!! /usr/libexec/autopackage/luau-downloader.bin not owned by any package is broken !!!
*   /usr/libexec/autopackage/luau-downloader.bin -> (none)
*   /usr/lib/ghc-6.8.2/ghc-6.8.2 -> dev-lang/ghc
*   /usr/lib/libguilereadline-v-17.so.17.0.3 -> dev-scheme/guile
*  !!! /usr/lib/opera/plugins/libnullplugin.so not owned by any package is broken !!!
*   /usr/lib/opera/plugins/libnullplugin.so -> (none)
*  !!! /usr/lib/opera/plugins/libunixprintplugin.so not owned by any package is broken !!!
*   /usr/lib/opera/plugins/libunixprintplugin.so -> (none)
*   /usr/lib/python2.4/lib-dynload/readline.so -> dev-lang/python
*   /usr/lib/python2.5/lib-dynload/readline.so -> dev-lang/python
*   /usr/lib/ruby/1.8/i686-linux/readline.so -> dev-lang/ruby
*  !!! /usr/local/lib/gaim/gevolution.so not owned by any package is broken !!!
*   /usr/local/lib/gaim/gevolution.so -> (none)
*  !!! /usr/local/lib/gaim/ssl-gnutls.so not owned by any package is broken !!!
*   /usr/local/lib/gaim/ssl-gnutls.so -> (none)
*  !!! /usr/local/lib/gaim/ssl-nss.so not owned by any package is broken !!!
*   /usr/local/lib/gaim/ssl-nss.so -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
[ebuild     U ] dev-libs/libpcre-7.9 [7.8]
[ebuild   R   ] dev-db/sqlite-2.8.16-r4 
[ebuild     UD] sys-libs/readline-5.2_p13 [6.0]
[ebuild   R   ] sys-devel/bc-1.06.95 
[ebuild   R   ] sys-libs/slang-2.1.4 
[ebuild   R   ] net-ftp/ftp-0.17-r7 
[ebuild   R   ] net-misc/ntp-4.2.4_p6 
[ebuild     U ] dev-lang/yasm-0.8.0 [0.7.2]
[ebuild   R   ] sys-devel/gdb-6.8-r2 
[ebuild     U ] sys-devel/gcc-4.3.3-r2 [4.3.3]
[ebuild     U ] dev-libs/libtasn1-2.0 [1.8]
[ebuild   R   ] dev-lang/ghc-6.8.2 
[ebuild   R   ] net-ftp/lftp-3.7.11 
[ebuild     U ] media-video/ffmpeg-0.5-r1 [0.4.9_p20090201]
[ebuild   R   ] app-text/hunspell-1.2.8 
[ebuild   R   ] dev-lang/python-2.4.4-r15 
[ebuild   R   ] dev-lang/python-2.5.4-r2 
[ebuild     U ] media-libs/xine-lib-1.1.16.3 [1.1.16.1]
[ebuild   R   ] net-fs/samba-3.0.34 
[ebuild   R   ] dev-scheme/guile-1.8.6 
[ebuild   R   ] media-video/xine-ui-0.99.5-r2 
[ebuild   R   ] dev-lang/ruby-1.8.7_p72-r11 
[ebuild     U ] net-libs/gnutls-2.6.5 [2.6.4]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  ('ebuild', '/', 'sys-libs/readline-5.2_p13', 'merge') pulled in by
    =sys-libs/readline-5* required by ('ebuild', '/', 'dev-lang/ghc-6.8.2', 'merge')
    (and 11 more)

  ('installed', '/', 'sys-libs/readline-6.0', 'nomerge') pulled in by
    sys-libs/readline required by ('ebuild', '/', 'sys-libs/slang-2.1.4', 'merge')
    >=sys-libs/readline-4.1 required by ('installed', '/', 'dev-lang/python-2.6.1-r1', 'nomerge')
    >=sys-libs/readline-4.1 required by ('ebuild', '/', 'sys-devel/bc-1.06.95', 'merge')
    (and 8 more)


* Warning: Failed to resolve package order.
* Will merge in arbitrary order
Possible reasons:
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it
.....
* All prepared. Starting rebuild
emerge --oneshot  app-text/hunspell:0
dev-db/sqlite:0
dev-lang/ghc:0
dev-lang/python:2.4
dev-lang/python:2.5
dev-lang/ruby:1.8
dev-scheme/guile:12
media-video/xine-ui:0
net-fs/samba:0
net-ftp/ftp:0
net-ftp/lftp:0
net-libs/gnutls:0
net-misc/ntp:0
sys-devel/bc:0
sys-devel/gdb:0
sys-libs/slang:0
..........

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     UD] sys-libs/readline-5.2_p13 [6.0]
[ebuild   R   ] app-text/hunspell-1.2.8 
[ebuild   R   ] dev-db/sqlite-2.8.16-r4 
[ebuild   R   ] dev-lang/python-2.4.4-r15 
[ebuild   R   ] dev-lang/python-2.5.4-r2 
[ebuild   R   ] dev-lang/ruby-1.8.7_p72-r11 
[ebuild   R   ] dev-scheme/guile-1.8.6 
[ebuild   R   ] media-video/xine-ui-0.99.5-r2 
[ebuild   R   ] net-fs/samba-3.0.34 
[ebuild   R   ] net-ftp/ftp-0.17-r7 
[ebuild   R   ] net-ftp/lftp-3.7.11 
[ebuild     U ] net-libs/gnutls-2.6.5 [2.6.4]
[ebuild   R   ] net-misc/ntp-4.2.4_p6 
[ebuild   R   ] sys-devel/bc-1.06.95 
[ebuild   R   ] sys-devel/gdb-6.8-r2 
[ebuild   R   ] sys-libs/slang-2.1.4 
[ebuild   R   ] dev-lang/ghc-6.8.2 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  ('ebuild', '/', 'sys-libs/readline-5.2_p13', 'merge') pulled in by
    =sys-libs/readline-5* required by ('ebuild', '/', 'dev-lang/ghc-6.8.2', 'merge')
    (and 9 more)

  ('installed', '/', 'sys-libs/readline-6.0', 'nomerge') pulled in by
    sys-libs/readline required by ('ebuild', '/', 'sys-libs/slang-2.1.4', 'merge')
    >=sys-libs/readline-4.1 required by ('ebuild', '/', 'dev-lang/python-2.5.4-r2', 'merge')
    >=sys-libs/readline-4.1 required by ('ebuild', '/', 'sys-devel/bc-1.06.95', 'merge')
    (and 6 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
*   (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
*   remove temporary files, and try again.
*   (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
* Found some broken files that weren't associated with known packages
* The broken files are:
*   /usr/libexec/autopackage/luau-downloader.bin
*   /usr/lib/opera/plugins/libnullplugin.so
*   /usr/lib/opera/plugins/libunixprintplugin.so
*   /usr/local/lib/gaim/gevolution.so
*   /usr/local/lib/gaim/ssl-gnutls.so
*   /usr/local/lib/gaim/ssl-nss.so
Comment 4 Rafał Mużyło 2009-04-20 18:58:21 UTC
Let's try reading comment 1 again -
what exactly does it say ?
It says: "add a version of dev-lang/ghc more recent than 6.8.2 to your
package.keywords". It seems even -r1 would do.
Comment 5 Petr Skarka 2009-04-20 19:21:35 UTC
(In reply to comment #4)
> Let's try reading comment 1 again -
> what exactly does it say ?
> It says: "add a version of dev-lang/ghc more recent than 6.8.2 to your
> package.keywords". It seems even -r1 would do.
> 

But I use ~x86. So I should use last versions of programs, isn't it?
Add ghc in more recent version than 6.8.2 not solve this problem.
Comment 6 Rafał Mużyło 2009-04-20 21:56:36 UTC
Well, yes, the output was:
  ('ebuild', '/', 'sys-libs/readline-5.2_p13', 'merge') pulled in by
    =sys-libs/readline-5* required by ('ebuild', '/', 'dev-lang/ghc-6.8.2',
'merge')
    (and 11 more)
so, you'll have to update ghc first, and see what will pop up next on the list.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-20 23:04:13 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Let's try reading comment 1 again -
> > what exactly does it say ?
> > It says: "add a version of dev-lang/ghc more recent than 6.8.2 to your
> > package.keywords". It seems even -r1 would do.
> > 
> 
> But I use ~x86. So I should use last versions of programs, isn't it?
> Add ghc in more recent version than 6.8.2 not solve this problem.
> 

Your output shows:
[ebuild   R   ] dev-lang/ghc-6.8.2 

which means that you do not have a ~arch version of ghc on the machine. Since anything greater than 6.8.2 is masked, you will have to unmask it via package.unmask.

- dev-lang/ghc-6.10.2 (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Lennart Kolmodin <kolmodin@gentoo.org> (19 Apr 2009)
# Mark ghc-6.10.2 and related packages for testing

This sometimes happens in the ~arch tree. Since we highly recommend that you know what you are doing when you use ~arch (at least the ability to do your own research) - I'm going to close this bug. I have alerted the ghc maintainer to consider unmasking this. However, you could also help by testing it too.