Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 264951

Summary: x11-drivers/nvidia-drivers-180.44 cause dev-util/giggle-0.4.91 to fail with undefinced reference to _nv00xxxxgl errors
Product: Gentoo Linux Reporter: James <jinjiongxin>
Component: New packagesAssignee: Ricardo Mendoza (RETIRED) <ricmm>
Severity: normal CC: cardoe, ikelos
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: build.log

Description James 2009-04-05 10:09:49 UTC
fail to compile:
/usr/lib/ undefined reference to `_nv001840gl'
/usr/lib/ undefined reference to `_nv001842gl'
/usr/lib/ undefined reference to `_nv001838gl'
/usr/lib/ undefined reference to `_nv001841gl'
/usr/lib/ undefined reference to `_nv001839gl'

$ emerge --info
Portage (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo i686)
System uname: Linux-2.6.29-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.0
Timestamp of tree: Sun, 05 Apr 2009 09:30:17 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.7
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/gentoo-china /usr/local/portage/layman/gentoo-taiwan /usr/local/portage/local_overlay"
USE="X aac acl acpi alsa asf bash-completion berkdb bzip2 cairo cleartype cli cracklib crypt cups dbus dri dvd fortran gdbm gif glitz gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kpathsea mad midi mp3 mp4 mudflap ncurses nls nptl nptlonly nsplugin nvidia opengl openmp pam pcre pdf perl png pppd python readline reflection samba session spl ssl startup-notification svg symlink sysfs tcpd tiff truetype unicode vidix vim-syntax win32codecs x264 x86 xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"

Reproducible: Always
Comment 1 James 2009-04-05 10:13:26 UTC
Created attachment 187358 [details]
Comment 2 Mike Auty (RETIRED) gentoo-dev 2009-04-05 10:33:13 UTC
This is an error in /usr/lib/ and unlikely to be related to giggle at all.  Based on the symbol names I'd think it was nvidia related.  

Can you please test the following:

* Try recompiling something else with glitz/cairo and see if that fails in the same way (pretty much any other gtkish program)
* Run "revdep-rebuild" to check there aren't any issues with your current system
* Run "eselect opengl set nvidia" to make sure the nvidia GL drivers are selected

Please try recompiling giggle after each of these changes and see if it cures the problem (I expect the last one to do so).  If you're still experiencing the problem, please report which version of the nvidia drivers you're using, the version of xorg-server you're using and the output of "eselect opengl list"...
Comment 3 James 2009-04-05 12:05:08 UTC
Sorry, it doesn't work.
I had nvidia-drivers-180.44 installed, and have tried 180.41 and 180.37.
None solves the problem.
xorg-server version: 1.5.3-r5
$ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11

As shown above, nvidia is selected.
Comment 4 Mike Auty (RETIRED) gentoo-dev 2009-04-05 12:18:13 UTC
Just to double check, did you try re-setting the nvidia opengl selection?  Even though it says it's selected, it still might not have been.  Posting the output of "ldd /usr/lib/" should help determine whether the nvidia drivers were correctly selected.

I'm also using nvidia-drivers-180.44 (with glitz and so forth) and can't recreate the problem.

A workaround might be to temporarily set the opengl implementation to xorg-x11, try compiling giggle, and then re-setting the opengl implementation to xorg-x11?

You should also try recompiling glitz (with nvidia selected) and then see if that helps.
Comment 5 James 2009-04-05 12:44:08 UTC
$ ldd /usr/lib/ =>  (0xb807b000) => /usr/lib/opengl/nvidia/lib/ (0xb7096000) => /usr/lib/tls/ (0xb7094000) => /lib/ (0xb706e000) => /usr/lib/ (0xb705f000) => /usr/lib/ (0xb6f6f000) => /lib/ (0xb6f6b000) => /lib/ (0xb6e28000)
	/lib/ (0xb807c000) => /usr/lib/ (0xb6e24000) => /usr/lib/ (0xb6e21000) => /usr/lib/ (0xb6e06000) => /usr/lib/ (0xb6e00000)

I tried to recompile glitz as suggested, but it doesn't help either.

When I reset to xorg-x11, I can compile and run giggle successfully.
But once I switch back to nvidia, starting giggle crashes.
Comment 6 Mike Auty (RETIRED) gentoo-dev 2009-04-05 12:56:54 UTC
I'm going to refer this to the nvidia guys in case they've seen this before.  There are a couple earlier bugs in Gentoo's bugzilla mentioning it but for very old versions of nvidia and without a clear solution...
Comment 7 James 2009-04-05 12:59:11 UTC
Comment 8 Doug Goldstein (RETIRED) gentoo-dev 2009-11-15 06:45:20 UTC
This bug appears to have slipped in the cracks. Can you retest with some recent versions and re-open if the problem still exists?