Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 263864

Summary: dev-util/monodevelop-1.9.3 should have the dev-dotnet/mono-addins dependencies reversed
Product: Gentoo Linux Reporter: Maciej Piechotka <uzytkownik2>
Component: New packagesAssignee: dotnet <dotnet>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: 2008.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Maciej Piechotka 2009-03-26 14:08:24 UTC
dev-util/monodevelop-1.9.3 should have the dev-dotnet/mono-addins dependencies reversed. Currently it is:
        ||      (
                ~dev-dotnet/mono-addins-0.3.1
                >=dev-dotnet/mono-addins-0.4[gtk]
        )

and some packet managers (paludis) choose the dev-dotnet/mono-addins-0.3.1.

Reproducible: Always
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-26 22:52:19 UTC
+  26 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+  monodevelop-1.9.1.ebuild, monodevelop-1.9.2.ebuild,
+  monodevelop-1.9.3.ebuild:
+  Fix order of mono-addins in || ( a b ) expression to prefer the newest
+  version. Bug 263864. Thanks to uzytkownik <uzytkownik2@gmail.com> for
+  reporting.
+