Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 263285

Summary: media-audio/rhythmbox-0.12.0 should RDEPEND on gst-plugins-libmms and gst-plugins-soup
Product: Gentoo Linux Reporter: Yang Zhao <yang>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED FIXED    
Severity: minor CC: graaff, pacho, tester
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugzilla.gnome.org/show_bug.cgi?id=575962
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 241674    
Bug Blocks:    

Description Yang Zhao 2009-03-21 19:17:10 UTC
Rhythmbox currently fails to play most "Radio" sources under default install due to lack of mms:// (gst-plugins-libmms) and http:// (gst-plugins-soup) dependency.

These plugins are not pulled in by any other package, and need to be done so explicitly by rhythmbox or implicitly through gst-plugins-meta for Rhythmbox to function fully.
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-03-21 21:32:05 UTC
I have neither and http streams work just fine. Could you paste a few test urls ?

Also the ebuilds clearly says it doesn't provide all dependencies to play music so I'm not sure we are going to change this before we get to bug #241674.
Comment 2 Yang Zhao 2009-03-21 21:41:54 UTC
Hm.. It may be due to the redirects to mirror that's involved in the streams I'm listening to. Here they are:

http://www.cbc.ca/livemedia/cbcr1-vancouver.asx
http://www.cbc.ca/livemedia/cbcr2-vancouver.asx
http://shoutcast1.cbcradio3.com
Comment 3 RĂ©mi Cardona gentoo-dev 2009-03-22 18:13:51 UTC
I think I'm hitting that bug on my laptop. I can't play internet radios anymore. I'll try to update RB to 0.12 first, see if that helps.

I'll try gst-plugins-soup then.

Thanks
Comment 4 Hans de Graaff gentoo-dev 2009-03-24 19:27:38 UTC
I can't play last.fm streams anymore with rhythmbox 0.12.0.

Installing gst-plugins-soup fixed this for me. Not sure what changed recently in rhythmbox that this is now needed. If anything this should probably be mentioned in the postinst message, since it's a regression from earlier versions that seemed to handle this directly?
Comment 5 Yang Zhao 2009-03-24 22:39:30 UTC
rhythmbox-0.10.1-r1 RDEPENDs on >=net-libs/libsoup-2.2.99:2.2. The latest stable libsoup is 2.24.3.

It seems like the libsoup dependency was moved out to gstreamer sometime around 0.11.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-03-25 09:22:30 UTC
remi reported it with 0.11.99.3, upstream bug gives some clues about why it stopped working like this. We will change the ebuild when things get a bit sorted out.
Comment 7 Olivier Crete (RETIRED) gentoo-dev 2009-04-20 03:20:54 UTC
If you don't have gst-plugins-soup, playbin will use the gnomevfs plugin instead, which may or may not work (doesn't for me). I suggest just adding the soup dep at least. As for the mms plugin, we should probably have a handler script that will tell the user which plugin to install.
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-05-07 23:23:15 UTC
added them to 0.12.1-r1, dropped gst-plugins-gnome-vfs even though I don't think it is the correct approach, upstream doesn't seem to be willing to/interested in  fix it.
Comment 9 Yang Zhao 2009-05-08 05:08:44 UTC
Thanks.

Closing.