Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 262256

Summary: Ebuild needed: qtscriptgenerator
Product: Gentoo Linux Reporter: Mieszko Ślusarczyk <mieszkoslusarczyk>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: kennethlakin, mikko.cal, qt, simon, xenoterracide
Priority: High Keywords: EBUILD, InOverlay
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: [kde-testing]
Package list:
Runtime testing required: ---
Attachments: include everything patch
qtscriptgenerator-0.1.0.ebuild
build.log
patch by Thomas Kuther
patch by Thomas Kuther
qtscriptgenerator-0.1.0.ebuild
ignore me

Description Mieszko Ślusarczyk 2009-03-12 12:26:18 UTC
Amarok 2.1 will depend on the QtScript Generator as a seperate package (it
currently bundles it with its tarball). I have a feeling that there maybe be
some issues packaging it due the Phonon oddness and similar, so I want to make
sure that its available in time for Amarok 2.1. And make things a bit easier on
our SVN users.

http://code.google.com/p/qtscriptgenerator/downloads/list

original info: http://mail.kde.org/pipermail/amarok/2009-March/007811.html

Reproducible: Always
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2009-03-12 12:42:27 UTC
This package doesnt build so far ( neither the 0.1.0 version nor the git version from trolltech ).

I am not sure that this package is actually an amarok dependency. Amarok bundles this package in order to generate QtScript bindings for it self.
Comment 2 Mieszko Ślusarczyk 2009-03-12 12:45:10 UTC

(In reply to comment #1)
> This package doesnt build so far ( neither the 0.1.0 version nor the git
> version from trolltech ).
> 
> I am not sure that this package is actually an amarok dependency. Amarok
> bundles this package in order to generate QtScript bindings for it self.
> 

I know it doesn't compile now...

If you doubt it'll be needed see:
http://mail.kde.org/pipermail/amarok/2009-March/007811.html
https://bugs.kde.org/show_bug.cgi?id=177863
Comment 3 Mieszko Ślusarczyk 2009-03-12 12:46:49 UTC
Btw. you gave me live ebuild of it, and I filed a bug about it not building at 
http://code.google.com/p/qtscriptgenerator/issues/detail?id=38
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2009-03-12 19:50:07 UTC
There are initial ebuilds ( 0.1.0 and 9999 ) on qting-edge overlay but dont count on them. Qtscriptgenerator is broken by upstream right now, so both of them dont work. Hopefully upstream will fix it soon
Comment 5 Mikko C. 2009-03-14 12:46:43 UTC
I get this error when compiling 9999:

cd qtscript_phonon/ && /usr/bin/qmake qtscript_phonon.pro -unix QTDIR=/usr/lib64 QMAKE=/usr/bin/qmake QMAKE_CC=x86_64-pc-linux-gnu-gcc QMAKE_CXX=x86_64-pc-linux-gnu-g++ QMAKE_LINK=x86_64-pc-linux-gnu-g++ QMAKE_CFLAGS_RELEASE=-march=core2\ -O2\ -pipe QMAKE_CFLAGS_DEBUG=-march=core2\ -O2\ -pipe QMAKE_CXXFLAGS_RELEASE=-march=core2\ -O2\ -pipe QMAKE_CXXFLAGS_DEBUG=-march=core2\ -O2\ -pipe QMAKE_LFLAGS_RELEASE=-Wl,-O1 QMAKE_LFLAGS_DEBUG=-Wl,-O1 QMAKE_RPATH= QMAKE_STRIP= -o Makefile                   
WARNING: Failure to find: ../../generated_cpp/com_trolltech_qt_phonon/main.cpp                                               
WARNING: Failure to find: ../../generated_cpp/com_trolltech_qt_phonon/main.cpp                                               
cd qtscript_phonon/ && make -f Makefile                                                                                      
make[1]: Entering directory `/var/tmp/paludis/x11-libs-qtscriptgenerator-9999/work/qtscriptgenerator-9999/qtbindings/qtscript_phonon'                                                                                                                     
make -f Makefile.Debug                                                                                                       
make[2]: Entering directory `/var/tmp/paludis/x11-libs-qtscriptgenerator-9999/work/qtscriptgenerator-9999/qtbindings/qtscript_phonon'                                                                                                                     
make[2]: *** No rule to make target `../../generated_cpp/com_trolltech_qt_phonon/main.cpp', needed by `debug/main.o'.  Stop. 
make[2]: Leaving directory `/var/tmp/paludis/x11-libs-qtscriptgenerator-9999/work/qtscriptgenerator-9999/qtbindings/qtscript_phonon'                                                                                                                      
make[1]: *** [debug] Error 2
Comment 6 Mieszko Ślusarczyk 2009-03-14 14:31:06 UTC
Mikko, currently qtscriptgenerator is broken upstream, report, or search for bugs at http://code.google.com/p/qtscriptgenerator/issues/list.
Comment 7 Caleb Cushing 2009-03-22 02:32:25 UTC
Created attachment 185833 [details]
include everything patch

http://code.google.com/p/qtscriptgenerator/issues/detail?id=39 this is my patch for 0.1.0 from the above issue. it's just some modifcations to the other patch... which wouldn't apply.
Comment 8 Caleb Cushing 2009-03-22 02:33:50 UTC
Created attachment 185835 [details]
qtscriptgenerator-0.1.0.ebuild

slightly different from the qting-edge ebuild, only functional difference is that it uses the qt4 eclass from portage and that it applies the include-everything.patch I can post a diff if you really need it.
Comment 9 Caleb Cushing 2009-03-22 02:36:39 UTC
Created attachment 185836 [details]
build.log

build log with my current errors.
Comment 10 Simon Bühler 2009-03-22 18:08:24 UTC
Created attachment 185897 [details, diff]
patch by 
Thomas Kuther
Comment 11 Simon Bühler 2009-03-22 18:09:13 UTC
Created attachment 185899 [details, diff]
patch by 
Thomas Kuther
Comment 12 Simon Bühler 2009-03-22 18:09:52 UTC
ok added the two patches i used to compile it 
Comment 13 Markos Chandras (RETIRED) gentoo-dev 2009-03-22 20:10:19 UTC
Ebuilds fixed on qting-edge. Note that include_everything* patches are useless since we disable phonon bindings ( using the last patch )

Please test them and verify that they work :)

Thank you all for your great work
Comment 14 Simon Bühler 2009-03-23 10:37:39 UTC
adding the full paths of the  phonon includes in qtscript_masterinclude.h should fix the phonon issue
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2009-03-23 10:45:05 UTC
I wasn't able to compile qtscriptgenerator using the include_everything proposed patches. Hence, I disabled phonon bindings for now until I come up with a workaround.
Comment 16 Caleb Cushing 2009-03-23 11:14:22 UTC
Created attachment 185977 [details]
qtscriptgenerator-0.1.0.ebuild

this requires the phonon disable patch. just for consistency it works thus far regardless of version so shouldn't be named 9999 imho. it isn't in my ebuild.
Comment 17 Murph 2009-03-31 20:31:06 UTC
Created attachment 186890 [details]
ignore me

On amd64. emerge qtscriptgenerator from kde-testing and tried to emerge amarok-2.0.2.

# emerge -pvl amarok

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-sound/amarok-2.0.2 [2.0.1.1] USE="ipod kdeprefix mp4 mtp opengl semantic-desktop -cdaudio% -daap -debug -ifp -mp3tunes -njb" LINGUAS="ja ko -ar -be -bg -ca -cs -csb -da -de -el -eo -es -et -eu -fi -fr -ga -gl -he -is -it -km -ku -lt -lv -nb -nds -ne -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -se -si -sk -sl -sv -th -tr -uk -zh_CN -zh_TW" 0 kB [0=>1]               

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:                           
 [0] /usr/portage                                    
 [1] /usr/local/portage/layman/kde-testing           

*amarok-2.0.2

  05 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +amarok-2.0.2.ebuild:
  Bump                                                                  

  05 Feb 2009; Maciej Mrozowski (reavertm) <reavertm@poczta.fm>
  metadata.xml, amarok-9999.ebuild:                            
  Added missing [kdeprefix=] USE deps in amarok, reformatting  

  12 Jan 2009; Manuel Nickschas <sputnick@quassel-irc.org>
  amarok-2.0.1.1.ebuild:                                  
  Remove unused USE                                       

# emerge --info
Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r1-murph x86_64)
=================================================================                                              
System uname: Linux-2.6.28-gentoo-r1-murph-x86_64-Intel-R-_Core-TM-2_CPU_6700_@_2.66GHz-with-glibc2.2.5        
Timestamp of tree: Tue, 31 Mar 2009 07:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.6
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.51.0.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -pipe -fomit-frame-pointer -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release/etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -pipe -fomit-frame-pointer -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com ftp://cites.uiuc.edu/pub/gentoo http://mirrors.cs.wmich.edu/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en ja hi ko"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/mozilla /usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="16bit 3dnow 3dnowext 3ds 64bit 7zip X a52 aac aalib acl acpi additions aim aimextras alsa amarok amd amd64 amr ao asf bash-completion berkdb bl bluetooth bzip2 c++ cairo calendar canna cap ccache cdda cddb cdinstall cdrom cg chroot cid cjk cli cmake cracklib crypt css curl dbus dga dio divx divx4linux dri dv dvb dvd dvdnav dvdr dvdread dvi emacs embedded encode ethereal examples fbcon ffmpeg firefox flac flash fontconfig fortran ftp fuse gcj gd gdbm gif gimp git glep glitz glx gmail gmailtimestamps gmedia google-gadgets gpm gstreamer010 gtalk gtk gtk2 gtkhtml gtkspell gzip hal hddtemp hpn html htmlhandbook http httpd hub iconvicq id3 ieee1394 imagemagick immqt-bc insecure-drivers insecure-savers ipod irc isdnlog j2ee jabber java java6 javascript jikesjp2 jpeg kde kde4 kdepim kdeprefix kqemu lame latex lcd libcaca lirc lm_sensors logitech-mouse mad madwifi mastroka math matroska mcal mccp midi mikmod mjpeg mmap mmx mmxext mng mp3 mp4 mp4live mpeg mpeg2 mpeg4 mplayer mplayer-bin msn mtp mudflap multilibmultitarget musicbrainz mysql ncurses nepomuk networkmanager nfs nls nptl nptlonly nsplugin ntfs ntlm ntlm_unsupported_patch nvidia oav odbc offensive ogg openal opengl openmp openssl pam pcre pdf perl plasma png pppd python qmake qt4 quicktime rar rdesktop readline realmedia reflection regex reiserfs samba sdl semantic-desktop session smp sms speex spell spl sqlite sqlite3 srt sse sse-filters sse2 ssl ssse3 svg sysfs szip taglib tcpd tetex theora threads threadsafe tiff transcode truetype type1 unicode urandom usb utf8 v4l v4l2 vcd vdpau vorbis wavpack webkit wifi wma wmf wmp x264 xcomposite xine xinerama xml xorg xrandr xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_fileauthz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ja hi ko" LIRC_DEVICES="mceusb2" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 18 Markos Chandras (RETIRED) gentoo-dev 2009-03-31 21:12:58 UTC
Excuse me , but this amarok bug has nothing to do with this specific bug . Amarok-2.0.2 bugs should go on http://bugs.gentoo.org/show_bug.cgi?id=261643

Comment 19 Murph 2009-03-31 22:45:51 UTC
Comment on attachment 186890 [details]
ignore me

Sorry -___-
I don't see any way to remove/edit the comment. My apologies, please disregard it.
Comment 20 styx 2009-06-06 17:01:30 UTC
qtscriptgenerator from kde-testing overlay works for me
Comment 21 Davide Pesavento gentoo-dev 2009-06-06 18:39:40 UTC
Why is this bug still open? qtscriptgenerator-0.1.0 has been in portage for almost 2 months...
Comment 22 Markos Chandras (RETIRED) gentoo-dev 2009-06-06 18:45:31 UTC
Thats true

Closing