Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 261790

Summary: sys-freebsd/freebsd-lib-7.1-r2 - pmake: don't know how to make /var/tmp/portage/freebsd-lib-7.1-r2/work/include/../sys/conf/newvers.sh. Stop
Product: Gentoo Linux Reporter: Zhang Weiwu <zhangweiwu>
Component: New packagesAssignee: Gentoo/BSD Team <bsd+disabled>
Status: VERIFIED INVALID    
Severity: normal CC: zhangweiwu
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Zhang Weiwu 2009-03-09 01:32:55 UTC
* Installing includes into /include_proper as zhangweiwu:0...
pmake: don't know how to make /var/tmp/portage/freebsd-lib-7.1-r2/work/include/../sys/conf/newvers.sh. Stop

pmake: stopped in /var/tmp/portage/freebsd-lib-7.1-r2/work/include

!!! ERROR: sys-freebsd/freebsd-lib-7.1-r2 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  freebsd-lib-7.1-r2.ebuild, line 167:   Called install_includes '/include_proper'
  freebsd-lib-7.1-r2.ebuild, line 362:   Called die

!!! install_includes() failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



Reproducible: Always




# emerge --info

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/2008.0

To upgrade do the following steps:
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default/linux/x86/2008.0 make.profile



Portage 2.1.1-r1 (default-linux/x86/2007.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11-gentoo-r3 i686)
=================================================================
System uname: 2.6.11-gentoo-r3 i686 Intel(R) Xeon(TM) CPU 2.80GHz
Gentoo Base System version 1.4.16
Last Sync: Sun, 08 Mar 2009 01:45:02 +0000
app-admin/eselect-compiler: [Not Present]
app-shells/bash:     3.1_p16
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.3.4-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/cmake:      2.4.3
dev-util/confcache:  [Not Present]
sys-apps/baselayout: 1.9.4-r6
sys-apps/openrc:     [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.8-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 acl alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_authn_alias apache2_modules_authn_anon apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_rewrite apache2_modules_setenvif apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias berkdb bzip2 cjk cli cracklib crypt cups curl dri elibc_glibc fortran gd gdbm gpm iconv imap input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text ldap midi mmx mudflap mysql mysqli ncurses net nls nptl nptlonly openmp pam pcre perl pppd python readline reflection sasl session simplexml spl sse ssl tcpd unicode userland_GNU video_cards_apm video_cards_ark video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_r128 video_cards_radeon video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo xorg xsl zlib"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

P.S. If I follow the emerge message to run this:
To upgrade do the following steps:
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default/linux/x86/2008.0 make.profile


Then I would get this, when emerge, next time:
# emerge -av freebsd-ubin
Traceback (most recent call last):
  File "/usr/bin/emerge", line 4049, in ?
    emerge_main()
  File "/usr/bin/emerge", line 3768, in emerge_main
    settings, trees, mtimedb = load_emerge_config()
  File "/usr/bin/emerge", line 3679, in load_emerge_config
    trees = portage.create_trees(trees=trees, **kwargs)
  File "/usr/lib/portage/pym/portage.py", line 6780, in create_trees
    config_incrementals=portage_const.INCREMENTALS)
  File "/usr/lib/portage/pym/portage.py", line 902, in __init__
    addProfile(os.path.realpath(self.profile_path))
  File "/usr/lib/portage/pym/portage.py", line 889, in addProfile
    raise portage_exception.ParseError(
NameError: global name 'parents_file' is not defined
Comment 1 Timothy Redaelli (RETIRED) gentoo-dev 2009-03-11 21:58:54 UTC
why are you compile freebsd-libs under linux?
Comment 2 Zhang Weiwu 2009-03-12 01:05:02 UTC
Why you provided it?

My reason: I have a server on Gentoo and an application developed on FreeBSD using freebsd's tr(1) which supports multi-byte. Coreutil's tr fail to support multi-byte characters (see http://savannah.gnu.org/bugs/?23030 )
Comment 3 Zhang Weiwu 2009-03-12 01:06:32 UTC
Since this issue is more than 10 years old (multibyte support on core-utils, although it's reported in 2004 but it actually has longer history), I more or less have reason to believe this will not be fixed during the life-cycle of the application we are using. Writing my own version of tr is beyond my skill as sysop.
Comment 4 Alexis Ballier gentoo-dev 2009-06-18 12:24:51 UTC
freebsd-lib is not meant to be used under linux (unless you're building a cross compiler which crossdev handles fine here). Closing as invalid.
Comment 5 Zhang Weiwu 2009-06-18 13:21:00 UTC
Just for other people who come to this page with the same frustration of gnu bin-utils' incompatibility with UTF-8 in general, instead of compiling freebsd's bin-utils, you can download and compile heirloom utilities which can be compiled much easier on Linux.

Heirloom tools are hosted here: http://heirloom.sourceforge.net.