Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 261625

Summary: kde-base/konsole-4.2.1 doesn't handle ctrl-C / ctrl-Z and pass them to bash
Product: Gentoo Linux Reporter: Daniel Black (RETIRED) <dragonheart>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Daniel Black (RETIRED) gentoo-dev 2009-03-07 22:37:09 UTC
$ cat
^C^C^C^C^C^C^C^Z^Z^Z^Z^Z

and nothing happened. just displayed on the konsole like this. 4.2.0 was working ok.

didn't seem to be anything upstream.

killing the session in yakuake takes a long time ~10+seconds. konsole didn't kill the session.

Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-vs2.3.0.36.4-gentoo x86_64)
=================================================================                                                  
System uname: Linux-2.6.28-vs2.3.0.36.4-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.0.0
Timestamp of tree: Fri, 06 Mar 2009 21:15:01 +0000                                                                    
distcc 3.1 x86_64-pc-linux-gnu [enabled]                                                                              
app-shells/bash:     3.2_p39                                                                                          
dev-java/java-config: 1.3.7-r1, 2.1.6-r1                                                                              
dev-lang/python:     2.5.4-r2, 2.6.1                                                                                  
dev-python/pycrypto: 2.0.1-r6                                                                                         
dev-util/cmake:      2.6.2                                                                                            
sys-apps/baselayout: 2.0.0                                                                                            
sys-apps/openrc:     9999
sys-apps/sandbox:    1.3.9
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="                http://mirror.internode.on.net/pub/gentoo                 http://ftp.swin.edu.au/gentoo/                 http://mirror.isp.net.au/ftp/pub/gentoo/http://gentoo.osuosl.org                 http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/openrc /usr/local/layman/gnash-cvs /usr/local/layman/x11 /usr/local/layman/sunrise"
SYNC="rsync://mirror.internode.on.net/gentoo-portage"
USE="3dnow 3dnowex X aac acl acpi adns alsa amd64 ares avahi bash-completion berkdb bzip2 cairo caps cli cracklib crypt css cups curl dbus divx4linux dri drm dvdr ecc emerald encode ethereal exif extensions fastcgi ffmpeg fla flac fortran fpx gd gdbm gif gimp gimpprint glitz gmp gnutls gphoto2 graphviz gs gtk hal hardened hpn i8x0 iconv idn ilbc imagemagick imlib ipv6 isdnlog javacommjbig jpeg jpeg2k kde kde4 kdeenablefinal kdehiddenvisibility kdeprefix kerberos lcms libgda libsamplerate lzo lzw mad mbox midi mmx mng mp3 mpeg mudflap multilib multitarget musicbrainz mysql ncurses nptl nptlonly ntlm ogg oggvorbis openal openexr opengl openmp operanom2 pam pango pcre pdf perl php png postgres ppds pppd pulseaudio python qt qt3 qt4 readline reflection restrict-javascript samba session sguil slp smime sndfile socks5 sox speex spell spl sse sse2 ssl svg svgz sysfs tga theora tiff true-type truetype unicode usb vcd vhosts vim vim-syntax vorbis webkit wmf x264 xcb xine xinerama xml xml2 xorg xscreensaver xvid zlib zrtp" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloatlinear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="nv vesa nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Daniel Black (RETIRED) gentoo-dev 2009-03-07 22:39:06 UTC
small correction - konsole did do a dialog to kill the session (it was just hidden). I was slow though.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-07 22:44:46 UTC

*** This bug has been marked as a duplicate of bug 260441 ***