Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 261046

Summary: ^C ^Z stopped working in X (konsole, xterm, ...) in KDE4.2
Product: Gentoo Linux Reporter: Korvin <korvin>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Korvin 2009-03-03 10:50:26 UTC
This is a very strange bug. I'll try to write as much as possible.

0. Some time ago I ran 'kwin --replace', and then previous version of kwin was
hanging as zombie process.

1. It started in the middle of my session; I haven't installed new pkgs or
upgraded applets.

2. Eventually I've noticed that Konsole stops understanding ^keys, such as ^C
^Z. So if I start `ping localhost' and then hit ^C -- nothing happens. Ping
remains pinging, and thats all. Er, actually "^C" is printed on the terminal,
much like as it is incorrect binding, but it isn't:

$ stty -a
speed 38400 baud; rows 40; columns 157; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 =
<undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon ixoff
-iuclc -ixany -imaxbel iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke

3. The worst thing is that it's not only Konsole's fault. If I run xterm and
run command there -- effect is exactly the same.

4. xterm is not closing using X button in the window
frame. just hangs there

5. If I run "system activity" applet and try to close a window using popup menu
"Send signal -> SIGTERM" it is not work (whereas SIGKILL does the thing).

6. I have posted this bug to KDE tracker (https://bugs.kde.org/show_bug.cgi?id=186000), and there is another bug https://bugs.kde.org/show_bug.cgi?id=185995 related somehow.

7. This I now happening even after reboot!

8. It is all working in separate fluxbox session. I mean xterm is catching ^C
ok there, so it isn't Xorg's fault imho.

9. Of course it is working in system console (Ctrl+Alt+F1)  :)

10. There is kwin_killer_helper zombie processis in my process list.

11. If I run sandbox sh and do smth ^C -- it works (bash/bashrc issue?).

Well... hope if this helps somehow :\

P. S: All of this makes me think of incorrect SIGTERM handling or something...
Seems that it is not achieving dest process (I know, it's a bit crazy to say
that =).

Reproducible: Always

Steps to Reproduce:




Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-tuxonice-r3 x86_64)
=================================================================                                         
System uname: Linux-2.6.28-tuxonice-r3-x86_64-AMD_Athlon-tm-_64_X2_Dual-Core_Processor_TK-57-with-glibc2.2.5
Timestamp of tree: Tue, 03 Mar 2009 01:45:01 +0000                                                          
distcc 3.0 x86_64-pc-linux-gnu [disabled]                                                                   
app-shells/bash:     3.2_p39                                                                                
dev-java/java-config: 1.3.7-r1, 2.1.6-r1                                                                    
dev-lang/python:     2.4.4-r13, 2.5.2-r7                                                                    
dev-python/pycrypto: 2.0.1-r6                                                                               
dev-util/cmake:      2.6.3                                                                                  
sys-apps/baselayout: 1.12.11.1                                                                              
sys-apps/sandbox:    1.2.18.1-r2                                                                            
sys-devel/autoconf:  2.13, 2.63                                                                             
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -mmmx -msse -msse2 -m3dnow"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -mmmx -msse -msse2 -m3dnow"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://fido.online.kz/gentoo http://mirror.yandex.ru/gentoo-distfiles"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl alsa amd64 berkdb bluetooth bzip2 cli cracklib crypt cups dbus dri dvd dvdr dvdread encode exif fortran gdbm gif gpm gstreamer hal i18n iconv ipv6 isdnlog jpeg kde lm_sensors midi mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png pppd python qt3support readline reflection samba session smb spl sse sse2 ssl svg sysfs tcpd tiff truetype unicode usb utf8 vorbis wifi xcomposite xinerama xorg zlib" ALSA_CARDS="hda-intel usb-audio usb-usx2y ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-03 10:55:36 UTC
Sounds very much like the infamous nvidia-drivers-180.35 bug. Please have a look at bug #260441 and in case you are using nvidia-drivers-180.35, mark your bug as a duplicate of that one.
Comment 2 Korvin 2009-03-03 13:06:02 UTC
Yes, you're absolutely right. Downgrading the driver fixes the thing :)


*** This bug has been marked as a duplicate of bug 260441 ***