Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 258631

Summary: Kopete 4.2 crashes when kdelibs-3.5 are installed due to lack of STYLE_VERSION in html4.css
Product: Gentoo Linux Reporter: Maxim Grechkin <maximsch2>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: critical CC: esigra, rafael
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 245954    

Description Maxim Grechkin 2009-02-11 17:53:05 UTC
I have KDE 4.2 installed and kdelibs-3.5.10 for k3b. When I try to send someone a message from kopete it crashes

Reproducible: Always

Steps to Reproduce:
1. Install kopete:4.2 and kdelibs:3.5 kdeprefix enabled
2. Run kopete and try to chat with anybody (I use jabber)


Actual Results:  
It will crash with:
!!!!!!! ERROR !!!!!!! - KHTML default stylesheet version mismatch. Aborting. Check your installation. File usedwas: /usr/kde/3.5/share/apps/khtml/css/html4.css. Expected STYLE_VERSION 1



Problem could be fixed by adding STYLE_VERSION 1 to that file, so there is actually no problem in it's content, but it would be much better if kopete will look in /usr/kde/4.2
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-12 18:53:06 UTC
How the crap you managed to install kdelibs-3.5.9?
:D
you should update to 3.5.10 problem will wanish. 
Comment 2 Maxim Grechkin 2009-02-12 19:09:19 UTC
In fact problem reappeared after upgrade to 3.5.10-r2 from 3.5.9 with hand-fixed html4.css. But I think it shouldn't matter at all. Kopete should look to /usr/kde/4.2 not 3.5
Comment 3 Rafael Kolless 2009-02-21 08:31:09 UTC
Please check with:

env

if KDEDIRS is still set systen wide

and execute an env-update && source /etc/profile

this should fix your problem :)
Comment 4 Maxim Grechkin 2009-02-21 08:42:12 UTC
env | grep KDEDIRS
returns nothing
Comment 5 Rafael Kolless 2009-02-21 11:51:59 UTC
in this case set in 
/etc/env.d/43kdepaths-4.2

KDEDIRS=/usr/:/usr/kde/4.2

and 45-kdepaths-3.5

KDEDIRS=/usr/kde/3.5

I had the same problem since kde4 that KDEDIRS should not be needed anymore but on my system I always have to set KDEDIRS manually for not getting into problems like you have.
Comment 6 Maxim Grechkin 2009-02-21 21:55:01 UTC
Shouldn't it be done by ebuild?
Comment 7 Rafael Kolless 2009-02-22 14:26:57 UTC
It is always said that KDEDIRS is not needed anymore but I can't agree with it.
I always have to rewrite the env-files for KDE after an update or upgrade.
BTW, did it solve your problem?
Comment 8 Maxim Grechkin 2009-02-22 14:52:21 UTC
Yes it fixed the problem. I removed STYLE_VERSION from 3.5's file and kopete still works. After removal from 4.2's file it crashes with error, but points to correct file. So now it is using good html4.css. Is it hard for ebuild to put this variables?
Comment 9 Rafael Kolless 2009-02-22 14:55:47 UTC
No, it is not hard, KDEDIRS has been removed from the ebuild several month ago.

Propably someone from the KDE team could explain why it is sometimes needed.
Comment 10 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 10:59:54 UTC
Comment 8 got me totally confused: where do you want these variables? in kde4.2? in kde3? in kopete? in kdelibs? 
Never mind, we have made several changes in kde3 eclasses and $PATHs so i guess it should be fixed, if not please reopen