Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 258304

Summary: New Version: sci-mathematics/cgal-3.5.1
Product: Gentoo Linux Reporter: Antonio Quartulli <a>
Component: New packagesAssignee: Gentoo Science Mathematics related packages <sci-mathematics>
Status: RESOLVED FIXED    
Severity: normal CC: benjamin.girault, ssuominen
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.cgal.org
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 283429    
Attachments: ebuild for CGAL 3.5
ebuild for CGAL 3.5.1
cgal-3.5.1.ebuild
Let's try above again
Fixes multilib issues

Description Antonio Quartulli 2009-02-09 08:12:06 UTC
A new version for sci-mathematics/cgal is available.
Renaming ebuild doesn't work because this new version is not in the reps.

Reproducible: Always
Comment 1 S├ębastien Fabbro (RETIRED) gentoo-dev 2009-02-10 10:16:44 UTC
Hi,

Thanks for the notice. It looks like upstream changed the build system to cmake, so the current ebuild would need full rework. It might take some time.

Comment 2 Benjamin Girault 2009-12-15 16:57:46 UTC
I made a minimal ebuild for CGAL 3.5. It works on my amd64 box. Since it is one of my first ebuilds, feel free to comment it ;)
Comment 3 Benjamin Girault 2009-12-15 16:58:54 UTC
Created attachment 213107 [details]
ebuild for CGAL 3.5
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-01-07 21:59:19 UTC
http://www.cgal.org/releases.html#release3.5.1

We need this in tree to remove the Qt3 version.
Comment 5 Benjamin Girault 2010-01-08 12:18:54 UTC
Created attachment 215643 [details]
ebuild for CGAL 3.5.1

Here is an updated version of my previous ebuild. However, I can't put it in the main tree.
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2010-01-08 13:14:54 UTC
Created attachment 215644 [details]
cgal-3.5.1.ebuild

Here's somewhat more complete ebuild. Not everything is optional, there's no switch to turn them off (automagic) and I'm unsure of the demos and examples flags...

Also license MIT was missing
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2010-01-08 13:18:44 UTC
Created attachment 215646 [details]
Let's try above again
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2010-01-08 13:24:30 UTC
Created attachment 215648 [details]
Fixes multilib issues

One more, will install with multilib-strict and doesn't install the bundled documentation to wrong dir
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2010-01-09 12:17:48 UTC
+*cgal-3.5.1 (09 Jan 2010)
+
+  09 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +cgal-3.5.1.ebuild:
+  Version bump wrt #258304, thanks to Antonio Quartulli for reporting.