Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 256406

Summary: app-cdr/brasero-0.9.1[nautilus] causes nautilus to be semi translated
Product: Gentoo Linux Reporter: Pacho Ramos <pacho>
Component: Current packagesAssignee: optical media herd <media-optical>
Status: RESOLVED FIXED    
Severity: normal CC: flaschenkopp, gnome, serkan
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugzilla.gnome.org/show_bug.cgi?id=569204
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: 1.png
brasero-i18n.patch

Description Pacho Ramos gentoo-dev 2009-01-26 12:47:02 UTC
I have tried to know what update has broken this but I have been unable, I have tried to downgrade enchant but it hasn't fix the problem.

At least with locale es_ES in all gentoo machines I have tried, some strings are shown unstranslated on nautilus. For example, right clicking on a file shows "Make link", "Move to Trash", "Delete"... in english while other strings are in spanish. This worked fine some weeks ago (well, this is the first time I see this behavior). 

I attach a screenshot showing how some strings are in spanish and some in english

My emerge -pv nautilus:
gnome-base/nautilus-2.22.5.1-r1  USE="X gnome -beagle -debug -tracker"

My emerge --info:
Portage 2.1.6.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28-tuxonice-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-tuxonice-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Mon, 26 Jan 2009 09:30:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/java-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups daap dbus dell dirac divx djvu dts dvd dvdr dvdread dvi eds emboss emovix encode epiphany evo exif fam fbcondecor fbsplash ffmpeg flac fortran fuse galago gdbm gif glitz gmedia gnome gnome-keyring gpm gsm gstreamer gtk hal iconv ieee1394 ipv6 isdnlog java java6 jpeg jpeg2k kdeenablefinal kdehiddenvisibility kpathsea ladspa laptop latex lcms ldap libnotify lirc lzma mad midi mikmod mjpeg mmx mmxext mono moonlight mp3 mpeg mudflap multilib musepack musicbrainz nautilus ncurses network network-cron networkmanager nls nptl nptlonly ntp ogg opengl openmp pam pch pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline realmedia reflection scanner schroedinger sdl session smp sms speex spell spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs t1lib tcpd theora threads tiff totem truetype unicode usb v4l2 vcd vhook vorbis wmf wmp x264 xattr xcb xft xinetd xml xorg xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Thanks

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2009-01-26 12:47:50 UTC
Created attachment 179761 [details]
1.png
Comment 2 Serkan Kaba (RETIRED) gentoo-dev 2009-01-26 13:15:02 UTC
I experience the problem with other GNOME apps (such as gedit) as well (with GNOME 2.24). I suspect that being due to a gtk+ upgrade (I'll double check that). Can you also examine if you upgraded gtk+ lately.
Comment 3 Serkan Kaba (RETIRED) gentoo-dev 2009-01-26 18:17:52 UTC
(In reply to comment #2)
> I experience the problem with other GNOME apps (such as gedit) as well (with
> GNOME 2.24). I suspect that being due to a gtk+ upgrade (I'll double check
> that). Can you also examine if you upgraded gtk+ lately.
> 

gtk+ wasn't the problem.
Comment 4 telperion 2009-02-02 19:02:48 UTC
same here 
many items in english, locale is it.

http://img102.imageshack.us/img102/3412/schermatapj0.jpg


gentoobox ~ # emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28.2 i686)
=================================================================
System uname: Linux-2.6.28.2-i686-Intel-R-_Pentium-R-_Dual_CPU_E2180_@_2.00GHz-with-glibc2.0
Timestamp of tree: Mon, 02 Feb 2009 11:15:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ "
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi berkdb branding bzip2 cairo cddb cdr cli cracklib crypt css cups dbus dri dts dv dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv id3tag imagemagick inkjar isdnlog jpeg kde lame ldap libnotify libsamplerate mad matroska mdnsresponder-compat midi mikmod mmx mp3 mpeg mudflap musepack musicbrainz ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png postscript ppds pppd pulseaudio python qt3 qt3support qt4 quicktime readline reflection samba sdl session sndfile soundtouch spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora tiff truetype twolame unicode usb vcd vorbis win32codecs wmf wxwindows x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 5 telperion 2009-02-02 19:09:42 UTC
gentoobox ~ # emerge -av gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gnome-2.24.1  USE="cdr cups dvdr esd ldap -accessibility -mono" 0 kB


gentoobox ~ # emerge -av nautilus

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/nautilus-2.24.2  USE="X gnome -beagle -debug -doc -tracker -xmp" 0 kB


Comment 6 Philipp Leonhardt 2009-02-04 09:02:32 UTC
same here for me on
gnome-base/nautilus-2.24.2

i updated something but i don't know what.
In Ubuntu repository there is no translation patch for nautilus-2.24.2
so it should be another problem.
Comment 7 telperion 2009-02-04 12:11:50 UTC
brasero brasero brasero!

app-cdr/brasero-0.9.1 is the problem,

downgrade to 

app-cdr/brasero-0.8.4-r1

then

killall nautilus

and all is fine, correct language in all the item.


Comment 8 labor_ratte 2009-02-04 17:11:18 UTC
(In reply to comment #7)
> brasero brasero brasero!
> 
> app-cdr/brasero-0.9.1 is the problem,
> 
> downgrade to 
> 
> app-cdr/brasero-0.8.4-r1
> 
> then
> 
> killall nautilus
> 
> and all is fine, correct language in all the item.
> 

Yes, that's it!
Another temporary solution for me is:
# USE="-nautilus" emerge -a brasero
So the extensions don't get installed.
Comment 9 Pacho Ramos gentoo-dev 2009-02-04 19:11:12 UTC
Good catch! :-D

I also have found upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=569204
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-02-04 19:54:17 UTC
that's unfortunate but that's what you get for installing something that ought to replace nautilus-cd-burner and is currently in development scheduled to release for 2.26. There is a good chance the it's a gettext domain collision issue. Nothing to do for gnome but keeping us CCed, reassigning to media-optical.
Comment 11 Pacho Ramos gentoo-dev 2009-02-04 20:52:26 UTC
Created attachment 180960 [details, diff]
brasero-i18n.patch

Upstream has just fixed the bug, this backported patch works fine with 0.9.1 and should with with 2.25.90 also
Comment 12 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-08 14:57:48 UTC
+*brasero-2.25.90 (08 Feb 2009)
+
+  08 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+  +files/brasero-2.25.90-il8n.patch, -brasero-0.9.1.ebuild,
+  +brasero-2.25.90.ebuild:
+  Bump to latest development version. Fix bug 256406, brasero causes
+  nautilus to be semi-translated, thanks to Pacho Ramos
+  <pacho@condmat1.ciencias.uniovi.es> for report and patch. Add blurb about
+  gstreamer plugin having to be installed for each codec w.r.t. bug 256830.
+  Dropped keywords for ppc and ppc64 because they haven't keyworded
+  nautilus-2.24.x, bug 258134.
+

Thanks again, Pacho.