Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 256352

Summary: emerge dev-java/sun-jdk-1.4.2.19 failed
Product: Gentoo Linux Reporter: Anton <dr4k0n>
Component: [OLD] DevelopmentAssignee: Java team <java>
Status: VERIFIED INVALID    
Severity: normal CC: arttuv69
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Anton 2009-01-25 21:31:53 UTC
When I emerge eclipse-sdk, it want to install dev-java/sun-jdk-1.4.2.19, which failed....



Reproducible: Always




EMERGE LOG:

-------------------------------------------------
# emerge eclipse-sdk
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 68) dev-java/sun-jdk-1.4.2.19
>>> Creating Manifest for /usr/portage/dev-java/sun-jdk
  digest.assumed                 4
   sun-jdk-1.4.2.19::j2sdk-1_4_2_19-linux-i586.bin
   sun-jdk-1.4.2.19::jce_policy-1_4_2.zip
   sun-jdk-1.5.0.17::jdk-5.0u17-dlj-linux-i586.bin
   sun-jdk-1.6.0.11::jdk-6u11-dlj-linux-i586.bin
 * checking ebuild checksums ;-) ...                                                                                                 [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                [ ok ]
 * checking miscfile checksums ;-) ...                                                                                               [ ok ]
You should enable -g (or higher) for debugging!
>>> Creating Manifest for /usr/portage/dev-java/sun-jdk
  digest.assumed                 4
   sun-jdk-1.4.2.19::j2sdk-1_4_2_19-linux-i586.bin
   sun-jdk-1.4.2.19::jce_policy-1_4_2.zip
   sun-jdk-1.5.0.17::jdk-5.0u17-dlj-linux-i586.bin
   sun-jdk-1.6.0.11::jdk-6u11-dlj-linux-i586.bin
>>> Unpacking source...
 * 
 * ERROR: dev-java/sun-jdk-1.4.2.19 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2484:  Called die
 * The specific snippet of code:
 *           die "cannot read ${At}. Please check the permission and try again.";
 *  The die message:
 *   cannot read j2sdk-1_4_2_19-linux-i586.bin. Please check the permission and try again.
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/sun-jdk-1.4.2.19/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/sun-jdk-1.4.2.19/temp/environment'.
 * 

>>> Failed to emerge dev-java/sun-jdk-1.4.2.19, Log file:

>>>  '/var/tmp/portage/dev-java/sun-jdk-1.4.2.19/temp/build.log'

 * Messages for package dev-java/sun-jdk-1.4.2.19:

 * 
 * ERROR: dev-java/sun-jdk-1.4.2.19 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2484:  Called die
 * The specific snippet of code:
 *           die "cannot read ${At}. Please check the permission and try again.";
 *  The die message:
 *   cannot read j2sdk-1_4_2_19-linux-i586.bin. Please check the permission and try again.
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/sun-jdk-1.4.2.19/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/sun-jdk-1.4.2.19/temp/environment'.
 * 

----------------------------------------





emerge --info:

--------------------------------

# emerge --info
Portage 2.1.6.4 (default/linux/amd64/2008.0/developer, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r9 x86_64)
=================================================================
System uname: Linux-2.6.23-gentoo-r9-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_275-with-glibc2.2.5
Timestamp of tree: Sun, 25 Jan 2009 19:45:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r14, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.7-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64 x86"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=opteron -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg collision-protect cvs digest distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms sign splitdebug strict stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://gentoo.tiscali.nl/pub/mirror/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo "
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex 3dnowext X a52 aac aalib acl acpi alsa amd64 apache2 apm bcmath berkdb bluetooth bzip2 cairo cdr cgi cli cracklib crypt cups curl curlwrappers dbus djvu dri dvd dvdr dvdread eds emboss encode esd evo fam firefox flac fortran gd-external gdbm geoip gif gnome gpm gstreamer gtk hal hddtemp iconv imap isdnlog jack java javascript jpeg kerberos latex ldap libgda libnotify lzo mad mailwrapper mhash midi mikmod mmx mmxext mp3 mpeg mudflap multilib mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcntl pcre pdf perl php png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline reflection rss samba scanner sdl session slang snmp soap sockets spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb vcd vorbis xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



---------------------------
Comment 1 Arttu Valo 2009-01-27 15:13:11 UTC
Given your ACCEPT_KEYWORDS this has a high potential of being a duplicate of, e.g., bug #242106 -- with just incremented version of the sun-jdk package.

They're listing quite a load of things that could be wrong. Maybe you can see all the suggestions over there and check if some of those would work for you?
Comment 2 Petteri R├Ąty (RETIRED) gentoo-dev 2009-01-27 20:23:15 UTC
(In reply to comment #0)
> ACCEPT_KEYWORDS="amd64 x86"

(In reply to comment #1)
> Given your ACCEPT_KEYWORDS this has a high potential of being a duplicate of,
> e.g., bug #242106 -- with just incremented version of the sun-jdk package.
> 

Good catch. ACCEPT_KEYWORDS like this are not supported so marking as INVALID. Please reopen if you can reproduce with something supported.
Comment 3 Anton 2009-01-28 01:50:19 UTC
(In reply to comment #2)
> (In reply to comment #0)
> > ACCEPT_KEYWORDS="amd64 x86"
> 
> (In reply to comment #1)
> > Given your ACCEPT_KEYWORDS this has a high potential of being a duplicate of,
> > e.g., bug #242106 -- with just incremented version of the sun-jdk package.
> > 
> 
> Good catch. ACCEPT_KEYWORDS like this are not supported so marking as INVALID.
> Please reopen if you can reproduce with something supported.
> 

I set ACCEPT_KEYWORDS="amd64" and eclipse-sdk installed fine!