Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 255896

Summary: net-analyzer/netperf: automake called by maintainer-mode
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Netmon Herd <netmon>
Status: RESOLVED FIXED    
Severity: QA    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://blog.flameeyes.eu/2008/06/13/maintaner-mode
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 226305    
Attachments: Build log

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:54:26 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:54:40 UTC
Created attachment 179262 [details]
Build log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2009-08-26 00:52:25 UTC
Fixed in version bump 2.4.5.