Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 254783

Summary: version bump sci-electronics/geda-suite-20090113
Product: Gentoo Linux Reporter: Marcel Schmedes <sm>
Component: New packagesAssignee: The Soldering-Iron Brotherhood <sci-electronics>
Status: RESOLVED FIXED    
Severity: enhancement CC: patrick
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 245704, 254781, 254784, 254785    
Bug Blocks:    
Attachments: new ebuild for geda-suite
diff geda-suite-20090112 to geda-suite-20050820 ebuild
new ebuild for geda-suite
diff geda-suite-20090113 to geda-suite-20050820 ebuild

Description Marcel Schmedes 2009-01-13 07:33:40 UTC
Updated geda tools collection suite.
Works out-of-the-box (TM) (need depend. Bug)

Reproducible: Always

Steps to Reproduce:
Comment 1 Marcel Schmedes 2009-01-13 07:38:17 UTC
Created attachment 178322 [details]
new ebuild for geda-suite
Comment 2 Marcel Schmedes 2009-01-13 07:39:09 UTC
Created attachment 178323 [details, diff]
diff geda-suite-20090112 to geda-suite-20050820 ebuild
Comment 3 Marcel Schmedes 2009-01-13 08:09:58 UTC
Created attachment 178324 [details]
new ebuild for geda-suite

New Attachment with geda-1.4.3
Comment 4 Marcel Schmedes 2009-01-13 08:10:32 UTC
Created attachment 178326 [details, diff]
diff geda-suite-20090113 to geda-suite-20050820 ebuild

New diff with geda-1.4.3
Comment 5 C W Rose 2009-02-17 16:03:03 UTC
Could you please change the IUSE='' string in this
ebuild to IUSE=""?  geda-suite is the only ebuild
to use this formulation, and it's a nuisance when
parsing ebuilds.

Thanks - Will
Comment 6 Patrick Lauer gentoo-dev 2009-03-07 22:02:27 UTC
Trying to update to the attached ebuild I hit a failure in iverilog, so cannot bump yet.
Comment 7 Patrick Lauer gentoo-dev 2009-03-07 22:04:42 UTC
Adding iverilog bug as dependency
Comment 8 Denis Dupeyron gentoo-dev 2009-04-22 22:52:44 UTC
Marcel, Patrick,

Stefan Salewski and I are reworking the geda ebuild and splitting it. So I'd rather we hold off on that one for a bit.

Thanks,
Denis.
Comment 9 Daniel Kukula 2010-02-27 12:07:07 UTC
(In reply to comment #8)
> Marcel, Patrick,
> 
> Stefan Salewski and I are reworking the geda ebuild and splitting it. So I'd
> rather we hold off on that one for a bit.
> 
> Thanks,
> Denis.
> 
Hi. Any info about it, in portage it is still only avaliable the version from 2005  gives some errors:

[blocks B     ] sci-electronics/geda-symbols ("sci-electronics/geda-symbols" is blocking sci-electronics/geda-1.6.1)

Comment 10 Thomas Beierlein gentoo-dev 2010-03-07 12:47:38 UTC
In reply to comment #9

Just unmerge geda-symbols before merging geda-1.6.1
Comment 11 c.h. 2010-03-19 11:19:43 UTC
(In reply to comment #10)
> In reply to comment #9
> 
> Just unmerge geda-symbols before merging geda-1.6.1
> 

2 points:
1. the version is still 2005xxxx, where is the bumped 2009xxxxx
2. it is ebuild itself tries to emerge both geda-symbols and geda-1.6.1 (i.e. both are not emerged yet.)
Comment 12 c.h. 2010-03-19 11:24:00 UTC
(In reply to comment #10)
> In reply to comment #9
> 
> Just unmerge geda-symbols before merging geda-1.6.1
> 

2 points:
1. the version is still 2005xxxx, where is the bumped 2009xxxxx
2. it is ebuild itself tries to emerge both geda-symbols and geda-1.6.1 (i.e. both are not emerged yet.)(In reply to comment #11)
> (In reply to comment #10)
> > In reply to comment #9
> > 
> > Just unmerge geda-symbols before merging geda-1.6.1
> > 
> 
> 2 points:
> 1. the version is still 2005xxxx, where is the bumped 2009xxxxx
oops... missed the "hold off" comment.....
> 2. it is ebuild itself tries to emerge both geda-symbols and geda-1.6.1 (i.e.
> both are not emerged yet.)
> 

Comment 13 Thomas Beierlein gentoo-dev 2011-04-30 06:23:03 UTC
A new version is in tree now.

+*geda-suite-20110427 (30 Apr 2011)
+
+  30 Apr 2011; Thomas Beierlein <tomjbe@gentoo.org>
+  +geda-suite-20110427.ebuild:
+  Adapted to actual gEDA tools suite
+