Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 254727

Summary: media-sound/radiomixer: package needs at least one USE flag but no USE flag enabled by default
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Markus Ullmann (RETIRED) <jokey>
Status: RESOLVED FIXED    
Severity: QA    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://blog.flameeyes.eu/2009/01/12/tinderboxing-problems-missing-default-use-flags
Whiteboard:
Package list:
Runtime testing required: ---

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-12 23:08:18 UTC
Hello,

You're receiving this canned (template-based) bug report because I found an annoyance with a package during my tinderbox run.

The package in question is checking for one out of a series of USE flags to be enabled, likely because these are multiple selectable backends, but it currently does not use the EAPI=1 feature of default USE flags to work out of the box.

You can see in my blog post in the URL field why that's a problem, and how to address the issue.

It would be very kind of you for both users and developers working on automated reporting, if the ebuild for the package enabled by default at least one backend (more might be enabled if needed).

Please note that sometimes you don't feel the need for this because the desktop profile already enables some of the USE flags, but please consider the idea of enabling them nonetheless, it would help a lot.

Thanks,
Diego
Comment 1 Gene Seto 2009-01-24 21:19:07 UTC
updated the ebuild here http://bugs.gentoo.org/show_bug.cgi?id=251250.
Comment 2 Markus Ullmann (RETIRED) gentoo-dev 2009-01-31 21:40:29 UTC
Added the updates to CVS, thanks Gene