Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 252463

Summary: dev-util/git- fails make check
Product: Gentoo Linux Reporter: Hans de Graaff <graaff>
Component: New packagesAssignee: Fernando J. Pereda (RETIRED) <ferdy>
Severity: normal CC: robbat2
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Hans de Graaff gentoo-dev Security 2008-12-25 11:15:26 UTC
I'm emerging git with the following use flags: 

[ebuild     U ] dev-util/git- [] USE="bash-completion cgi curl gtk iconv mozsha1 perl subversion vim-syntax%* xinetd -cvs -doc -emacs (-ppcsha1) -threads -tk -webdav" 0 kB

I have subversion installed:
[ebuild   R   ] dev-util/subversion-1.5.4  USE="apache2 bash-completion dso nls perl python ruby vim-syntax webdav-neon -berkdb -debug -doc -emacs -extras -java -sasl -webdav-serf" 0 kB

And getting these test failures for the git svn support. There are actually more errors, but I think these are all due to the initial failures. Let me know if all of the output is useful.

*** ***
* define NO_SVN_TESTS to skip git-svn tests
*   ok 1: initialize git-svn
* FAIL 2: import an SVN revision into git
	git-svn fetch
*   ok 3: checkout from svn
* FAIL 4: try a deep --rmdir with a commit
		git checkout -f -b mybranch remotes/git-svn &&
		mv dir/a/b/c/d/e/file dir/file &&
		cp dir/file file &&
		git update-index --add --remove dir/a/b/c/d/e/file dir/file file &&
		git commit -m "$name" &&
		git-svn set-tree --find-copies-harder --rmdir \
			remotes/git-svn..mybranch &&
		svn up "$SVN_TREE" &&
		test -d "$SVN_TREE"/dir && test ! -d "$SVN_TREE"/dir/a
* FAIL 5: detect node change from file to directory #1
		mkdir dir/new_file &&
		mv dir/file dir/new_file/file &&
		mv dir/new_file dir/file &&
		git update-index --remove dir/file &&
		git update-index --add dir/file/file &&
		git commit -m 'detect node change from file to directory #1' &&
		test_must_fail git-svn set-tree --find-copies-harder --rmdir 		remotes/git-svn..mybranch
Comment 1 Hans de Graaff gentoo-dev Security 2008-12-27 11:17:28 UTC
Just had some time to dig around in this. It turns out that the perl binary gets a segmentation fault, or rather the shared object installed by subversion:

#0  0x00007f063e9ced00 in ?? ()
#1  0x00007f064097b09d in run_cleanups (cref=0x2bb28d8) at memory/unix/apr_pools.c:2288
#2  0x00007f064097bb27 in apr_pool_destroy (pool=0x2bb28b8) at memory/unix/apr_pools.c:774
#3  0x00007f064097bb15 in apr_pool_destroy (pool=0x2ba9888) at memory/unix/apr_pools.c:771
#4  0x00007f064097bb15 in apr_pool_destroy (pool=0x2935ee8) at memory/unix/apr_pools.c:771
#5  0x00007f064097be4c in apr_pool_terminate () at memory/unix/apr_pools.c:602
#6  0x00007f0641424eb3 in _wrap_apr_terminate ()
   from /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/auto/SVN/_Core/
#7  0x0000000000477216 in Perl_pp_entersub ()
#8  0x0000000000475aae in Perl_runops_standard ()
#9  0x00000000004253e9 in Perl_call_sv ()
#10 0x00000000004257bc in Perl_call_list ()
#11 0x000000000042912e in perl_destruct ()
#12 0x0000000000422158 in main ()

I currently have dev-lang/perl-5.8.8-r5, dev-libs/apr-1.3.2 and subversion 1.5.4 installed.
Comment 2 Hans de Graaff gentoo-dev Security 2008-12-27 12:20:02 UTC
I've tried several git versions to see if this problem was recently introduced on the git side of things, but all versions that I tried, including git-, now fail in this particular way. I am currently using git- and I'm sure all tests passed when I initially installed it, so the reason most likely is in the combination of the other software components.
Comment 3 Hans de Graaff gentoo-dev Security 2008-12-27 13:55:38 UTC
This is another manifestation of bug #223747. Recompiling subversion with -dso USE flag fixed things and all tests now pass.

*** This bug has been marked as a duplicate of bug 223747 ***