Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 251616

Summary: portage hangs after tests run
Product: Portage Development Reporter: Peter Volkov (RETIRED) <pva>
Component: CoreAssignee: Portage team <dev-portage>
Severity: normal Keywords: InVCS, REGRESSION
Priority: High    
Version: 2.2   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 210077, 216231    
Attachments: bzr-1.10-r1.ebuild
remove unnecessary regex patterns that cause problems

Description Peter Volkov (RETIRED) gentoo-dev 2008-12-19 12:46:59 UTC
This is really weird bug. After I've disabled failing tests in bzr tests pass but then emerge process hangs after:

>>> Completed installing bzr-1.10-r1 into /vt/portage/tmp/portage/dev-util/bzr-1.10-r1/image/

hang... 100% cpu load.
Comment 1 Peter Volkov (RETIRED) gentoo-dev 2008-12-19 12:51:46 UTC
Created attachment 175862 [details]

to reproduce the problem run
FEATURES=test emerge -v bzr

I've tried to reduce number tests but failed: at some point I've reduced to 4 tests branches (by branches I mean blackbox.*, )test_http.* and so on - tests having same beginning in their name) but then after I've tried to reduce to two, emerge passes. When I back to 4 tests it stopped to hang too but when I back to all tests it hangs.
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2008-12-19 12:55:43 UTC
And forgot to note. To avoid tests failures you need net-misc/curl-7.18.2 and dev-python/pycurl-7.16.4... I have not checked if I disabled all tests for newer versions of this libraries.
Comment 3 Zac Medico gentoo-dev 2008-12-19 21:42:06 UTC
Created attachment 175901 [details, diff]
remove unnecessary regex patterns that cause problems

The test suite uses \r to rewrite the same line thousands of times and this triggers a performance issue in the regex patterns that are used to search the build log for QA issues.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2008-12-20 10:45:08 UTC
Thank you very much Zac. It works.
Comment 5 Zac Medico gentoo-dev 2008-12-20 22:30:55 UTC
This is fixed in and 2.2_rc18.