Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 249748

Summary: Request to add offensive USE flag to gnome-screensaver package
Product: Gentoo Linux Reporter: don quixada <quixada>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED WONTFIX    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://forums.gentoo.org/viewtopic-p-5298538.html#5298538
Whiteboard:
Package list:
Runtime testing required: ---

Description don quixada 2008-12-03 23:00:32 UTC
I'm not sure how this issue can be resolved since it applies to both xscreensaver and gnome-screensaver, but effectively there is no way of disabling the  "webcollage" hack short of deleting it it manually. The "webcollage" hack has the potential to display porn. See the following bug discussion:

http://bugs.gentoo.org/show_bug.cgi?id=249673

Please supply a simple and intuitive way to disable offensive screensavers while still being able to use the xscreensaver hacks.
Comment 1 Mart Raudsepp gentoo-dev 2008-12-03 23:15:41 UTC
No. We provide for convenience a script that by default creates .desktop files necessary for gnome-screensaver out of ALL of what's available in xscreensaver.
If you don't want a *.desktop file for webcollage, simply don't create it.

If you insist, you can try adding a --no-offensive option to the script found in /usr/share/doc/gnome-screensaver-*/migrate-xscreensaver-config.sh* and contributing that, so that it would be easy to migrate all xscreensavers for use by gnome-screensaver.
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-03-01 20:31:19 UTC
Closing wontfix per comment #1, please reopen if there is some patch we can apply to the conversion script.