Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 249226 (gcc-4.4)

Summary: [tracker] GCC 4.4 porting
Product: Gentoo Linux Reporter: Ryan Hill (RETIRED) <rhill>
Component: [OLD] GCC PortingAssignee: Please assign to toolchain <gcc-porting>
Status: RESOLVED FIXED    
Severity: normal CC: 404errorqc, accounts.niko.bockerman, AlonsoSchaich, ansla80, asturm, axiator, didier-bugzillagentoo, dmahler, esigra, facorread, gabriel, greg, haavardw, hiyuh.root, jaak, jlp.bugs, jrmalaq, kanelxake, loki_val, mrybarski, n-roeser, nikoli, please.no.spam.here, rahul, smoothhound, szarpaj, vyacheslavovich, web, ziga.boehm, zorry
Priority: High Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 233958, 248738, 249224, 250813, 251030, 251034, 252287, 252745, 253143, 254254, 254256, 256654, 256777, 257627, 257643, 258377, 260802, 260815, 260919, 262286, 262319, 263215, 264040, 264229, 264464, 264543, 264686, 264761, 265041, 265044, 265046, 265322, 265579, 265750, 265758, 267453, 267466, 267472, 267784, 267816, 268086, 268430, 268992, 269114, 269148, 269150, 269190, 269239, 269240, 269242, 269245, 269250, 269252, 269254, 269258, 269260, 269275, 269278, 269302, 269307, 269311, 269312, 269320, 269324, 269328, 269329, 269452, 269618, 269674, 269678, 269728, 269751, 269803, 269866, 269975, 269986, 270093, 270116, 270120, 270129, 270593, 270638, 270720, 270916, 270926, 271236, 271251, 271475, 271605, 271607, 271608, 271611, 271617, 271619, 271630, 271636, 271645, 271657, 271814, 271843, 271890, 272019, 272120, 272250, 272316, 272374, 272375, 272377, 272417, 272514, 272567, 272601, 272625, 272703, 272770, 272851, 273159, 273161, 273182, 273233, 273275, 273369, 273396, 273400, 273424, 273428, 273500, 273504, 273505, 273506, 273520, 273524, 273526, 273531, 273532, 273534, 273575, 273828, 273832, 273834, 273837, 273839, 273840, 273843, 273845, 273900, 273977, 273990, 273996, 274000, 274001, 274010, 274012, 274018, 274039, 274041, 274044, 274116, 274121, 274131, 274164, 274168, 274219, 274220, 274242, 274261, 274281, 274315, 274316, 274583, 275062, 275126, 275128, 275169, 275715, 275791, 275802, 275812, 275903, 275908, 275911, 275915, 275916, 276188, 276196, 276231, 276239, 276246, 276288, 276291, 276493, 276495, 276510, 276562, 276660, 276676, 276686, 276691, 276740, 276742, 276841, 276843, 276890, 276906, 276956, 277082, 277106, 277151, 277157, 277175, 277179, 277188, 277216, 277220, 277246, 277314, 277409, 277421, 277422, 277426, 277561, 277562, 277564, 277565, 277579, 277591, 277632, 277659, 277660, 277668, 277673, 277731, 277733, 277736, 277758, 277762, 277765, 277770, 277797, 277937, 278068, 278071, 278079, 278106, 278109, 278154, 278155, 278216, 278247, 278427, 278432, 278462, 279160, 279483, 279572, 279657, 279881, 279890, 279972, 280236, 280237, 280704, 280824, 280988, 281047, 281077, 281733, 281763, 282676, 284478, 284524, 287638, 288124, 291231, 294571, 294585, 295980, 298223, 300595, 311573, 311595, 320353, 330165, 333501, 376451    
Bug Blocks: 280941, 302468    

Description Ryan Hill (RETIRED) gentoo-dev 2008-11-29 05:13:07 UTC
This bug will be used to track packages that are broken by the upcoming GCC 4.4.

  - Please file a NEW bug for each package and make it BLOCK this one.
  - GCC 4.3 porting issues should not block this bug.  Use bug #198121 instead.
  - Do NOT use this bug for issues with GCC-4.4 itself.  File a new bug and
assign it to toolchain.
  - Do NOT add comments, logs, patches, discussion, rants, or stories about
your Uncle Milt here.  There are other channels for such things.


Until 4.4.0 is released, filing bugs without patches enclosed is strongly
discouraged and will likely end up RESOLVED WONTFIX.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-11-29 21:11:54 UTC
something new i want to try.  when filing bugs against packages, please include a link to the bug or ml message where the patch has been reported upstream, or the diff or commit message where the patch was applied.
Comment 2 Daniel J. 2008-12-23 15:01:38 UTC
Lots more GCC 4.4-broken packages (and suggested fixes) can be found by Googling
site:bugs.debian.org ftbfs-gcc-4.4
I'll be filing more reports based on results of that search.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-03-09 10:46:42 UTC
Alexander E. Patrakov sent my way a common problem in multiple packages with the dtoa.c source file: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=518927

I'll be starting a tree scan today, and report packages that do contain that.
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-03-10 01:38:32 UTC
nspr and konqueror do.  nspr is fixed in the gcc-porting overlay.  see https://bugzilla.mozilla.org/show_bug.cgi?id=439144 for the update of dtoa that was sent to the author.  also https://bugzilla.redhat.com/show_bug.cgi?id=487844.
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-03-10 01:42:01 UTC
mozilla-derived software also have the problem (nvu and sunbird, as well as virtualbox). It also was present in ruby 1.9.1_pre1 (not sure on the current one, the process is still working in series.

dtoa.c files are present in cdrtools and cdrdao although they don't hit the particular word1 define Alexander pointed out.
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2009-03-10 02:14:53 UTC
ruby is built w/ -fno-strict-aliasing, so it won't hit the problem either, but yes, i'd like to have that flag used on as few packages as possible.
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-03-12 15:03:44 UTC
For reference here is the list of packages that do contain the broken dtoa.c:

/var/log/dtoa-scan/app-editors:nvu-1.0-r4.log
/var/log/dtoa-scan/app-emacs:ruby-mode-1.9.1_pre1.log
/var/log/dtoa-scan/app-emulation:virtualbox-guest-additions-2.1.4.log
/var/log/dtoa-scan/app-emulation:virtualbox-ose-2.1.4-r1.log
/var/log/dtoa-scan/app-office:mozilla-sunbird-0.9.log
/var/log/dtoa-scan/dev-lang:mono-2.2-r3.log
/var/log/dtoa-scan/dev-lang:polyml-5.2.1.log
/var/log/dtoa-scan/dev-lang:ruby-1.8.6_p287-r12.log
/var/log/dtoa-scan/dev-libs:nspr-4.7.3.log
/var/log/dtoa-scan/kde-base:kdelibs-3.5.10-r2.log
/var/log/dtoa-scan/mail-client:mozilla-thunderbird-2.0.0.19.log
/var/log/dtoa-scan/net-libs:webkit-gtk-0_p40220.log
/var/log/dtoa-scan/net-libs:xulrunner-1.8.1.19.log
/var/log/dtoa-scan/net-libs:xulrunner-1.9.0.7.log
/var/log/dtoa-scan/www-client:seamonkey-1.1.14.log
/var/log/dtoa-scan/x11-drivers:xf86-input-virtualbox-2.1.4.log
/var/log/dtoa-scan/x11-drivers:xf86-video-virtualbox-2.1.4.log
/var/log/dtoa-scan/x11-libs:qt-assistant-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-demo-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-gui-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-opengl-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-phonon-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-qt3support-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-sql-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-svg-4.5.0.log
/var/log/dtoa-scan/x11-libs:qt-webkit-4.5.0.log
/var/log/dtoa-scan/x11-plugins:enigmail-0.95.7-r3.log
/var/log/dtoa-scan/x11-plugins:lightning-0.9.log
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2009-03-27 02:47:30 UTC
Results of building rawhide w/ 4.4:
https://www.redhat.com/archives/fedora-devel-list/2009-February/msg00180.html
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-01 10:44:09 UTC
Link to debian bug reports

http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=ftbfs-gcc-4.4;users=debian-gcc@lists.debian.org
Comment 10 Evan Teran 2009-05-16 23:12:31 UTC
I have noticed something and am not sure if it is a real "bug". Basically shortly after I installed gcc-4.4, I started to recompile things with it. I started getting crashes when launching firefox and thunderbird. Finally I traced it down to the fact that I had compiled libzip with -O3. Switching my flags to the more sane -O2 and recompiling that lib fixed things.

So my question is:

if an application or library used to work with -O3 and doesn't anymore, is that a regression? I imagine that the lib breaks strict aliasing rules causing -O3 to break the code.

I know that Gnome's policy is not to accept bugs caused by -O3, what is gentoo's overall policy on this?
Comment 11 Ryan Hill (RETIRED) gentoo-dev 2009-05-17 03:29:16 UTC
I'd consider it a regression.  I don't know if our Gnome team would, but at the very least they could add a `replace-flags -O3 -O2` to the ebuild (though in a perfect world i would like to see the actual bug fixed).

I'm not sure this is an aliasing bug though, since strict aliasing is enabled at -O2.  It could be related to the vectorizer which is enabled at -O3 for some architectures.  If you want to narrow it down, you can see what flags are turned on by -O3 like so:

$ gcc-4.4.0 -O2 -Q --help=opt > gcc44.o2.flags
$ gcc-4.4.0 -O3 -Q --help=opt > gcc44.o3.flags
$ diff -u gcc44.o2.flags gcc44.o3.flags

But in any case, please file a bug for libzip so we can investigate it.