Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 247839

Summary: x11-drivers/xf86-input-evtouch - needs freemono font?
Product: Gentoo Linux Reporter: Balint Dobai-Pataky <dpblnt>
Component: [OLD] UnspecifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: High    
Version: 2008.0   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Balint Dobai-Pataky 2008-11-20 22:31:57 UTC 
evalibrate located at /usr/local/bin/ev_calibrate
xinit located at /usr/bin/xinit
xserver located at /usr/bin/X
Creating FIFO...
Starting calibration program...

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN 
Current Operating System: Linux touch 2.6.25-gentoo-r9 #1 SMP PREEMPT Thu Nov 20 22:06:58 EET 2008 i686
Build Date: 21 November 2008
	Before reporting problems, check
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 21 05:32:20 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in

(II) Module already built-in
(EE) intel(0): [dri] I830CheckDRIAvailable failed: dri not loaded
(EE) AIGLX: DRI module not loaded
State: S_UNTOUCHED	Action: No Action		Button: 0
State: S_TOUCHED	Action: No Action		Button: 0
State: S_LONGTOUCHED	Action: down		Button: 1
State: S_MOVING	Action: No Action		Button: 0
State: S_MAYBETAPPED	Action: click		Button: 1
State: S_ONEANDAHALFTAP	Action: click		Button: 1
XLoadQueryFont: failed loading font '*freemono*'

Reproducible: Always

i was not able to find this freemono font on my installed systems.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-21 02:21:32 UTC
It's accessing files in the wrong places. An image of the binary package the ebuild would build would have these files:

while you have some files in /usr/local. I suggest you remove those and reopen this bug report if that still doesn't solve the issue.
Comment 2 Balint Dobai-Pataky 2008-11-21 05:43:14 UTC
true, sorry, that must have remained there from a previous ebuild of mine somehow.
i removed that and it works now.