Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 246518

Summary: net-libs/webkit-gtk-0_p37894 - WebCore/css/CSSGrammar.y:348.11-20: symbol maybe_sgml redefined
Product: Gentoo Linux Reporter: Jürgen Geuter <tante>
Component: Current packagesAssignee: Markus Ullmann (RETIRED) <jokey>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: alexxy, auke, daniel.perzynski, derek.berube, devurandom, fuzzyray, georgi, greg, ikelos, m.debruijne, paul.hartman, renatogallo, rob, scy-bugs-gentoo, Sergiy.Borodych, sfullenwider, steven
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: log fil of the build
like this it works like a charm

Description Jürgen Geuter 2008-11-12 17:23:28 UTC
I tried building net-libs/webkit-gtk-0_p37894 with two different useflag combinations, both failed with the same error. The combinations were:

net-libs/webkit-gtk-0_p37894  USE="gstreamer pango sqlite svg -coverage -debug -soup -xslt"
net-libs/webkit-gtk-0_p37894  USE="gstreamer pango sqlite svg soup xslt -coverage -debug"

The build dies almost instantly with the following error:

make -j3
/usr/bin/perl JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/keywords.table > DerivedSources/lexer.lut.h
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/ArrayPrototype.cpp -i > JavaScriptCore/kjs/ArrayPrototype.lut.h
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/DatePrototype.cpp -i > JavaScriptCore/kjs/DatePrototype.lut.h
Creating hashtable for JavaScriptCore/kjs/DatePrototype.cpp
Creating hashtable for JavaScriptCore/kjs/keywords.table
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/MathObject.cpp -i > JavaScriptCore/kjs/MathObject.lut.h
Creating hashtable for JavaScriptCore/kjs/ArrayPrototype.cpp
Creating hashtable for JavaScriptCore/kjs/MathObject.cpp
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/NumberConstructor.cpp -i > JavaScriptCore/kjs/NumberConstructor.lut.h
Creating hashtable for JavaScriptCore/kjs/NumberConstructor.cpp
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/RegExpConstructor.cpp -i > JavaScriptCore/kjs/RegExpConstructor.lut.h
Creating hashtable for JavaScriptCore/kjs/RegExpConstructor.cpp
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/RegExpObject.cpp -i > JavaScriptCore/kjs/RegExpObject.lut.h
Creating hashtable for JavaScriptCore/kjs/RegExpObject.cpp
JavaScriptCore/kjs/create_hash_table JavaScriptCore/kjs/StringPrototype.cpp -i > JavaScriptCore/kjs/StringPrototype.lut.h
Creating hashtable for JavaScriptCore/kjs/StringPrototype.cpp
JavaScriptCore/pcre/dftables JavaScriptCore/pcre/chartables.c
/usr/bin/bison -d -p kjsyy ./JavaScriptCore/kjs/grammar.y -o DerivedSources/grammar.cpp > bison_out.txt 2>&1
rm -f ./DerivedSources/CSSGrammar.cpp.h ./DerivedSources/CSSGrammar.hpp
/usr/bin/bison -d -p cssyy WebCore/css/CSSGrammar.y -o ./DerivedSources/CSSGrammar.cpp
WebCore/css/CSSGrammar.y:348.11-20: symbol maybe_sgml redefined
make: *** [DerivedSources/CSSGrammar.cpp] Error 1
make: *** Waiting for unfinished jobs....
/usr/bin/perl -p -e 'END { if ($conflict) { unlink "grammar.cpp"; die; } } $conflict ||= /conflict/' < bison_out.txt
cat ./DerivedSources/grammar.hpp > ./DerivedSources/grammar.h
rm -f ./DerivedSources/grammar.hpp bison_out.txt
 * 
 * ERROR: net-libs/webkit-gtk-0_p37894 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2586:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-0_p37894/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-0_p37894/temp/environment'.
 * 

Reproducible: Always

Steps to Reproduce:




emerge --info
Portage 2.2_rc14 (default/linux/amd64/2008.0/desktop, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Wed, 12 Nov 2008 06:32:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r15, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/cwiid /usr/local/portage/layman/gnome /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X X509 a52 aac aalib acl acpi administrator aim alsa amarok amazon amd64 ao apache2 applet async audiofile autoipd automount avahi bash-completion berkdb bluetooth bogofilter bonjour branding bzip2 cairo caps cdb cddb cdio cdparanoia cdr chroot cli colordiff cracklib crypt cscope css cups curl cvs daap dbus device-mapper disk-partition dri dts dvd dvdr dvdread eds emboss encode esd evo exif expat fam fat ffmpeg firefox flac fontconfig fortran fuse gconf gd gdbm gdm gedit geoip gif gimp glade glib gmail gnome gnome-keyring gnutls gpg gphoto2 gpm grub gstreamer gtk gtkhtml gzip hal hdaps hddtemp ibam icons iconv icq id3 id3tag imagemagick imap imlib imlib2 ipod ipv6 isdnlog jabber javascript john jpeg jpeg2k json kpathsea lame laptop latex libgda libnotify libsamplerate libwww lm_sensors loop-aes lvm mad maildir matroska mdnsresponder-compat midi mikmod mime mjpeg mmap mmx mng mono mozdevelop mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib music musicbrainz mysql mysqli nautilus ncurses network networkmanager nfs nls nptl nptlonly nsplugin ntfs ntp obex offensive ogg ogg123 openal opengl openid openmp oscar pam pango parted pcmcia pcre pdf pdo perl php pidgin pixmaps plugins png pop posix postgres postscript ppds pppd pulseaudio python pyzord qemu qt3 qt3support qt4 query-browser quicktime rar rdesktop readline reflection reiserfs rss samba sdl session sharedmem silc simplexml smp sndfile sockets spell spl sql sqlite sqlite3 sse sse2 ssl startup-notification stream subversion svg sysfs syslog t1lib taglib tagwriting talkfilters tcpd tetex theora threads tidy tiff totem tracker transcode truetype twolame type1 unicode unzip upnp usb v4l2 vcd vcdx vhosts vim-syntax vnc vorbis wav webdav webdav-neon wifi wmf wxwindows x264 xattr xcb xcf xcomposite xft xine xinerama xml xmlrpc xorg xosd xpm xrandr xscreensaver xulrunner xv xvid yahoo zeroconf zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jürgen Geuter 2008-11-12 17:24:57 UTC
Created attachment 171564 [details]
log fil of the build

Added the build.log file
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-12 17:39:29 UTC
Do you happen to have sys-devel/bison-2.4 installed?
Comment 3 Jürgen Geuter 2008-11-12 17:40:40 UTC
Yes, I have bison-2.4
Comment 4 Ahmed Ammar (RETIRED) gentoo-dev 2008-11-13 09:15:59 UTC
(In reply to comment #3)
> Yes, I have bison-2.4

Seems to be a bison-2.4 issue, with bison-2.3 you get past the above issue.
Comment 5 Sudrien 2008-11-14 05:07:17 UTC
workaround works for me
Comment 6 Jürgen Geuter 2008-11-17 15:58:20 UTC
Masking bison-2.4 worked for me, too. The ebuild should probably depend on <=bison-2.3
Comment 7 Neil Cathey 2008-11-22 00:29:43 UTC
Here's a link to upstream's bug report:

https://bugs.webkit.org/show_bug.cgi?id=22205

However, there's currently no fix.
Comment 8 Neil Cathey 2008-12-10 02:50:29 UTC
There is now a patch on WebKit's Bugzilla:

https://bugs.webkit.org/attachment.cgi?id=25831&action=view

I tried the patch and WebKit compiled for me with bison-2.4-r1, though I haven't actually made sure it runs.
Comment 9 Mr. B 2008-12-28 20:14:01 UTC
(In reply to comment #8)
> There is now a patch on WebKit's Bugzilla:
> 
> https://bugs.webkit.org/attachment.cgi?id=25831&action=view
> 
> I tried the patch and WebKit compiled for me with bison-2.4-r1, though I
> haven't actually made sure it runs.
> 

I can confirm that this works, seemingly without any adverse effects.
Comment 10 Ravi Pinjala 2009-01-04 00:53:39 UTC
The patch from Webkit's bugzilla works fine for me as well; all I had to do was epatch it in the ebuild, no other changes necessary.
Comment 11 Alexandre Ghisoli 2009-01-05 21:24:26 UTC
(In reply to comment #8)
> There is now a patch on WebKit's Bugzilla:
> 
> https://bugs.webkit.org/attachment.cgi?id=25831&action=view
> 
> I tried the patch and WebKit compiled for me with bison-2.4-r1, though I
> haven't actually made sure it runs.
> 

Confirmed working. Thanks !
Comment 12 Nikolay Engyozov 2009-01-11 10:53:42 UTC
works for me too
Comment 13 renato gallo 2009-01-11 21:26:34 UTC
Created attachment 178121 [details]
like this it works like a charm

working ebuild with the patch we are talking about
Comment 14 renato gallo 2009-01-11 21:40:56 UTC
to use my ebuild:
1) copy it into the corresponding portage dir
2) mkdir files into that very same portage dir
3) cd into files and wget the patch at the link 
   https://bugs.webkit.org/attachment.cgi?id=25831&action=view
4) cd .. 
5) ebuild digest my ebuild
Comment 15 Auke Booij (tulcod) 2009-01-16 19:55:24 UTC
so is this going into the tree anytime soon?
Comment 16 renato gallo 2009-01-16 21:53:37 UTC
since it is the first one I do I hope so :D

(In reply to comment #15)
> so is this going into the tree anytime soon?
> 

Comment 17 Markus Ullmann (RETIRED) gentoo-dev 2009-01-25 19:04:56 UTC
okay, gnome team promised to do housekeeping until I'm back but seems they didn't. Pushed latest nightly to portage now. Do folks want to have this version "Fixed" as well or just go ahead to rev 40220?
Comment 18 Peter Alfredsen (RETIRED) gentoo-dev 2009-01-26 01:44:43 UTC
*** Bug 256372 has been marked as a duplicate of this bug. ***
Comment 19 Paul Hartman 2009-01-26 02:58:22 UTC
latest version in portage works for me, bison-2.4.1 and webkit-gtk-0_p40220 compiled happily. ~amd64
Comment 20 Peter Alfredsen (RETIRED) gentoo-dev 2009-01-26 11:42:58 UTC
*** Bug 256402 has been marked as a duplicate of this bug. ***
Comment 21 Sergiy Borodych 2009-01-28 13:13:53 UTC
for me bison-2.4.1 and webkit-gtk-0_p40220 compiled fine too (on ~amd64)