Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 245537

Summary: x11-drivers/xf86-video-virtualbox-{1.6.6,2.0.4} fails to build with gcc 4.3
Product: Gentoo Linux Reporter: fturtle
Component: [OLD] GCC PortingAssignee: Markus Ullmann (RETIRED) <jokey>
Severity: normal CC: hwoarang, swapon
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 198121    
Attachments: emerge --info

Description fturtle 2008-11-04 15:42:58 UTC
Both versions of virtualbox video driver for xf86 fail with the same error

Reproducible: Always

Steps to Reproduce:
1.use GCC-4.3 and glibc-2.7

Actual Results:  
 ** There are known problems with gcc version 4.3 when compiling the recompiler
  ** stuff. You need to specify a compatibility compiler with version < 4.3. Look
  ** for a package compat-gcc-34 on Fedora systems or something similar on other
  ** distributions and call configure with parameter --with-gcc-compat=gcc34.

Expected Results:  
successful build
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-04 20:24:55 UTC
Please post your `emerge --info' in a comment and attach the full build log to this bug report.
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2008-12-20 19:40:10 UTC
Created attachment 175995 [details]
emerge --info

I am reopening this bug as I have the same problem. 

emerge --info is attached
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2008-12-20 19:41:13 UTC
As explained before i am having the same  issue with all xf86-input-virtualbox

Please let me know if you need more information
Comment 4 Wormo (RETIRED) gentoo-dev 2008-12-20 21:12:21 UTC
This is a known problem with the upstream project, hence the nice informative error message displayed. They are working on gcc 4.3 support, but until it is finished how about just using a stable gcc 4.2 toolchain? The upgrade to gcc 4.3 breaks a fair amount of existing code (see gcc 4.3 porting, bug 198121 ...) so it is handy to have a gcc 4.2 toolchain available that you can switch to for packages where maintainers and upstream projects are still working on gcc 4.3 support.
Comment 5 Alessio Cassibba (X-Drum) 2008-12-25 21:06:39 UTC
(In reply to comment #0)
> Both versions of virtualbox video driver for xf86 fail with the same error

as said in comment #4 by wormo this is a known issue,
upstream doesn't support gcc-4.3 at this time, so there is
no known solution to this issue.

On a side note, on Dec 17, 2008 virtualbox 2.1.0
was released, gcc-4.3.x is *still not supported* but i was
able to build it (bug #251335 comment #34).

You can try this release, ebuilds are currently on jokey's overlay[1]

Comment 6 Markus Ullmann (RETIRED) gentoo-dev 2009-03-11 08:58:15 UTC
Upstream feature, thanks for the report though