Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 245198

Summary: Please stabilise media-gfx/kphotoalbum-3.1.1-r1
Product: Gentoo Linux Reporter: Christian Faulhammer (RETIRED) <fauli>
Component: New packagesAssignee: Ioannis Aslanidis (RETIRED) <deathwing00>
Status: RESOLVED FIXED    
Severity: enhancement CC: jkt, kde
Priority: High Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 245160    
Attachments: backtrace.log

Description Christian Faulhammer (RETIRED) gentoo-dev 2008-11-01 20:55:47 UTC
This is for GCC 4.3 stabilisation.  Please add arches as you see fit. Thanks.
Comment 1 Jan Kundrát (RETIRED) gentoo-dev 2008-11-01 21:14:36 UTC
*** Bug 239286 has been marked as a duplicate of this bug. ***
Comment 2 Jan Kundrát (RETIRED) gentoo-dev 2008-11-01 21:15:35 UTC
From the original bug report:

Hi, it's been in tree for half a year, no bugs in Gentoo Bugzilla, and last
upstream release for KDE3/Qt3 ever (I'm part of them, so I know very well :) ).

Ioannis, please CC arches (amd64, ppc, sparc, x86) if you're ok with going
stable.
Comment 3 Ioannis Aslanidis (RETIRED) gentoo-dev 2008-11-02 00:43:02 UTC
Arches, please proceed as requested.
Comment 4 Thomas Anderson (tanderson) (RETIRED) gentoo-dev 2008-11-04 19:34:06 UTC
RepoMan scours the neighborhood...
  ebuild.patches                2
   media-gfx/kphotoalbum/kphotoalbum-3.1.0.ebuild: PATCHES is not a bash array on line: 34
   media-gfx/kphotoalbum/kphotoalbum-3.1.1-r1.ebuild: PATCHES is not a bash array on line: 29


Other than that, good to go for amd64
Comment 5 nixnut (RETIRED) gentoo-dev 2008-11-08 13:49:28 UTC
ppc stable 
Comment 6 Markus Meier gentoo-dev 2008-11-08 14:21:20 UTC
amd64/x86 stable
Comment 7 Tiago Cunha (RETIRED) gentoo-dev 2008-12-02 23:12:02 UTC
Created attachment 174115 [details]
backtrace.log

I'm getting lots of "setmntent: No such file or directory" when using the application, and a Segmentation fault when adding a new category (Settings->Configure KPhotoAlbum->Categories->New->"Test"->OK->OK).

Backtrace generated with USE="debug" FEATURES="nostrip" CXXFLAGS="-O1 -pipe -g -ggdb".

Portage 2.1.4.5 (default/linux/sparc/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r2 sparc64)
=================================================================
System uname: 2.6.26-gentoo-r2 sparc64 sun4u
Timestamp of tree: Wed, 26 Nov 2008 12:22:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-mcpu=ultrasparc -O2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/pam.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mcpu=ultrasparc -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.dei.uc.pt/pub/linux/gentoo http://cesium.di.uminho.pt/pub/gentoo ftp://ftp.rnl.ist.utl.pt/pub/gentoo http://darkstar.ist.utl.pt/pub/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X alsa bash-completion bindist bluetooth branding bzip2 cairo cdr cli cracklib crypt dbus dri dvd dvdr dvdread emboss encode evo fam firefox fortran gcc64 gif gnome gstreamer gtk hal iconv ipv6 isdnlog jpeg kde libnotify mad midi mikmod mp3 mpeg mudflap ncurses nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session sparc spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vim-syntax vorbis xml xorg xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="mach64 sunffb"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Ioannis Aslanidis (RETIRED) gentoo-dev 2008-12-03 09:10:41 UTC
(In reply to comment #7)
> Created an attachment (id=174115) [edit]
> backtrace.log
> 
> I'm getting lots of "setmntent: No such file or directory" when using the
> application, and a Segmentation fault when adding a new category
> (Settings->Configure KPhotoAlbum->Categories->New->"Test"->OK->OK).
> 
> Backtrace generated with USE="debug" FEATURES="nostrip" CXXFLAGS="-O1 -pipe -g
> -ggdb".
> 
> Portage 2.1.4.5 (default/linux/sparc/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0,

And you are using gcc 4.1.2 instead of gcc 4.3.
Comment 9 Tiago Cunha (RETIRED) gentoo-dev 2008-12-06 15:12:12 UTC
> And you are using gcc 4.1.2 instead of gcc 4.3.

My bad. However, I'm still getting the same results.

Portage 2.1.4.5 (default/linux/sparc/2008.0/desktop, gcc-4.3.2, glibc-2.6.1-r0, 2.6.26-gentoo-r2 sparc64)
=================================================================
System uname: 2.6.26-gentoo-r2 sparc64 sun4u
Timestamp of tree: Wed, 03 Dec 2008 11:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-mcpu=ultrasparc -O2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/pam.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mcpu=ultrasparc -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-akv --with-bdeps y"
FEATURES="ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.dei.uc.pt/pub/linux/gentoo http://cesium.di.uminho.pt/pub/gentoo ftp://ftp.rnl.ist.utl.pt/pub/gentoo http://darkstar.ist.utl.pt/pub/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X alsa bash-completion bindist bluetooth branding bzip2 cairo cdr cli cracklib crypt dbus dri dvd dvdr dvdread emboss encode evo fam firefox fortran gcc64 gif gnome gstreamer gtk hal iconv ipv6 isdnlog jpeg kde libnotify mad midi mikmod mp3 mpeg mudflap ncurses nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session sparc spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vim-syntax vorbis xml xorg xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="mach64 sunffb"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 10 Jan Kundrát (RETIRED) gentoo-dev 2008-12-08 14:31:11 UTC
Hi Tiago, thanks for a bugreport. First of all, the 3.1.1 is the last release of KPA based on Qt3/KDE4. Plenty of changes went to the trunk since we ported the app to kde4/qt4 (which wasn't released yet). Mainly due to some re-organisation of this dialog, this bug is not an issue anymore.

In addition, this isn't a regression from 3.1.0, so I think you can proceed with stabling. Thanks for the report again.
Comment 11 Tiago Cunha (RETIRED) gentoo-dev 2008-12-08 19:39:07 UTC
(In reply to comment #10)
> Hi Tiago, thanks for a bugreport. First of all, the 3.1.1 is the last release
> of KPA based on Qt3/KDE4. Plenty of changes went to the trunk since we ported
> the app to kde4/qt4 (which wasn't released yet). Mainly due to some
> re-organisation of this dialog, this bug is not an issue anymore.
> 
> In addition, this isn't a regression from 3.1.0, so I think you can proceed
> with stabling. Thanks for the report again.

Ok. SPARC stable. Closing since we're last.