Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 241578

Summary: media-sound/cowbell-0.2.7.1 fails eautoreconf with libtool 2.2
Product: Gentoo Linux Reporter: larstobi <larstobi>
Component: New packagesAssignee: Gentoo Sound Team <sound>
Status: RESOLVED FIXED    
Severity: normal CC: flameeyes
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    
Attachments: Adds AC_PROG_CXX to configure.in
Patch the ebuild to use the configure.in patch

Description larstobi 2008-10-12 12:15:41 UTC
=media-sound/cowbell-0.2.7.1 fails to build, bails out at automake with "am__fastdepCXX does not appear in AM_CONDITIONAL"

Reproducible: Always

Steps to Reproduce:
1.emerge =media-sound/cowbell-0.2.7.1
2.It fails.

Actual Results:  
# emerge --nodeps cowbell

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-sound/cowbell-0.2.7.1
 * cowbell-0.2.7.1.tar.gz RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * checking ebuild checksums ;-) ...                                        [ ok ]
 * checking auxfile checksums ;-) ...                                       [ ok ]
 * checking miscfile checksums ;-) ...                                      [ ok ]
>>> Unpacking source...
>>> Unpacking cowbell-0.2.7.1.tar.gz to /var/tmp/portage/media-sound/cowbell-0.2.7.1/work
 * Fixing OMF Makefiles ...                                                  [ ok ]
 * Running elibtoolize in: cowbell-0.2.7.1
 * Applying install-sh-1.5.4.patch ...
 * Applying portage-1.5.10.patch ...
 * Applying max_cmd_len-1.5.20.patch ...
 * Applying sed-1.5.6.patch ...
 * Running eautoreconf in '/var/tmp/portage/media-sound/cowbell-0.2.7.1/work/cowbell-0.2.7.1' ...
 * Running aclocal ...                                                       [ ok ]
 * Running libtoolize --copy --force --install --automake ...                [ ok ]
 * Running aclocal ...                                                       [ ok ]
 * Running autoconf ...                                                      [ ok ]
 * Running automake --add-missing --copy ...                                 [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 * /var/tmp/portage/media-sound/cowbell-0.2.7.1/temp/automake-96623.out

 * 
 * ERROR: media-sound/cowbell-0.2.7.1 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 2835:  Called eautoreconf
 * environment, line  905:  Called eautomake
 * environment, line  879:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 * environment, line  387:  Called die
 * The specific snippet of code:
 * die "Failed Running $1 !";
 * The die message:
 * Failed Running automake !
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/media-sound:cowbell-0.2.7.1:20081012-121053.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/cowbell-0.2.7.1/temp/environment'.
 * 

>>> Failed to emerge media-sound/cowbell-0.2.7.1, Log file:

>>>  '/var/log/portage/media-sound:cowbell-0.2.7.1:20081012-121053.log'

 * GNU info directory index is up-to-date.


Expected Results:  
Build without error.

# emerge --info
Portage 2.2_rc11 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-x86_64-AMD_Athlon-tm-_64_FX-74_Processor-with-glibc2.2.5
Timestamp of tree: Thu, 09 Oct 2008 17:06:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -msse3 -pipe -fomit-frame-pointer -fexpensive-optimizations -falign-functions=64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 larstobi 2008-10-12 12:17:58 UTC
Created attachment 168160 [details, diff]
Adds AC_PROG_CXX to configure.in
Comment 2 larstobi 2008-10-12 12:18:46 UTC
Created attachment 168162 [details, diff]
Patch the ebuild to use the configure.in patch
Comment 3 Samuli Suominen gentoo-dev 2008-12-19 19:51:48 UTC
Using commit message:
------------------------------------------------------------------------------
Add GCONF_DEBUG=no because the pkg doesn't support --enable/--disable-debug configure option. Add AC_PROG_CXX for libtool-2.2 wrt #241578, thanks to <larstobi at snota.no>. Run intltoolize because otherwise it won't build or install them at all.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27.7 i686)
------------------------------------------------------------------------------
Comment 4 Samuli Suominen gentoo-dev 2008-12-19 20:15:25 UTC
Patch sent to upstream (e-mail used in AUTHORS file)