Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 240816

Summary: media-libs/libnut: C(XX)FLAGS are ignored (at src_configure/compile)
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: Current packagesAssignee: media-video herd <media-video>
Status: RESOLVED OBSOLETE    
Severity: normal CC: treecleaner
Priority: High Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Deadline: 2019-10-07   

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-09 21:28:30 UTC
I don't know the build system for this program (and this is a generic bug template so I cannot tell you which program exactly is), but my tests shows that it's not respecting CFLAGS (or CXXFLAGS) properly.

Please look into it, since it's important to respect user CFLAGS and CXXFLAGS.

Warning: this bug might look like a false positive because you actually have your CFLAGS being used; this happens if the CFLAGS are "set in stone" in the build system during src_unpack/src_prepare. While QA has not as of this moment expressed to me a preference, I'd sincerely suggest to avoid the set-in-stone approach, so that ebuild commands could work to reproduce the actual results.

To avoid the set in stone approach:

- consider just changing CFLAGS= to CFLAGS+= if the build system enables warnings;
- if the buildsystem does not use CFLAGS variable at all, in the sed use '$(CFLAGS)', single quoted, so that the CFLAGS variable is picked up;
- use '$(OPTCFLAGS)' in the sed and then use make OPTCFLAGS=$CFLAGS.

Thanks,
Diego
Comment 1 Pacho Ramos gentoo-dev 2016-02-26 11:00:45 UTC
is this still the case with 2016.02.09?
Comment 2 Pacho Ramos gentoo-dev 2016-02-26 11:00:57 UTC
bleh, wrong tab
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-07 08:09:57 UTC
Removing.