Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 240406

Summary: media-gfx/picasa-3 - ebuild request
Product: Gentoo Linux Reporter: nusch <nusch88>
Component: New packagesAssignee: Stefan Schweizer (RETIRED) <genstef>
Severity: enhancement CC: andreas, caster, ckdake, gent_bz, m27315, vladimir
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: picasa 3 ebuild, alpha
updated picasa 3 alpha ebuild
diff between the original and updated ebuilds
picasa-3 beta ebuild
... and a diff
picasa-3 beta ebuild
... and a diff

Description nusch 2008-10-07 17:59:34 UTC
There is a new version - Picasa 3.0 for linux, with a lot of new features like face recognition etc

Reproducible: Always
Comment 1 Simonas Leleiva 2008-10-08 15:05:22 UTC
Created attachment 167616 [details]
picasa 3 ebuild, alpha

Here's something working, which I've produced real-quick.

Still, sed curses about some errors around, hope will give you a head start
Comment 2 Rolandas Valteris 2008-10-08 23:04:40 UTC
Created attachment 167670 [details]
updated picasa 3 alpha ebuild
Comment 3 Rolandas Valteris 2008-10-08 23:10:21 UTC
Created attachment 167676 [details, diff]
diff between the original and updated ebuilds

made some simple updates for sed errors. i'm new to gentoo bugzilla and not sure what's the correct course of action so i've attached both updated ebuild and the diff.

note on the ebuild: i'm not sure that domenu is a correct call on picasa-kdehal.desktop file.
Comment 4 Vladimir Rusinov 2008-11-04 20:54:30 UTC
>>> Downloading ''
--2008-11-04 23:53:43--
Resolving,,, ...
Connecting to||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-11-04 23:53:43 ERROR 404: Not Found.

!!! Couldn't download 'picasa-3.0.5719-02.i386.rpm'. Aborting.
!!! File picasa-3.0.5719-02.i386.rpm doesn't exist, can't update Manifest

Comment 5 Rolandas Valteris 2008-11-05 18:04:28 UTC
Created attachment 170827 [details]
picasa-3 beta ebuild

google renamed picasa rpm into picasa-3.0-current.i386.rpm. they dropped build number altogether. hence the download error above. attached beta ebuild fixes this.

TODO: add nsplugin use flag and install plugin for firefox when it's set.
Comment 6 Rolandas Valteris 2008-11-05 18:09:56 UTC
Created attachment 170828 [details]
... and a diff
Comment 7 Rolandas Valteris 2008-11-06 06:24:20 UTC
Created attachment 170882 [details]
picasa-3 beta ebuild

added nsplugin support
Comment 8 Rolandas Valteris 2008-11-06 06:28:24 UTC
Created attachment 170884 [details, diff]
... and a diff
Comment 9 Trevor Bowen 2008-12-10 18:27:06 UTC
The new 3.0 ebuild worked for me.  I did have to pull in unstable versions of various dependencies:

echo 'media-gfx/picasa ~amd64' >> /etc/portage/package.keywords 
echo 'net-libs/xulrunner ~amd64' >> /etc/portage/package.keywords 
echo 'dev-libs/nspr ~amd64' >> /etc/portage/package.keywords 
echo 'dev-libs/nss ~amd64' >> /etc/portage/package.keywords 

But, otherwise it worked great!

Any chance of this moving into stable?  I guess it is waiting on the other deps to move to stable first?
Comment 10 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2009-02-08 01:50:47 UTC
Bumped in tree, thanks all.